[PATCH 0/4] Update Ren'py to 8.1.0

  • Done
  • quality assurance status badge
Details
3 participants
  • ???
  • jgart
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 19 May 2023 12:44
(address . guix-patches@gnu.org)
cover.1684493082.git.liliana.prikler@gmail.com
Hi Guix,

this series updates Ren'py to 8.1.0 and also introduces G-Expressions
everywhere.

Cheers

Liliana Marie Prikler (4):
gnu: python-pygame-sdl2: Update to 2.1.0-for-renpy-8.1.0.
gnu: python-pygame-sdl2: Use G-Expressions.
gnu: python-renpy: Update to 8.1.0.
gnu: python-renpy: Use G-Expressions.

gnu/packages/game-development.scm | 159 +++++++++++++++---------------
1 file changed, 82 insertions(+), 77 deletions(-)


base-commit: 5b700945fb0b33eec410de8979cae2fbf0d4f118
--
2.40.1
L
L
Liliana Marie Prikler wrote on 19 May 2023 12:13
[PATCH 2/4] gnu: python-pygame-sdl2: Use G-Expressions.
(address . 63582@debbugs.gnu.org)
8996533df8588efeae94692f14079a22c0f1e426.1684493082.git.liliana.prikler@gmail.com
* gnu/packages/game-development.scm (python-pygame-sdl2)[arguments]: Convert
to list of G-Expressions.
---
gnu/packages/game-development.scm | 32 +++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 0f12d18b27..5b3faceb89 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1298,22 +1298,22 @@ (define-public python-pygame-sdl2
(delete-file-recursively "gen-static")))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; tests require pygame to be installed first
- #:phases
- (modify-phases %standard-phases
- (add-after 'set-paths 'set-sdl-vars
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "PYGAME_SDL2_CFLAGS"
- (string-append "-I"
- (assoc-ref inputs "sdl-union")
- "/include/SDL2 -D_REENTRANT"))
- (setenv "PYGAME_SDL2_LDFLAGS"
- (string-append "-L"
- (assoc-ref inputs "sdl-union")
- "/lib -Wl,-rpath,"
- (assoc-ref inputs "sdl-union")
- "/lib -Wl,--enable-new-dtags -lSDL2"))
- #t)))))
+ (list
+ #:tests? #f ; tests require pygame to be installed first
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'set-paths 'set-sdl-vars
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "PYGAME_SDL2_CFLAGS"
+ (string-append "-I"
+ (assoc-ref inputs "sdl-union")
+ "/include/SDL2 -D_REENTRANT"))
+ (setenv "PYGAME_SDL2_LDFLAGS"
+ (string-append "-L"
+ (assoc-ref inputs "sdl-union")
+ "/lib -Wl,-rpath,"
+ (assoc-ref inputs "sdl-union")
+ "/lib -Wl,--enable-new-dtags -lSDL2")))))))
(inputs
(list (sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf))))
(native-inputs
--
2.40.1
L
L
Liliana Marie Prikler wrote on 19 May 2023 11:01
[PATCH 1/4] gnu: python-pygame-sdl2: Update to 2.1.0-for-renpy-8.1.0.
(address . 63582@debbugs.gnu.org)
12680874cca4063314cde128da3b8aa367b18f9b.1684493082.git.liliana.prikler@gmail.com
* gnu/packages/game-development.scm (python-pygame-sdl2): Update to
2.1.0-for-renpy-8.1.0.
---
gnu/packages/game-development.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 66f23819fc..0f12d18b27 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1278,7 +1278,7 @@ (define-public python-pygame
(define-public python-pygame-sdl2
(let ((real-version "2.1.0")
- (renpy-version "8.0.3"))
+ (renpy-version "8.1.0"))
(package
(inherit python-pygame)
(name "python-pygame-sdl2")
@@ -1288,7 +1288,7 @@ (define-public python-pygame-sdl2
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" renpy-version
"/pygame_sdl2-" version ".tar.gz"))
- (sha256 (base32 "1nq78mybkvshshdjy5bly6nfq6dnwll648ng62fwmksxpni17486"))
+ (sha256 (base32 "1qj39jqnv334p4wnxc2v5qxyahp7nkqf9hpdd2sgqcmgaqwnqqmj"))
(modules '((guix build utils)))
(snippet
'(begin
--
2.40.1
L
L
Liliana Marie Prikler wrote on 19 May 2023 11:55
[PATCH 3/4] gnu: python-renpy: Update to 8.1.0.
(address . 63582@debbugs.gnu.org)
93dd15946900b1bddf1aabd02939459a452e4920.1684493082.git.liliana.prikler@gmail.com
* gnu/packages/game-development.scm (python-renpy): Update to 8.1.0.
[source]: No longer unbundle fribidi.
Drop sync service and report as official version.
[arguments]<#:phases>: Drop ‘fix-include-paths’.
[propagated-inputs]: Add python-ecdsa.
---
gnu/packages/game-development.scm | 40 +++++++++++++++++--------------
1 file changed, 22 insertions(+), 18 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5b3faceb89..96a7a52b62 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -99,6 +99,7 @@ (define-module (gnu packages game-development)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
@@ -1329,25 +1330,33 @@ (define-public python-pygame-sdl2
(define-public python-renpy
(package
(name "python-renpy")
- (version "8.0.3")
+ (version "8.1.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.renpy.org/dl/" version
"/renpy-" version "-source.tar.bz2"))
- (sha256 (base32 "1b49y60pi6304fg06lw5gajzrgg9w80swpfkn6pw0lxbr6djgjgn"))
+ (sha256
+ (base32
+ "08l7z2vwqxkskj3rs2a0w9ahah28ixq8hy48h30k2dm9g19h450h"))
(modules '((guix build utils)))
- (patches
- (search-patches
- "renpy-use-system-fribidi.patch"))
(snippet
- '(with-directory-excursion "module"
- ;; drop fribidi sources
- (delete-file-recursively "fribidi-src")
- ;; drop _renpytfd, as there are missing sources
- (substitute* "setup.py"
- (("cython\\(\"_renpytfd\"" all)
- (string-append "pass # " all)))))))
+ #~(begin
+ ;; Build without sync service.
+ ;; Encryption is only used for enabling this service and requires
+ ;; libhydrogen, which doesn't have a public release, so drop it
+ ;; as well
+ (for-each delete-file
+ '("renpy/encryption.pyx"
+ "renpy/common/00sync.rpy"))
+ (substitute* "module/setup.py"
+ (("cython\\(\"renpy\\.encryption\"\\)") ""))
+ (substitute* "renpy/__init__.py"
+ (("import renpy\\.encryption") ""))
+ ;; Trust vc_version.py when it comes to detecting whether a
+ ;; version is official.
+ (substitute* "renpy/__init__.py"
+ (("official = official and .*") ""))))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; Ren'py doesn't seem to package tests
@@ -1359,11 +1368,6 @@ (define-public python-renpy
(("xdg-open")
(string-append (assoc-ref inputs "xdg-utils")
"/bin/xdg-open")))))
- (add-after 'unpack 'fix-include-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "module/setup.py"
- (("/usr/include/fribidi")
- (search-input-directory inputs "include/fribidi")))))
(add-after 'set-paths 'set-build-vars
(lambda* (#:key inputs native-inputs #:allow-other-keys)
(setenv "RENPY_CYTHON"
@@ -1405,7 +1409,7 @@ (define-public python-renpy
libpng
(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf))
xdg-utils))
- (propagated-inputs (list python-future python-pygame-sdl2))
+ (propagated-inputs (list python-ecdsa python-future python-pygame-sdl2))
(home-page "https://www.renpy.org/")
(synopsis "Ren'py python module")
(description "This package contains the shared libraries and Python modules
--
2.40.1
L
L
Liliana Marie Prikler wrote on 19 May 2023 12:14
[PATCH 4/4] gnu: python-renpy: Use G-Expressions.
(address . 63582@debbugs.gnu.org)
8fac5ba5bd77bae12c9411c28f1ee03099ccb28f.1684493082.git.liliana.prikler@gmail.com
* gnu/packages/game-development.scm (python-renpy)[arguments]: Convert to
list of G-Expressions.
---
gnu/packages/game-development.scm | 83 ++++++++++++++++---------------
1 file changed, 42 insertions(+), 41 deletions(-)

Toggle diff (96 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 96a7a52b62..453196d3af 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1359,47 +1359,48 @@ (define-public python-renpy
(("official = official and .*") ""))))))
(build-system python-build-system)
(arguments
- `(#:tests? #f ; Ren'py doesn't seem to package tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-commands
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "renpy/editor.py"
- (("xdg-open")
- (string-append (assoc-ref inputs "xdg-utils")
- "/bin/xdg-open")))))
- (add-after 'set-paths 'set-build-vars
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (setenv "RENPY_CYTHON"
- (search-input-file (or native-inputs inputs)
- "/bin/cython"))
- (setenv "RENPY_DEPS_INSTALL" (string-join (map cdr inputs) ":"))))
- (replace 'build
- (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
- ;; The "module" subdirectory contains a python (really cython)
- ;; project, which is built using a script, that is thankfully
- ;; named "setup.py".
- (with-directory-excursion "module"
- (apply (assoc-ref %standard-phases 'build) args))
- ;; The above only builds the cython modules, but nothing else,
- ;; so we do that here.
- (invoke "python" "-m" "compileall" "renpy")))
- (replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
- ;; Again, we have to wrap the module installation.
- ;; Additionally, we want to install the python code
- ;; (both source and compiled) in the same directory.
- (let* ((out (assoc-ref outputs "out"))
- (site (string-append "/lib/python"
- (python-version
- (assoc-ref inputs "python"))
- "/site-packages")))
- (with-directory-excursion "module"
- (apply (assoc-ref %standard-phases 'install) args))
- (copy-recursively "renpy"
- (string-append out site "/renpy"))
- (delete-file-recursively (string-append out site
- "/renpy/common"))))))))
+ (list
+ #:tests? #f ; Ren'py doesn't seem to package tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-commands
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "renpy/editor.py"
+ (("xdg-open")
+ (string-append (assoc-ref inputs "xdg-utils")
+ "/bin/xdg-open")))))
+ (add-after 'set-paths 'set-build-vars
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (setenv "RENPY_CYTHON"
+ (search-input-file (or native-inputs inputs)
+ "/bin/cython"))
+ (setenv "RENPY_DEPS_INSTALL" (string-join (map cdr inputs) ":"))))
+ (replace 'build
+ (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+ ;; The "module" subdirectory contains a python (really cython)
+ ;; project, which is built using a script, that is thankfully
+ ;; named "setup.py".
+ (with-directory-excursion "module"
+ (apply (assoc-ref %standard-phases 'build) args))
+ ;; The above only builds the cython modules, but nothing else,
+ ;; so we do that here.
+ (invoke "python" "-m" "compileall" "renpy")))
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+ ;; Again, we have to wrap the module installation.
+ ;; Additionally, we want to install the python code
+ ;; (both source and compiled) in the same directory.
+ (let* ((out (assoc-ref outputs "out"))
+ (site (string-append "/lib/python"
+ (python-version
+ (assoc-ref inputs "python"))
+ "/site-packages")))
+ (with-directory-excursion "module"
+ (apply (assoc-ref %standard-phases 'install) args))
+ (copy-recursively "renpy"
+ (string-append out site "/renpy"))
+ (delete-file-recursively (string-append out site
+ "/renpy/common"))))))))
(native-inputs (list python-cython))
(inputs
(list ffmpeg
--
2.40.1
?
Re: [bug#63582] [PATCH 0/4] Update Ren'py to 8.1.0
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 63582@debbugs.gnu.org)
874jo831c4.fsf@envs.net
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (13 lines)
> Hi Guix,
>
> this series updates Ren'py to 8.1.0 and also introduces G-Expressions
> everywhere.
>
> Cheers
>
> Liliana Marie Prikler (4):
> gnu: python-pygame-sdl2: Update to 2.1.0-for-renpy-8.1.0.
> gnu: python-pygame-sdl2: Use G-Expressions.
> gnu: python-renpy: Update to 8.1.0.
> gnu: python-renpy: Use G-Expressions.

Looks good to me, thank you!
J
(address . 63582@debbugs.gnu.org)
cc9e0d559452c5a6943909c24795e09f@dismail.de
LGTM!
L
L
Liliana Marie Prikler wrote on 28 May 2023 23:16
(address . 63582-done@debbugs.gnu.org)
1443ea4b6cef6093abe876cdb813927ab97153c6.camel@gmail.com
Am Freitag, dem 19.05.2023 um 12:14 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (4 lines)
> * gnu/packages/game-development.scm (python-renpy)[arguments]:
> Convert to
> list of G-Expressions.
> ---
Pushed.
Closed
?