[PATCH 0/2] Update emacs-next to 29.0.91

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 18 May 2023 12:39
(address . guix-patches@gnu.org)
cover.1684406365.git.liliana.prikler@gmail.com
Hi Guix,

this series updates emacs-next to 29.0.91 and also rebases
emacs-next-tree-sitter on top of it. After going through with this
change, I think we in the Emacs team ought to start making preparations
for the release of 29.1, including all the build-system fixes etc.
we plan for this cycle.

Cheers

Liliana Marie Prikler (2):
gnu: emacs-next: Update to 29.0.91.
gnu: emacs-next-tree-sitter: "Downgrade" to 29.0.91.

gnu/packages/emacs.scm | 34 ++++++++++------------------------
1 file changed, 10 insertions(+), 24 deletions(-)


base-commit: 5b700945fb0b33eec410de8979cae2fbf0d4f118
--
2.40.1
L
L
Liliana Marie Prikler wrote on 18 May 2023 12:37
[PATCH 2/2] gnu: emacs-next-tree-sitter: "Downgrade" to 29.0.91.
(address . 63568@debbugs.gnu.org)
0a4c2da5d3755521710031f094936794a584dc9d.1684406365.git.liliana.prikler@gmail.com
* gnu/packages/emacs.scm (emacs-next-tree-sitter)[version, source]: Inherit
fields from emacs-next.
---
gnu/packages/emacs.scm | 30 ++++++++----------------------
1 file changed, 8 insertions(+), 22 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 31009ac4d9..7831a24922 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -418,28 +418,14 @@ (define-public emacs-next
(prepend autoconf)))))
(define-public emacs-next-tree-sitter
- (let ((commit "ac7ec87a7a0db887e4ae7fe9005aea517958b778")
- (revision "0"))
- (package
- (inherit emacs-next)
- (name "emacs-next-tree-sitter")
- (version (git-version "30.0.50" revision commit))
- (source
- (origin
- (inherit (package-source emacs-next))
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/git/emacs.git/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1akq6dbllwwqwx21wnwnv6aax1nsi2ypbd7j3i79sw62s3gf399z"))))
- (inputs
- (modify-inputs (package-inputs emacs-next)
- (prepend sqlite tree-sitter)))
- (synopsis "Emacs text editor with @code{tree-sitter} support")
- (description "This Emacs build supports tree-sitter."))))
+ (package
+ (inherit emacs-next)
+ (name "emacs-next-tree-sitter")
+ (inputs
+ (modify-inputs (package-inputs emacs-next)
+ (prepend sqlite tree-sitter)))
+ (synopsis "Emacs text editor with @code{tree-sitter} support")
+ (description "This Emacs build supports tree-sitter.")))
(define-public emacs-next-pgtk
(package
--
2.40.1
L
L
Liliana Marie Prikler wrote on 18 May 2023 12:06
[PATCH 1/2] gnu: emacs-next: Update to 29.0.91.
(address . 63568@debbugs.gnu.org)
028dba13c867bd3e32552b4e1ba61b9adf46338a.1684406365.git.liliana.prikler@gmail.com
* gnu/packages/emacs.scm (emacs-next): Update to 29.0.91.
---
gnu/packages/emacs.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index abd62af75a..31009ac4d9 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -394,7 +394,7 @@ (define-public emacs-next
(package
(inherit emacs)
(name "emacs-next")
- (version "29.0.90")
+ (version "29.0.91")
(source
(origin
(inherit (package-source emacs))
@@ -409,7 +409,7 @@ (define-public emacs-next
"emacs-native-comp-driver-options.patch"))
(sha256
(base32
- "1lmw3fa6c5w5d6cvk8vdqvqn67hm5lcxy9xykmvcgx258vs7x975"))))
+ "09jm1q5pvd1dc0xq5rhn66v1j235zlr72kwv5i27xigvi9nfqkv1"))))
(inputs
(modify-inputs (package-inputs emacs)
(prepend sqlite)))
--
2.40.1
A
A
Andrew Tropin wrote on 20 May 2023 09:44
Re: [bug#63568] [PATCH 2/2] gnu: emacs-next-tree-sitter: "Downgrade" to 29.0.91.
87a5xzzbt9.fsf@trop.in
On 2023-05-18 12:37, Liliana Marie Prikler wrote:

Toggle quote (48 lines)
> * gnu/packages/emacs.scm (emacs-next-tree-sitter)[version, source]: Inherit
> fields from emacs-next.
> ---
> gnu/packages/emacs.scm | 30 ++++++++----------------------
> 1 file changed, 8 insertions(+), 22 deletions(-)
>
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 31009ac4d9..7831a24922 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -418,28 +418,14 @@ (define-public emacs-next
> (prepend autoconf)))))
>
> (define-public emacs-next-tree-sitter
> - (let ((commit "ac7ec87a7a0db887e4ae7fe9005aea517958b778")
> - (revision "0"))
> - (package
> - (inherit emacs-next)
> - (name "emacs-next-tree-sitter")
> - (version (git-version "30.0.50" revision commit))
> - (source
> - (origin
> - (inherit (package-source emacs-next))
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://git.savannah.gnu.org/git/emacs.git/")
> - (commit commit)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32
> - "1akq6dbllwwqwx21wnwnv6aax1nsi2ypbd7j3i79sw62s3gf399z"))))
> - (inputs
> - (modify-inputs (package-inputs emacs-next)
> - (prepend sqlite tree-sitter)))
> - (synopsis "Emacs text editor with @code{tree-sitter} support")
> - (description "This Emacs build supports tree-sitter."))))
> + (package
> + (inherit emacs-next)
> + (name "emacs-next-tree-sitter")
> + (inputs
> + (modify-inputs (package-inputs emacs-next)
> + (prepend sqlite tree-sitter)))
> + (synopsis "Emacs text editor with @code{tree-sitter} support")
> + (description "This Emacs build supports tree-sitter.")))
>
> (define-public emacs-next-pgtk
> (package

Hi Liliana,

What do you think about moving everything from emacs-next-tree-sitter to
emacs-next and making emacs-next-tree-sitter to be just an alias to
emacs-next and later removing emacs-next-tree-sitter at all?

IMHO, shipping tree-sitter with emacs by default make much sense.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmRoenIACgkQIgjSCVjB
3rB6gA//X0x/VGymyzL+FkwOuko3n1FoufrrEqG7WLqQQrhYr7WEaTK40614hKUP
rUXMpMN8DeOjh3RebcjiI6faSZyYFXtFwj+GKSRnwoG3RvHGjWmtg5W8OSZAUKEE
3OUzslq3g+wtUyD2p+tgOWpyeRLMw66BApbKYmIqOrDfoM3BFnNBSqn4IgSVuWJK
YTARPW+Jxsf2q31zu3dq9Gt+tztQ/Q8fFcfuWYsMCLjaQKls2XZL0U0I4c6Yew6s
e6FII2FkXCUrAhfl20v7yBXgEc+nzU1F9d4XtT596wJNErg45evg2nHhZ3++K4FL
/IiTn+rJda1dKtZ/cLerRKMjm4Auw0DiXUxP7ZvjEwh9G5/fWYo633W1SFSMTbe7
cqX+FETgjqYytxrXnmCQ4SAUNoprU2ytUF5wtoxwlQbzHxgbWF+/hfxa0jDS+zjO
7EE3BEdon/e1cjrqXVbqNaZ6ePsfpcQYKpwxPmWfgVP8BL+WIsck2KzWbSgcC6Gd
KyNJSLyG9HjEpHouARoIkrV03ef9IINCvDfacAJ+mBx09eWekxNDGOi2d/SZ3ZOd
xjNIpIxPMuMyqZHdyRYeGPZlR43zxinExfOUoVE1tG5SEGXx0agk5tFeQwIR8psy
Vtotz4tJ8FfN6ZJA/+hxmHfu1in52mbDXoxnDnsZ1WTFrtIjUmw=
=BxjL
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 20 May 2023 18:30
17cab2b0d87ace3d63a6f5bf8b5522af2e76df1f.camel@gmail.com
Am Samstag, dem 20.05.2023 um 11:44 +0400 schrieb Andrew Tropin:
Toggle quote (58 lines)
> On 2023-05-18 12:37, Liliana Marie Prikler wrote:
>
> > * gnu/packages/emacs.scm (emacs-next-tree-sitter)[version, source]:
> > Inherit
> > fields from emacs-next.
> > ---
> >  gnu/packages/emacs.scm | 30 ++++++++----------------------
> >  1 file changed, 8 insertions(+), 22 deletions(-)
> >
> > diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> > index 31009ac4d9..7831a24922 100644
> > --- a/gnu/packages/emacs.scm
> > +++ b/gnu/packages/emacs.scm
> > @@ -418,28 +418,14 @@ (define-public emacs-next
> >         (prepend autoconf)))))
> >  
> >  (define-public emacs-next-tree-sitter
> > -  (let ((commit "ac7ec87a7a0db887e4ae7fe9005aea517958b778")
> > -        (revision "0"))
> > -    (package
> > -      (inherit emacs-next)
> > -      (name "emacs-next-tree-sitter")
> > -      (version (git-version "30.0.50" revision commit))
> > -      (source
> > -       (origin
> > -         (inherit (package-source emacs-next))
> > -         (method git-fetch)
> > -         (uri (git-reference
> > -               (url "https://git.savannah.gnu.org/git/emacs.git/")
> > -               (commit commit)))
> > -         (file-name (git-file-name name version))
> > -         (sha256
> > -          (base32
> > -          
> > "1akq6dbllwwqwx21wnwnv6aax1nsi2ypbd7j3i79sw62s3gf399z"))))
> > -      (inputs
> > -       (modify-inputs (package-inputs emacs-next)
> > -         (prepend sqlite tree-sitter)))
> > -      (synopsis "Emacs text editor with @code{tree-sitter}
> > support")
> > -      (description "This Emacs build supports tree-sitter."))))
> > +  (package
> > +    (inherit emacs-next)
> > +    (name "emacs-next-tree-sitter")
> > +    (inputs
> > +     (modify-inputs (package-inputs emacs-next)
> > +       (prepend sqlite tree-sitter)))
> > +    (synopsis "Emacs text editor with @code{tree-sitter} support")
> > +    (description "This Emacs build supports tree-sitter.")))
> >  
> >  (define-public emacs-next-pgtk
> >    (package
>
> Hi Liliana,
>
> What do you think about moving everything from emacs-next-tree-sitter
> to emacs-next and making emacs-next-tree-sitter to be just an alias
> to emacs-next and later removing emacs-next-tree-sitter at all?
I agree modulo checking supported systems for tree-sitter, but I'd like
to do this on the emacs-team branch rather than master for now.

Cheers
A
A
Andrew Tropin wrote on 21 May 2023 08:07
87zg5yxlmo.fsf@trop.in
On 2023-05-20 18:30, Liliana Marie Prikler wrote:
Toggle quote (64 lines)
> Am Samstag, dem 20.05.2023 um 11:44 +0400 schrieb Andrew Tropin:
>> On 2023-05-18 12:37, Liliana Marie Prikler wrote:
>>
>> > * gnu/packages/emacs.scm (emacs-next-tree-sitter)[version, source]:
>> > Inherit
>> > fields from emacs-next.
>> > ---
>> >  gnu/packages/emacs.scm | 30 ++++++++----------------------
>> >  1 file changed, 8 insertions(+), 22 deletions(-)
>> >
>> > diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
>> > index 31009ac4d9..7831a24922 100644
>> > --- a/gnu/packages/emacs.scm
>> > +++ b/gnu/packages/emacs.scm
>> > @@ -418,28 +418,14 @@ (define-public emacs-next
>> >         (prepend autoconf)))))
>> >  
>> >  (define-public emacs-next-tree-sitter
>> > -  (let ((commit "ac7ec87a7a0db887e4ae7fe9005aea517958b778")
>> > -        (revision "0"))
>> > -    (package
>> > -      (inherit emacs-next)
>> > -      (name "emacs-next-tree-sitter")
>> > -      (version (git-version "30.0.50" revision commit))
>> > -      (source
>> > -       (origin
>> > -         (inherit (package-source emacs-next))
>> > -         (method git-fetch)
>> > -         (uri (git-reference
>> > -               (url "https://git.savannah.gnu.org/git/emacs.git/")
>> > -               (commit commit)))
>> > -         (file-name (git-file-name name version))
>> > -         (sha256
>> > -          (base32
>> > -          
>> > "1akq6dbllwwqwx21wnwnv6aax1nsi2ypbd7j3i79sw62s3gf399z"))))
>> > -      (inputs
>> > -       (modify-inputs (package-inputs emacs-next)
>> > -         (prepend sqlite tree-sitter)))
>> > -      (synopsis "Emacs text editor with @code{tree-sitter}
>> > support")
>> > -      (description "This Emacs build supports tree-sitter."))))
>> > +  (package
>> > +    (inherit emacs-next)
>> > +    (name "emacs-next-tree-sitter")
>> > +    (inputs
>> > +     (modify-inputs (package-inputs emacs-next)
>> > +       (prepend sqlite tree-sitter)))
>> > +    (synopsis "Emacs text editor with @code{tree-sitter} support")
>> > +    (description "This Emacs build supports tree-sitter.")))
>> >  
>> >  (define-public emacs-next-pgtk
>> >    (package
>>
>> Hi Liliana,
>>
>> What do you think about moving everything from emacs-next-tree-sitter
>> to emacs-next and making emacs-next-tree-sitter to be just an alias
>> to emacs-next and later removing emacs-next-tree-sitter at all?
> I agree modulo checking supported systems for tree-sitter, but I'd like
> to do this on the emacs-team branch rather than master for now.
>
> Cheers
>
Agree :)
The patches LGTM.
--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmRptT8ACgkQIgjSCVjB
3rB63w//b31vqkXxNozJtJbHFe+/I+kFJ/i1qZWEguPCJPCoEAfmmplU8u10roVK
A8s9smz1xZ5AJtgb0y3QGCUbSrF19Q5zAtwrdcxw/oW/+2i+iM4puUVTo/2wQ2Om
aOGqHy7PLVUTEOFmzHY6YWiBgVJ3G+2qBrljKJwzRxqzSzhYQMRMva61ukCityiw
sqfCZIS64fnK5JgZ4pRh3iC4iTrKxWZDkROkdPwxXXEkGBooX4ESzO6TEv0rho72
p3LZX9ttjs1ptIZ9KoYdg1akrQfD0p0zlR7RXy7hXvX4t77wTzy8svCtn9g7K1ds
1VSzAbLLhFbsPWeW6q6YQ3YLcDxfWWRs2LQDPtIkjYvoyaOePFMVp7BJqD0hOThe
k5TTJ58vMStwvHC0UWl1psCExYDH/5aT9TuMJPBdF5Wf0HhHzoadGomo6CH1F/9N
Wtp9J0VO38cyBVwCJFUiotrkkv8HoUQPzep8IP22NXf2T83KcEEcWZr93Qrbw7a3
GFWWj+gJ+FTJYoyrUVYj4KcILyP5IctYsQJZiiGC6cvg6uZFqFwVueIab0+sE1Bw
y6CNfqvO/ze3fhGtxBkySWBVTacmOAx00yjBF84VMZO/PTDQnBJOVUerJaZCK7UP
QLpUkkgvsvcAkjd2VCYJaiwoICYXeLyhCDNdv2zVHuvMABpBZFE=
=wuwu
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 28 May 2023 23:17
Re: [PATCH 2/2] gnu: emacs-next-tree-sitter: "Downgrade" to 29.0.91.
(address . 63568-done@debbugs.gnu.org)
8bbfcbf0de7ae4b066a9ad43f658db5a0ec0c078.camel@gmail.com
Am Donnerstag, dem 18.05.2023 um 12:37 +0200 schrieb Liliana Marie
Prikler:
Toggle quote (4 lines)
> * gnu/packages/emacs.scm (emacs-next-tree-sitter)[version, source]:
> Inherit
> fields from emacs-next.
> ---
Pushed.
Closed
?