Hi Etienne,
I've noticed that conda (22.9.0) does not build as well, and have
resolved the issue in my local guix clone.
It required these changes:
- Add python-conda-package-streaming 0.7.0.
- Upgrade python-conda-package-handling from 1.7.3 to 2.1.0 (which has
python-conda-package-streaming as a dependency).
- Remove python-anaconda-client as a dependency of conda.
- Make conda a dependency of python-anaconda-client.
I'm also relatively new to guix. I think it is prefered to have small
patches, so I will send four patches for each of the above steps to
this issue as described in [1]. Then hopefully someone will review
them and merge them. Then after that it might be worthwhile to update
conda itself too.
Some notes:
- python-conda-package-streaming has conda itself as an optional
dependency for testing. I have therefore disabled all the tests.
- python-conda-package-streaming also removes the need for libarchive,
which apparently required some workarounds, so those are also removed.
- It is not clear to me why python-anaconda-client was a dependency of
conda in the first place, so maybe I'm missing something.
- I've also fixed some linting warnings on the existing packages.
Cheers,
Hugo