[PATCH 0/2] Update browserpass-native

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Timotej Lazar
Owner
unassigned
Submitted by
Timotej Lazar
Severity
normal
T
T
Timotej Lazar wrote on 29 Apr 2023 23:26
(address . guix-patches@gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20230429212602.8032-1-timotej.lazar@araneo.si
Hi, this updates browserpass-native and switches it to the new style.
Thanks!

Timotej Lazar (2):
gnu: browserpass-native: Update to 3.1.0.
gnu: browserpass-native: Use new package style.

gnu/packages/password-utils.scm | 79 +++++++++++++++------------------
1 file changed, 35 insertions(+), 44 deletions(-)


base-commit: 8fe5ed47cbbb6ae6ed00afa8d8b4f04e216d5adc
--
2.39.2
T
T
Timotej Lazar wrote on 29 Apr 2023 23:28
[PATCH 1/2] gnu: browserpass-native: Update to 3.1.0.
(address . 63179@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20230429212811.14469-1-timotej.lazar@araneo.si
* gnu/packages/password-utils.scm (browserpass-native): Update to 3.1.0.
[inputs]: Add bash-minimal.
---
gnu/packages/password-utils.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index f5f301308a..17427bc07c 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -75,6 +75,7 @@ (define-module (gnu packages password-utils)
#:use-module (gnu packages authentication)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
@@ -898,7 +899,7 @@ (define-public tessen
(define-public browserpass-native
(package
(name "browserpass-native")
- (version "3.0.7")
+ (version "3.1.0")
(source
(origin
(method git-fetch)
@@ -907,8 +908,7 @@ (define-public browserpass-native
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "1jkjslbbac49xjyjkc2b07phdm3i64z40kh6h55cl22dxjmpp1nb"))))
+ (base32 "1if72k526sqqxnw250qwxvzwvh1w0k8ag4p4xq3442b22hywx72i"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/browserpass/browserpass-native"
@@ -954,7 +954,7 @@ (define-public browserpass-native
(native-inputs
(list which))
(inputs
- (list gnupg go-github-com-mattn-go-zglob
+ (list bash-minimal gnupg go-github-com-mattn-go-zglob
go-github-com-rifflock-lfshook go-github-com-sirupsen-logrus
go-golang-org-x-sys))
(home-page "https://github.com/browserpass/browserpass-native")
--
2.39.2
T
T
Timotej Lazar wrote on 29 Apr 2023 23:28
[PATCH 2/2] gnu: browserpass-native: Use new package style.
(address . 63179@debbugs.gnu.org)(name . Timotej Lazar)(address . timotej.lazar@araneo.si)
20230429212811.14469-2-timotej.lazar@araneo.si
* gnu/packages/password-utils.scm (browserpass-native)[arguments]: Use
gexps. Drop trailing #t from phases.
---
gnu/packages/password-utils.scm | 71 ++++++++++++++-------------------
1 file changed, 31 insertions(+), 40 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 17427bc07c..0a3f2551c9 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -911,46 +911,37 @@ (define-public browserpass-native
(base32 "1if72k526sqqxnw250qwxvzwvh1w0k8ag4p4xq3442b22hywx72i"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/browserpass/browserpass-native"
- #:install-source? #f
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-makefile
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; This doesn't go in #:make-flags because the Makefile itself
- ;; gets installed.
- (substitute*
- "src/github.com/browserpass/browserpass-native/Makefile"
- (("PREFIX \\?= /usr")
- (string-append "PREFIX ?= " out)))
- #t)))
- (add-before 'build 'configure
- (lambda _
- (with-directory-excursion
- "src/github.com/browserpass/browserpass-native"
- (invoke "make" "configure"))
- #t))
- (replace 'build
- (lambda _
- (with-directory-excursion
- "src/github.com/browserpass/browserpass-native"
- (invoke "make"))
- #t))
- (replace 'install
- (lambda _
- (with-directory-excursion
- "src/github.com/browserpass/browserpass-native"
- (invoke "make" "install"))
- #t))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gnupg (assoc-ref inputs "gnupg")))
- (wrap-program (string-append out "/bin/browserpass")
- `("PATH" ":" prefix
- (,(string-append gnupg "/bin"))))
- #t))))))
+ (list #:import-path "github.com/browserpass/browserpass-native"
+ #:install-source? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'patch-makefile
+ (lambda _
+ ;; This doesn't go in #:make-flags because the Makefile
+ ;; itself gets installed.
+ (substitute* "src/github.com/browserpass/browserpass-native/Makefile"
+ (("PREFIX \\?= /usr")
+ (string-append "PREFIX ?= " #$output)))))
+ (add-before 'build 'configure
+ (lambda _
+ (with-directory-excursion
+ "src/github.com/browserpass/browserpass-native"
+ (invoke "make" "configure"))))
+ (replace 'build
+ (lambda _
+ (with-directory-excursion
+ "src/github.com/browserpass/browserpass-native"
+ (invoke "make"))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion
+ "src/github.com/browserpass/browserpass-native"
+ (invoke "make" "install"))))
+ (add-after 'install 'wrap-executable
+ (lambda _
+ (wrap-program (string-append #$output "/bin/browserpass")
+ `("PATH" ":" prefix
+ (,(string-append #$(this-package-input "gnupg") "/bin")))))))))
(native-inputs
(list which))
(inputs
--
2.39.2
L
L
Ludovic Courtès wrote on 14 Jun 2023 23:34
Re: bug#63179: [PATCH 0/2] Update browserpass-native
(name . Timotej Lazar)(address . timotej.lazar@araneo.si)(address . 63179-done@debbugs.gnu.org)
87pm5xpw2u.fsf@gnu.org
Hi,

Timotej Lazar <timotej.lazar@araneo.si> skribis:

Toggle quote (3 lines)
> gnu: browserpass-native: Update to 3.1.0.
> gnu: browserpass-native: Use new package style.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 63179@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 63179
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch