--symlink option of "guix shell -C -F" is non-functional for /lib and /usr/lib, unlike /bin

  • Open
  • quality assurance status badge
Details
One participant
  • Maxime Devos
Owner
unassigned
Submitted by
Maxime Devos
Severity
normal

Debbugs page

Maxime Devos wrote 2 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
f7f4118a-a4de-a985-3e3d-a97fc71df10e@telenet.be
$ guix shell -F -C tk -- some-software
# ... libtk8.5 not found, let's choose version 8.5
$ LC_ALL=en_GB.UTF-8 guix shell -F -C tk@8.5 shell
guix shell: error: tk: package not found for version 8.5
# Guix doesn't have version 8.5. Let's lie and pretend
# that 8.5=8.6, maybe it will be ‘close enough’ for
# ‘some-software’.
$ guix shell -F -C tk --symlink=/lib/libtk8.5.so=/lib/libtk8.5.so --
some-software
guix shell: fout: symlink target is absolute: '/lib/libtk8.5.so'
tip: The target of the symlink must be relative rather than absolute, as
it is relative to the profile created.
Perhaps the source and target components of the symlink spec were
inverted? Below is a valid example, where the
`/usr/bin/env' symbolic link is to target the profile's `bin/env' file:
--symlink=/usr/bin/env=bin/env
# Looks an arbitrary limitation to me -- the symlink code could just
# treat absolute targets as absolute instead of relative to the profile.
# Still, let's give following the tip a try.
$ LC_ALL=en_GB.UTF-8 guix shell -F -C tk
--symlink=/lib/libtk8.5.so=lib/libtk8.6.so -- some-software
error: failed to evaluate directive: ("/lib/libtk8.5.so" ->
"/gnu/store/sbvf4784c43ssr20x45icvm8s8h7zvh4-profile/lib/libtk8.6.so")
guix shell: error: symlink: Read-only file system: ".//lib/libtk8.5.so"
# If /usr/lib is tried instead of /lib, a different error occurs:
$ LC_ALL=en_GB.UTF-8 guix shell -F -C tk
--symlink=/usr/lib/libtk8.5.so=lib/libtk8.6.so -- some-software
guix shell: error: symlink: File exists: "/usr/lib"
# Contrast this with /bin, in which files symlinks can be put, unlike
# /usr/lib and /lib (yes I know that putting libraries in /bin doesn't
# make much sense, it's just an example):
$ LC_ALL=en_GB.UTF-8 guix shell -F -C tk
--symlink=/bin/libtk8.5.so=lib/libtk8.6.so -- some-software
guix shell: error: some-software: command not found
hint: Did you mean 'mtrace'?
Greetings,
Maxime.
Attachment: OpenPGP_signature
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 62547@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 62547
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help