[PATCH] services: fstrim: Fix schedule ungexp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Bruno Victal
Owner
unassigned
Submitted by
Bruno Victal
Severity
normal
B
B
Bruno Victal wrote on 26 Mar 2023 17:17
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
7af61583539bf581432ee87cb2401ee9674836a7.1679843763.git.mirai@makinata.eu
Previously, only the first level of the list would be quoted,
resulting in a schedule of the sort:
'(next-second (range 0 60 30))
being incorrectly ungexp'd into:
(list next-second (0 30))

* gnu/services/linux.scm (fstrim-mcron-job): Fix schedule ungexp.
---
gnu/services/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/services/linux.scm b/gnu/services/linux.scm
index d085b375a2..439848919d 100644
--- a/gnu/services/linux.scm
+++ b/gnu/services/linux.scm
@@ -234,7 +234,7 @@ (define (fstrim-mcron-job config)
;; lists are ungexp'd correctly since @var{schedule}
;; can be either a procedure, a string or a list.
#$(if (list? schedule)
- `(list ,@schedule)
+ #~'(#$@schedule)
schedule)
(lambda ()
(system* #$(file-append package "/sbin/fstrim")
--
2.39.1
M
M
Maxim Cournoyer wrote on 29 Mar 2023 04:08
control message for bug #62463
(address . control@debbugs.gnu.org)
87pm8s48dh.fsf@gmail.com
close 62463
quit
?