Inconsistent guile enviornment from guix shell

  • Done
  • quality assurance status badge
Details
4 participants
  • Josselin Poiret
  • Maxim Cournoyer
  • Skyler
  • Simon Tournier
Owner
unassigned
Submitted by
Skyler
Severity
normal
S
S
Skyler wrote on 25 Mar 2023 20:10
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
hi_7jAEECmnA-PPNliCmldWGrYqR-HqkSIJ7_oLR4vSHRIVI_JH4Zt_lKOb8953YbOANvw1BwdZTL2FxpQfeA8pwIQny5hTZVL9xlGO36Gw=@protonmail.com
Hello,

The modules available in a guile REPL seem to be inconsistent after running the guix shell command, where using the -D flag to create a development environment behaves as expected, but leaving out that flag to add the package itself to the environment does not. I am experiencing this issue with some random code on my machine, but I will use guile-pubstrate defined in guix code (https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/guile-xyz.scm?id=04724e59971b03f86a410285653d24005c62b924#n340)as an example for reproduction. Note that guile-pubstrate lists guile-webutils as a propagated input.

When I use `guix shell -D guile-pubstrate`, I am able to import the `(webutils bytevectors)` module, as I would expect. I am not able to import `(pubstrate apclient)`, also as I would expect. Inspecting GUILE_LOAD_PATH shows that a new profile path was added which contains the dependencies:

$ guix shell -D guile-pubstrate --checkguix shell: checking the environment variables visible from shell '/gnu/store/d99ykvj3axzzidygsmdmzxah4lvxd6hw-bash-5.1.8/bin/bash'...
guix shell: All is good!  The shell gets correct environment variables.
[env]$ guile
GNU Guile 3.0.7
Copyright (C) 1995-2021 Free Software Foundation, Inc.

Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
This program is free software, and you are welcome to redistribute it
under certain conditions; type `,show c' for details.

Enter `,help' for help.
scheme@(guile-user)> (use-modules (webutils bytevectors))
scheme@(guile-user)> (use-modules (pubstrate apclient))
While compiling expression:
no code for module (pubstrate apclient)
scheme@(guile-user)> ,q
[env]$ echo $GUILE_LOAD_PATH
/gnu/store/pr4vyrz2xsziv25hrdfyim0wy331p4z5-profile/share/guile/site/3.0:/run/current-system/profile/share/guile/site/3.0:/home/skyler/.guix-profile/share/guile/site/3.0
$ ls /gnu/store/pr4vyrz2xsziv25hrdfyim0wy331p4z5-profile/share/guile/site/3.0
8sync      apicheck.scm  config     debugging  fibers      gcrypt    gnutls      graph         io       match-bind.scm  md5.scm  rx      search  sjson.scm  term     text           web
8sync.scm  compat        container  fash.scm   fibers.scm  gdbm.scm  gnutls.scm  htmlprag.scm  logging  math            os       scheme  sjson   string     texinfo  unit-test.scm  webutils

However, when I use guix shell guile-pubstrate, neither (webutils bytevectors) nor (pubstrate apclient) are available. I would expect both of them to be, the former because it is a propagated input and the latter because it is the package that was directly added. If guile was able to locate pubstrate's modules, I would expect loading to fail because its runtime dependencies are not available. Inspecting GUILE_LOAD_PATH shows that nothing was added to it:

$ guix shell guile-pubstrate --check
guix shell: checking the environment variables visible from shell '/gnu/store/d99ykvj3axzzidygsmdmzxah4lvxd6hw-bash-5.1.8/bin/bash'...
guix shell: All is good!  The shell gets correct environment variables.
[env]$ guile
GNU Guile 3.0.9
Copyright (C) 1995-2023 Free Software Foundation, Inc.

Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
This program is free software, and you are welcome to redistribute it
under certain conditions; type `,show c' for details.

Enter `,help' for help.
scheme@(guile-user)> (use-modules (webutils bytevectors))
While compiling expression:
no code for module (webutils bytevectors)
scheme@(guile-user)> (use-modules (pubstrate apclient))
While compiling expression:
no code for module (pubstrate apclient)
scheme@(guile-user)> ,q
[env]$ echo $GUILE_LOAD_PATH
/run/current-system/profile/share/guile/site/3.0:/home/skyler/.guix-profile/share/guile/site/3.0


This is not an issue with the guile-pubstrate definition in particular, because guix shell guile-webutils also fails to add its modules to my environment:


$ guix shell --check guile-webutilsThe following derivation will be built:
  /gnu/store/ca8gv3yk2khs0h60kc5v682g7gvfqd23-profile.drv

building CA certificate bundle...
listing Emacs sub-directories...
building fonts directory...
building directory of Info manuals...
building profile with 1 package...
guix shell: checking the environment variables visible from shell '/gnu/store/d99ykvj3axzzidygsmdmzxah4lvxd6hw-bash-5.1.8/bin/bash'...
guix shell: All is good!  The shell gets correct environment variables.
[env]$ guile
GNU Guile 3.0.9
Copyright (C) 1995-2023 Free Software Foundation, Inc.

Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
This program is free software, and you are welcome to redistribute it
under certain conditions; type `,show c' for details.

Enter `,help' for help.
scheme@(guile-user)> (use-modules (webutils bytevectors))
While compiling expression:
no code for module (webutils bytevectors)

My machine is up-to-date as of today:

Generation 32 Mar 25 2023 11:32:38 (current)  guix 04724e5
    branch: master
    commit: 04724e59971b03f86a410285653d24005c62b924
  rde a7b5944
    repository URL: https://git.sr.ht/~abcdw/rde
    branch: master
    commit: a7b59443405169600a00f0b295a3fb1de360cb0b


Let me know if there is anything I can do to help diagnose or fix this issue.


Thanks,
Skyler
Attachment: file
Attachment: signature.asc
S
S
Skyler wrote on 29 Mar 2023 23:23
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
6gt4WqkUbUpYoJWwaHY0jhjoCOcVc9vHBCDzozLBB3xDg46YvsJLEEYxTaWdwZQciB9F0OQM5dGjQ-N81W9p2y5B3LBJAuMP0HrzwZx5_VM=@protonmail.com
Hello again,

I did some more digging, and it looks like the issue is that guile also has to be specified in the shell environment. I suppose this is reasonable, because the result of the shell environment should not depend on the calling environment, and the existence of guile in the environment is what tells guix that the variables need to be set. The load path is set with the -D flag because guile is a non-propagated input to the package, so it exists in the development shell environment automatically, but not in an ad-hoc environment.

I determined this by trying variations of the shell command in test users with clean environments, one of them including a home environment because I thought that might be a factor. There was no change based on whether the user had a home environment installed, but both users experienced the problem when guile was not included in the shell command. Incidentally, using the pure or container flags always works, because guile must be specified regardless of the calling environment in those cases, but I don't think it is immediately obvious why those flags "make it work".

In spite of being reasonable, it is not particularly intuitive. Could I recommend an addition to the manual in section "7.1 Invoking guix-shell", adding text like the below after the example invocation `guix shell python python-numpy -- python3?`?

"Note that it is necessary to include the main python package in this command even if it is already installed into your environment. This is so that the shell environment knows to set PYTHONPATH and other related variables. The shell environment cannot check the previously installed environment, because then it would be non-deterministic."

Thanks,
Skyler
------- Original Message -------
On Saturday, March 25th, 2023 at 12:10 PM, Skyler <skyvine@protonmail.com> wrote:

Toggle quote (95 lines)
> Hello,
>
> The modules available in a guile REPL seem to be inconsistent after running the guix shell command, where using the -D flag to create a development environment behaves as expected, but leaving out that flag to add the package itself to the environment does not. I am experiencing this issue with some random code on my machine, but I will use guile-pubstrate defined in guix code (https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/guile-xyz.scm?id=04724e59971b03f86a410285653d24005c62b924#n340) as an example for reproduction. Note that guile-pubstrate lists guile-webutils as a propagated input.
>
> When I use guix shell -D guile-pubstrate?, I am able to import the (webutils bytevectors)? module, as I would expect. I am not able to import (pubstrate apclient)?, also as I would expect. Inspecting GUILE_LOAD_PATH shows that a new profile path was added which contains the dependencies:
>
> $ guix shell -D guile-pubstrate --check
> guix shell: checking the environment variables visible from shell '/gnu/store/d99ykvj3axzzidygsmdmzxah4lvxd6hw-bash-5.1.8/bin/bash'...
> guix shell: All is good! The shell gets correct environment variables.
> [env]$ guile
> GNU Guile 3.0.7
> Copyright (C) 1995-2021 Free Software Foundation, Inc.
>
> Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
> This program is free software, and you are welcome to redistribute it
> under certain conditions; type `,show c' for details.
>
> Enter `,help' for help.
> scheme@(guile-user)> (use-modules (webutils bytevectors))
> scheme@(guile-user)> (use-modules (pubstrate apclient))
> While compiling expression:
> no code for module (pubstrate apclient)
> scheme@(guile-user)> ,q
> [env]$ echo $GUILE_LOAD_PATH
> /gnu/store/pr4vyrz2xsziv25hrdfyim0wy331p4z5-profile/share/guile/site/3.0:/run/current-system/profile/share/guile/site/3.0:/home/skyler/.guix-profile/share/guile/site/3.0
> $ ls /gnu/store/pr4vyrz2xsziv25hrdfyim0wy331p4z5-profile/share/guile/site/3.0
> 8sync apicheck.scm config debugging fibers gcrypt gnutls graph io match-bind.scm md5.scm rx search sjson.scm term text web
> 8sync.scm compat container fash.scm fibers.scm gdbm.scm gnutls.scm htmlprag.scm logging math os scheme sjson string texinfo unit-test.scm webutils
>
> However, when I use guix shell guile-pubstrate, neither (webutils bytevectors) nor (pubstrate apclient) are available. I would expect both of them to be, the former because it is a propagated input and the latter because it is the package that was directly added. If guile was able to locate pubstrate's modules, I would expect loading to fail because its runtime dependencies are not available. Inspecting GUILE_LOAD_PATH shows that nothing was added to it:
>
> $ guix shell guile-pubstrate --check
> guix shell: checking the environment variables visible from shell '/gnu/store/d99ykvj3axzzidygsmdmzxah4lvxd6hw-bash-5.1.8/bin/bash'...
> guix shell: All is good! The shell gets correct environment variables.
> [env]$ guile
> GNU Guile 3.0.9
> Copyright (C) 1995-2023 Free Software Foundation, Inc.
>
> Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
> This program is free software, and you are welcome to redistribute it
> under certain conditions; type `,show c' for details.
>
> Enter `,help' for help.
> scheme@(guile-user)> (use-modules (webutils bytevectors))
> While compiling expression:
> no code for module (webutils bytevectors)
> scheme@(guile-user)> (use-modules (pubstrate apclient))
> While compiling expression:
> no code for module (pubstrate apclient)
> scheme@(guile-user)> ,q
> [env]$ echo $GUILE_LOAD_PATH
> /run/current-system/profile/share/guile/site/3.0:/home/skyler/.guix-profile/share/guile/site/3.0
>
> This is not an issue with the guile-pubstrate definition in particular, because guix shell guile-webutils also fails to add its modules to my environment:
>
> $ guix shell --check guile-webutils
> The following derivation will be built:
> /gnu/store/ca8gv3yk2khs0h60kc5v682g7gvfqd23-profile.drv
>
> building CA certificate bundle...
> listing Emacs sub-directories...
> building fonts directory...
> building directory of Info manuals...
> building profile with 1 package...
> guix shell: checking the environment variables visible from shell '/gnu/store/d99ykvj3axzzidygsmdmzxah4lvxd6hw-bash-5.1.8/bin/bash'...
> guix shell: All is good! The shell gets correct environment variables.
> [env]$ guile
> GNU Guile 3.0.9
> Copyright (C) 1995-2023 Free Software Foundation, Inc.
>
> Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
> This program is free software, and you are welcome to redistribute it
> under certain conditions; type `,show c' for details.
>
> Enter `,help' for help.
> scheme@(guile-user)> (use-modules (webutils bytevectors))
> While compiling expression:
> no code for module (webutils bytevectors)
>
> My machine is up-to-date as of today:
>
> Generation 32 Mar 25 2023 11:32:38 (current)
> guix 04724e5
> repository URL: https://git.savannah.gnu.org/git/guix.git
> branch: master
> commit: 04724e59971b03f86a410285653d24005c62b924
> rde a7b5944
> repository URL: https://git.sr.ht/~abcdw/rde
> branch: master
> commit: a7b59443405169600a00f0b295a3fb1de360cb0b
>
> Let me know if there is anything I can do to help diagnose or fix this issue.
>
> Thanks,
> Skyler
Attachment: file
J
J
Josselin Poiret wrote on 30 Mar 2023 22:24
Re: bug#62448: Inconsistent guile enviornment from guix shell
87fs9mrnqi.fsf@jpoiret.xyz
Hi Skyler,

It's a shame that nobody had pointed out this (quite common) missing
piece earlier.

Skyler via Bug reports for GNU Guix <bug-guix@gnu.org> writes:

Toggle quote (4 lines)
> In spite of being reasonable, it is not particularly intuitive. Could I recommend an addition to the manual in section "7.1 Invoking guix-shell", adding text like the below after the example invocation `guix shell python python-numpy -- python3?`?
>
> "Note that it is necessary to include the main python package in this command even if it is already installed into your environment. This is so that the shell environment knows to set PYTHONPATH and other related variables. The shell environment cannot check the previously installed environment, because then it would be non-deterministic."

Yes, this would be a good idea. I can try to do this right now.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmQl8BUQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5Fhcaim8hC/wNAQVEZ0myo0b0s0s82F8Z/C7X4C2VsR/1
VUb/hVLmLkub03T1NHaQkZx8oi56856qq2TxT20fjshEXaCcbPwu6fDKeqtzD9Qr
puFyRg3cZE97HOUBlysmj0oU/2MaBlbklwhDD+tvxgvNAU1ifZRtvCWBZzh1JExQ
bLsY6FCeZkmQK0LLq1EPumPieyetApDH9ZrT2wJv/oNWgOmxMQlsosdVlxf4nDvC
1t80EUvtAw17AVV+t/2pX8uhg2lvu4TK9pL16KJBZqGMJ5/jfuc2PgnKqE/tjpVq
LgQZM05ufBBhJGoRA+dAFykXcxFSS3M5dh6WeYjwCjc4joqeSW8/3fRgk7BKg+Qd
h8MdDt9Z5Qk3y+GQAxnnzhZn6SPRWIXh/OreI1WFi4mIJdV4z9UKhnYADF/+dYPa
9di2xBQEYx7rS1+hpYh62ykliIZLYy51pVWF0ggTIRIDv/2Dz4ow+ozYn7AqMtnJ
Foe2VY/2+KgKekchH5oPpsA7WknjB78=
=kMgb
-----END PGP SIGNATURE-----

J
J
Josselin Poiret wrote on 30 Mar 2023 22:42
[PATCH] doc: Note that `guix shell` should contain base language packages.
e0ff6805cf50096274d9fb666ef361b2cbf3a4e8.1680208930.git.dev@jpoiret.xyz
* doc/guix.texi (Invoking guix shell): Explain that python must be included in
the invocation even if it is already available in the external environment.

Suggested-by: Skyler <skyvine@protonmail.com>
---
doc/guix.texi | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (32 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index c49e51b72e..879a526b77 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -96,7 +96,7 @@ Copyright @copyright{} 2021 Domagoj Stolfa@*
Copyright @copyright{} 2021 Hui Lu@*
Copyright @copyright{} 2021 pukkamustard@*
Copyright @copyright{} 2021 Alice Brenon@*
-Copyright @copyright{} 2021, 2022 Josselin Poiret@*
+Copyright @copyright{} 2021, 2022, 2023 Josselin Poiret@*
Copyright @copyright{} 2021 muradm@*
Copyright @copyright{} 2021, 2022 Andrew Tropin@*
Copyright @copyright{} 2021 Sarah Morgensen@*
@@ -5959,6 +5959,14 @@ building or downloading any missing package, and runs the
guix shell python python-numpy -- python3
@end example
+Note that it is necessary to include the main @code{python} package in
+this command even if it is already installed into your environment. This
+is so that the shell environment knows to set @env{PYTHONPATH} and other
+related variables. The shell environment cannot check the previously
+installed environment, because then it would be non-deterministic. This
+is true for most libraries: their corresponding language package should
+be included in the shell invocation.
+
@quotation Note
@cindex shebang, for @command{guix shell}
@command{guix shell} can be also be used as a script interpreter, also

base-commit: be5e280e5fe26f93bd5a6e3f76e4502edb913a94
--
2.39.2
S
S
Skyler wrote on 12 Apr 2023 00:57
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62448@debbugs.gnu.org)
LlwwxNps9NeeEH17HGch8TshLxZe0zFYbC9_27tDUs62l17Z7_xVB1nngBHU1ZhnxchS1B_grI5KItWfA2d3QtiP974mawbrkXo7alfiLg4=@protonmail.com
Is there a normal timeline for patch review or is it mor of an "as resources allow" type of deal?

------- Original Message -------
On Thursday, March 30th, 2023 at 1:42 PM, Josselin Poiret <dev@jpoiret.xyz> wrote:


Toggle quote (41 lines)
> * doc/guix.texi (Invoking guix shell): Explain that python must be included in
> the invocation even if it is already available in the external environment.
>
> Suggested-by: Skyler skyvine@protonmail.com
>
> ---
> doc/guix.texi | 10 +++++++++-
> 1 file changed, 9 insertions(+), 1 deletion(-)
>
> diff --git a/doc/guix.texi b/doc/guix.texi
> index c49e51b72e..879a526b77 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -96,7 +96,7 @@ Copyright @copyright{} 2021 Domagoj Stolfa@*
> Copyright @copyright{} 2021 Hui Lu@*
> Copyright @copyright{} 2021 pukkamustard@*
> Copyright @copyright{} 2021 Alice Brenon@*
> -Copyright @copyright{} 2021, 2022 Josselin Poiret@*
> +Copyright @copyright{} 2021, 2022, 2023 Josselin Poiret@*
> Copyright @copyright{} 2021 muradm@*
> Copyright @copyright{} 2021, 2022 Andrew Tropin@*
> Copyright @copyright{} 2021 Sarah Morgensen@*
> @@ -5959,6 +5959,14 @@ building or downloading any missing package, and runs the
> guix shell python python-numpy -- python3
> @end example
>
> +Note that it is necessary to include the main @code{python} package in
> +this command even if it is already installed into your environment. This
> +is so that the shell environment knows to set @env{PYTHONPATH} and other
> +related variables. The shell environment cannot check the previously
> +installed environment, because then it would be non-deterministic. This
> +is true for most libraries: their corresponding language package should
> +be included in the shell invocation.
> +
> @quotation Note
> @cindex shebang, for @command{guix shell}
> @command{guix shell} can be also be used as a script interpreter, also
>
> base-commit: be5e280e5fe26f93bd5a6e3f76e4502edb913a94
> --
> 2.39.2
J
J
Josselin Poiret wrote on 12 Apr 2023 10:35
(name . Skyler)(address . skyvine@protonmail.com)(address . 62448@debbugs.gnu.org)
87cz49v6ol.fsf@jpoiret.xyz
Hi Skyler,

Skyler <skyvine@protonmail.com> writes:

Toggle quote (2 lines)
> Is there a normal timeline for patch review or is it mor of an "as resources allow" type of deal?

Unfortunately no, there are no guarantees: someone needs to take some
time to look at this, and we can't force anyone to do it. The fact that
it's in a bug report instead of a patch submission probably doesn't
help, let me see if I can fix this with a debbugs command.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmQ2bWoQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaioOLDACm3edQqPbcEQtoFmGZPInMJ5F9HkW85th2
V74G5t/CtFoKZMSgCWYfaOHr5cO7Wp5zqgGeAIsfkCQ5zfw+GDm1o5GDz6wpTMYJ
66BodMT0iL8aKAgNpO0JHTqRhvoxV4zOo8t363Xp+9ER9s1RmDhkY3+tKNAl6L6y
8YuGrbE/m7cRIEX3g7KvD57Gmr0PcLh9PdYBy3dRTqIt9Qc2GMq9qAMcbEd9eH/w
BmW1lWxUYzLjYO/7vqXfd+Q/iHnUs6qRZNkXe3dwikZbXtNfjhfd3FoEnWcr6Ous
gc61ta4B3BeFWBA28pSWsmZpH496xh7yhhWRIY9vBnTAr9ikg6iSGzWCtwnKBwc4
78AwZcC2Ais7UYtEgcy7oaYdXU/DUJTAh6c5EWf0HWt21z3AmeNEKr5/MYqqHamW
QQt0r4bI12MrwrwnOqs2Hk56uN4OfOWsAlLkRT1MsbrvKcj3SaxVXFtMYeWlw/j6
wGKis6bbTCl0mQotT3Km+EobE/38DMQ=
=bG8i
-----END PGP SIGNATURE-----

J
J
Josselin Poiret wrote on 12 Apr 2023 10:37
Test
(address . control@debbugs.gnu.org)
87a5zdv6ll.fsf@jpoiret.xyz
tags 62448 + patch
thankyou

--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmQ2bdYQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaioEoC/9z4kSzSH3p3XjsWAPpgv7l0bj6MBTqw2bJ
PgLflR7Kb8scGIgovhmvbGQFy7DBWEQWXCUN4TATkKow21wVTgDN2HzF3mHw6fCX
f0kp75RP1B2VCQmV2q6P39vF6j6RHuCxMD+nw2WpHON9tf25UMP9yYybE2v/PsNZ
z+QB2dx/SUivUK/aiIUuuFTWcUuRASQbEVroWzxqG6/+FR7z+44e/5JbS4EGrYIA
LZkmE+RoVlG0XqmPPiQBk1NUiDSq4n4W7RSW8n5KUi0bDHyff3whOYPcu7DySv9L
OrEWp85rDuZ81LepTp6teecxMV9vY7BToHgQqjTIsK6m2nYLc/J0Xp1/R1C9xtvT
qkLSM/J56+Ez8+jjIrJVO24Vv89T/GUcQZPRn6Ky3fCHIOO6JrAa/yaogma6gfqr
2tgkfz/x2hTilrdc5rmo0VYq03jGQdQzE3D7Vo6iUr2H7dSuf3/cOvFK9U1B/HWb
ENrfFHFaEjg1w3+EEnz7u4GHuZXmwCs=
=Zqu7
-----END PGP SIGNATURE-----

S
S
Simon Tournier wrote on 12 Apr 2023 13:07
Re: bug#62448: [PATCH] doc: Note that `guix shell` should contain base language packages.
87y1mxgxze.fsf@gmail.com
Hi,

On jeu., 30 mars 2023 at 22:42, Josselin Poiret via Bug reports for GNU Guix <bug-guix@gnu.org> wrote:

Toggle quote (8 lines)
> +Note that it is necessary to include the main @code{python} package in
> +this command even if it is already installed into your environment. This
> +is so that the shell environment knows to set @env{PYTHONPATH} and other
> +related variables. The shell environment cannot check the previously
> +installed environment, because then it would be non-deterministic. This
> +is true for most libraries: their corresponding language package should
> +be included in the shell invocation.

Nitpick: Missing double space for sentences.

Otherwise, LGTM.


Cheers,
simon
M
M
Maxim Cournoyer wrote on 12 Apr 2023 14:43
(name . Skyler via Bug reports for GNU Guix)(address . bug-guix@gnu.org)
87leixjmon.fsf@gmail.com
Hello,

Skyler via Bug reports for GNU Guix <bug-guix@gnu.org> writes:

Toggle quote (2 lines)
> Is there a normal timeline for patch review or is it mor of an "as resources allow" type of deal?

The later, I'd say; we're all volunteers :-).

--
Thanks,
Maxim
S
S
Skyler wrote on 13 Apr 2023 21:53
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
vTKpScbWNptNJ2FoyJg5eQ39Po5gbtiC8qWPPPgGuSF19e9X3Kj8pA4djFX0AO0BNGyXDm3SSRKNVVvuY24H5baxCzMz5yZYw_3d99TjI-8=@protonmail.com
Toggle quote (2 lines)
> The later, I'd say; we're all volunteers :-).

Fair enough!
J
J
Josselin Poiret wrote on 25 Aug 2023 18:30
87o7ivt77o.fsf@jpoiret.xyz
Hi everyone,

Simon Tournier <zimon.toutoune@gmail.com> writes:

Toggle quote (4 lines)
> Nitpick: Missing double space for sentences.
>
> Otherwise, LGTM.

Pushed as 9f68a2a9c41166ec5ac24c082bcd96c433dd2ede.

Closing.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCgAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmTo1zsQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaipS0C/4+RA7+BWDf4ETWbcyoLFoKmuggoPmePMO9
xQ4fwjrqfIf9YDoeSVHdsktcp5kim4SbE/4vxkNvCQdPpbeboDVO98KH9c9ZcZj4
ee9aHyMvkhy3EZEoiBtz/JGOAMGh7LsgGM6PN3t9EfCpSeYE6cYYfHy7Wo+Pm8gE
YA4a5/2YVepjXU5nc3FqPRXuKtpxyWHUKMLoxsFIx4ALm7UqZqlFYUAxMku9XFih
5/PXB5H43XjXyShkhivLCYd7jjgEij/wXHpGCmeFJs7Q1LRC99+7BFdc5Kpe/t7d
ZbupVBzmWfD1kekL+PycmnYlZS7S1qC9xBDLqdSdIzYioHu1mVUXgMoMQik9GSah
+jpfO1G4hxF2xGn7URX/3sswgBC2S+sYJJpSkR9C4dZVqbXShw/YtCRYaSAkIn5x
1zw8TN1s3cw6+bnPxNWenMeriL3Er66fjQ7DCPdxJ3IcF78t8wfzVntG9ngn6ypy
RrPycNuoyZw3/1g0MyoOBYAu0vZJKHA=
=OVGI
-----END PGP SIGNATURE-----

?