[PATCH] import: opam: opam->guix-package: Fix default repo argument.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Csepp
Owner
unassigned
Submitted by
Csepp
Severity
normal
C
(address . guix-patches@gnu.org)(address . raingloom@riseup.net)
20230321225952.5138-1-raingloom@riseup.net
* guix/import/opam.scm
(opam->guix-package): Make default repo a list of strings.
---
guix/import/opam.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/import/opam.scm b/guix/import/opam.scm
index fa4f678593..4d353248d9 100644
--- a/guix/import/opam.scm
+++ b/guix/import/opam.scm
@@ -340,7 +340,7 @@ (define (opam->guix-source url-dict)
(sha256 (base32 ,(guix-hash-url temp)))))))
'no-source-information)))
-(define* (opam->guix-package name #:key (repo 'opam) version #:allow-other-keys)
+(define* (opam->guix-package name #:key (repo '("opam")) version #:allow-other-keys)
"Import OPAM package NAME from REPOSITORY (a directory name) or, if
REPOSITORY is #f, from the official OPAM repository. Return a 'package' sexp
or #f on failure."
--
2.39.1
L
L
Ludovic Courtès wrote on 9 Apr 2023 00:10
(name . Csepp)(address . raingloom@riseup.net)(address . 62359-done@debbugs.gnu.org)
87edou9gae.fsf@gnu.org
Hi,

Csepp <raingloom@riseup.net> skribis:

Toggle quote (3 lines)
> * guix/import/opam.scm
> (opam->guix-package): Make default repo a list of strings.

I adjusted the docstring accordingly and applied it, thanks!

Ludo’.
Closed
?