[PATCH] gnu: Add cl-music-spelling.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20230321154410.4343-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (cl-music-spelling, ecl-music-spelling,
sbcl-music-spelling): New variables.
---
gnu/packages/lisp-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b7b504caff..15e929086e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -27490,6 +27490,35 @@ (define-public ecl-triads
`(modify-phases ,phases
(delete 'build-binary))))))))
+(define-public sbcl-music-spelling
+ (let ((commit "a2d492af440ad30a21042140cf8ffce4b73fbd42")
+ (revision "0"))
+ (package
+ (name "sbcl-music-spelling")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ntrocado/music-spelling")
+ (commit commit)))
+ (file-name (git-file-name "music-spelling" version))
+ (sha256
+ (base32 "0fgahb0jjr4sp2739d55gylmx8alsghnx3spyaqfqci4cxfrys52"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs (list sbcl-alexandria))
+ (home-page "https://github.com/ntrocado/music-spelling/")
+ (synopsis "Automatically spell musical pitches and rhythms")
+ (description "This package implements an algorithm for the spelling
+of enharmonics and dealing with ties and dots in rhythm notation.")
+ (license license:asl2.0))))
+
+(define-public cl-music-spelling
+ (sbcl-package->cl-source-package sbcl-music-spelling))
+
+(define-public ecl-music-spelling
+ (sbcl-package->ecl-package sbcl-music-spelling))
+
(define-public sbcl-closure-template
;; There are no releases since 2015.
(let ((commit "f1983aa525045691e128027d2a2d74831c873d6e")
--
2.39.2
G
G
Guillaume Le Vaillant wrote on 22 Mar 2023 14:39
(name . jgart)(address . jgart@dismail.de)(address . 62346-done@debbugs.gnu.org)
87y1nodhwp.fsf@kitej
Patch pushed as 72644ce13f96b109a88cf067cc6e75beba3e9dae.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZBsFFg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9tgwD/U6rn6tnzWnLyhVAWdG3y2XiZ/5MtcWNeW6/X
p45nseMA/0/jtnS/xkWz3vWnj6A/zOI9OXubElZEQfWQ4I62OAGp
=aB8R
-----END PGP SIGNATURE-----

Closed
?