[PATCH] gnu: nim: Update to 1.6.12.

  • Done
  • quality assurance status badge
Details
One participant
  • Gruruya
Owner
unassigned
Submitted by
Gruruya
Severity
normal
G
G
Gruruya wrote on 21 Mar 2023 15:16
08c022e165e3004433e931731c28b407e667d4cd.1679407667.git.greytest@disroot.org
* gnu/packages/nim: Update to 1.6.12.
[patch-installer]: Install /lib to right directory.
[patch-more-shebangs]: Edit substitute* to point to new osproc source.
---
gnu/packages/nim.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index 6da382119f..77c2463cca 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -36,14 +36,14 @@ (define-module (gnu packages nim)
(define-public nim
(package
(name "nim")
- (version "1.6.6")
+ (version "1.6.12")
(source
(origin
(method url-fetch)
(uri (string-append "https://nim-lang.org/download/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0lm4450ig8k4l3rzxv6kcqji5l1lzicsw76ckwxm0q9qdz713cb7"))))
+ (base32 "1hjd9dxhqzn2ifr988li8q7v6kxpxlcqbdllfd6lsq3knw50pvxc"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; TODO: Investigate tests failures.
@@ -55,6 +55,7 @@ (define-public nim
(let ((out (assoc-ref outputs "out")))
(substitute* "install.sh"
(("/usr/local") out)
+ (("/lib/nim") "/lib")
(("/opt/nimble") (string-append out "/share/nimble"))
(("configdir=/etc/nim")
(string-append "configdir=" out "/etc/nim"))))))
@@ -102,7 +103,7 @@ (define-public nim
"lib/pure/osproc.nim"
"lib/pure/strscans.nim")
(("/bin/sh") sh))
- (substitute* (find-files "c_code" "stdlib_osproc\\.nim\\.c")
+ (substitute* (find-files "c_code" "@m\\.\\.@slib@spure@sosproc\\.nim\\.c")
(("\"/bin/sh\", 7") (format #f "~s, ~s" sh (string-length sh)))))))
(replace 'build
(lambda* (#:key (parallel-build? #t) #:allow-other-keys)
--
2.40.0
G
G
greytest wrote on 21 Mar 2023 16:43
close: Duplicate of #62341
(address . 62342-done@debbugs.gnu.org)
d20242faca8abae41643e848bd618575@disroot.org
Attachment: file
Closed
?