[PATCH 0/2] Add: texlive-halloweenmath.

  • Done
  • quality assurance status badge
Details
One participant
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal
N
N
Nicolas Goaziou wrote on 21 Mar 2023 14:21
(address . guix-patches@gnu.org)
20230321132151.349930-1-mail@nicolasgoaziou.fr
Hello,

This patch set provides texlive-halloweenmath along with its required dependency. There may be a subtler way of fixing the build, but I couldn't find one.

Nicolas Goaziou (2):
gnu: Add texlive-pict2e.
gnu: Add texlive-halloweenmath.

gnu/packages/tex.scm | 119 ++++++++++++++++++++++++++++++++++++++++---
1 file changed, 111 insertions(+), 8 deletions(-)


base-commit: 3893758dac76fc30b23d4715e849e262306f268d
--
2.39.2
N
N
Nicolas Goaziou wrote on 21 Mar 2023 14:23
[PATCH 1/2] gnu: Add texlive-pict2e.
(address . 62331@debbugs.gnu.org)
20230321132355.349979-1-mail@nicolasgoaziou.fr
* gnu/packages/tex.scm (texlive-pict2e): New variable.
---
gnu/packages/tex.scm | 65 ++++++++++++++++++++++++++++++++++++++------
1 file changed, 57 insertions(+), 8 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0c4e545edf..f03a9608d5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4388,6 +4388,55 @@ (define-public texlive-latex-cyrillic
language that is written in a Cyrillic alphabet.")
(license license:lppl1.3c+)))
+(define-public texlive-pict2e
+ (let ((template (simple-texlive-package
+ "texlive-pict2e"
+ (list "doc/latex/pict2e/"
+ "source/latex/pict2e/"
+ "tex/latex/pict2e/")
+ (base32
+ "0pazv1khsgjhxc673qrhjrbzlkgmcj53qccb9hw7ygdajxrjc2ba"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "latex/pict2e")
+ ((#:build-targets _ '()) '(list "pict2e.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/pict2e/")))
+ (add-after 'build 'build-doc
+ (lambda _
+ (copy-file "p2e-drivers.dtx" "build/p2e-drivers.dtx")
+ (with-directory-excursion "build"
+ (invoke "pdflatex" "p2e-drivers.dtx")
+ (delete-file "p2e-drivers.dtx")
+ ;; texlive.tlpbd expects a "pict2e.cfg" configuration file
+ ;; instead of "pict2e-example.cfg". Please it.
+ (rename-file "pict2e-example.cfg" "pict2e.cfg"))))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://ctan.org/pkg/pict2e")
+ (native-inputs
+ (list (texlive-updmap.cfg)))
+ (synopsis "New implementation of picture commands")
+ (description
+ "This package extends the existing LaTeX @code{picture} environment,
+using the familiar technique (the @code{graphics} and @code{color} packages)
+of driver files (at present, drivers for dvips, pdfTeX, LuaTeX, XeTeX, VTeX,
+dvipdfm, and dvipdfmx are available). The package documentation has a fair
+number of examples of use, showing where things are improved by comparison
+with the LaTeX @code{picture} environment.")
+ (license license:lppl1.3+))))
+
(define-public texlive-psnfss
(let ((template (simple-texlive-package
"texlive-psnfss"
@@ -4495,14 +4544,14 @@ (define-public texlive-psnfss
(add-after 'unpack 'chdir
(lambda _
(chdir "source/latex/psnfss")))
- (add-before 'copy-files 'unchdir
- (lambda _
- (chdir "../../..")))
- (add-after 'copy-files 'delete-extra-files
- (lambda* (#:key outputs #:allow-other-keys)
- (delete-file-recursively
- (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/source/latex/psnfss/build"))))))))
+ (add-before 'copy-files 'unchdir
+ (lambda _
+ (chdir "../../..")))
+ (add-after 'copy-files 'delete-extra-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/source/latex/psnfss/build"))))))))
(native-inputs
(list texlive-cm))
(home-page "https://www.ctan.org/pkg/psnfss")

base-commit: 3893758dac76fc30b23d4715e849e262306f268d
--
2.39.2
N
N
Nicolas Goaziou wrote on 21 Mar 2023 14:23
[PATCH 2/2] gnu: Add texlive-halloweenmath.
(address . 62331@debbugs.gnu.org)
20230321132355.349979-2-mail@nicolasgoaziou.fr
* gnu/packages/tex.scm (texlive-halloweenmath): New variable.
---
gnu/packages/tex.scm | 54 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f03a9608d5..d71b2ae14f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1620,6 +1620,60 @@ (define-public texlive-tex-plain
discussed in the book).")
(license license:knuth)))
+(define-public texlive-halloweenmath
+ (let ((template (simple-texlive-package
+ "texlive-halloweenmath"
+ (list "doc/latex/halloweenmath/"
+ "source/latex/halloweenmath/"
+ "tex/latex/halloweenmath/")
+ (base32
+ "1xq72k1p820b5q3haxf936g69p6gv34hr30870l96jnxa3ad7y05"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "latex/halloweenmath")
+ ((#:build-targets _ '()) '(list "halloweenmath.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/halloweenmath/")))
+ (add-after 'chdir 'non-interactive-build
+ ;; When it realizes it cannot employ the usedir directive, the
+ ;; build process stops and waits for an input before inserting
+ ;; generated files in the working directory. Do not ask for
+ ;; an input.
+ (lambda _
+ (substitute* "halloweenmath.ins"
+ (("\\Ask.*") "")
+ (("\\(your .*? will be ignored\\).*") ""))))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (native-inputs
+ (list texlive-bin
+ texlive-kpathsea
+ (texlive-updmap.cfg))) ;for psfonts.map
+ (propagated-inputs
+ (list texlive-amsmath texlive-pict2e))
+ (home-page "https://ctan.org/pkg/halloweenmath")
+ (synopsis "Scary and creepy math symbols with AMS-LaTeX integration")
+ (description
+ "The package defines a handful of commands for typesetting mathematical
+symbols of various kinds, ranging from large operators to extensible
+arrow-like relations and growing arrow-like math accents that all draw from
+the classic Halloween-related iconography (pumpkins, witches, ghosts, cats,
+and so on) while being, at the same time, seamlessly integrated within the
+rest of the mathematics produced by (AmS-)LaTeX.")
+ (license license:lppl1.3+))))
+
(define-public texlive-hardwrap
(package
(inherit (simple-texlive-package
--
2.39.2
N
N
Nicolas Goaziou wrote on 21 Mar 2023 22:36
[PATCH v2 0/2] Add texlive-halloweenmath.
(address . 62331@debbugs.gnu.org)
20230321213613.372782-1-mail@nicolasgoaziou.fr
There was some artefact in the first patch, which I removed.

Nicolas Goaziou (2):
gnu: Add texlive-pict2e.
gnu: Add texlive-halloweenmath.

gnu/packages/tex.scm | 103 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 103 insertions(+)


base-commit: 3893758dac76fc30b23d4715e849e262306f268d
--
2.39.2
N
N
Nicolas Goaziou wrote on 21 Mar 2023 22:36
[PATCH v2 1/2] gnu: Add texlive-pict2e.
(address . 62331@debbugs.gnu.org)
20230321213613.372782-2-mail@nicolasgoaziou.fr
* gnu/packages/tex.scm (texlive-pict2e): New variable.
---
gnu/packages/tex.scm | 49 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0c4e545edf..89f5ba2942 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4388,6 +4388,55 @@ (define-public texlive-latex-cyrillic
language that is written in a Cyrillic alphabet.")
(license license:lppl1.3c+)))
+(define-public texlive-pict2e
+ (let ((template (simple-texlive-package
+ "texlive-pict2e"
+ (list "doc/latex/pict2e/"
+ "source/latex/pict2e/"
+ "tex/latex/pict2e/")
+ (base32
+ "0pazv1khsgjhxc673qrhjrbzlkgmcj53qccb9hw7ygdajxrjc2ba"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "latex/pict2e")
+ ((#:build-targets _ '()) '(list "pict2e.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/pict2e/")))
+ (add-after 'build 'build-doc
+ (lambda _
+ (copy-file "p2e-drivers.dtx" "build/p2e-drivers.dtx")
+ (with-directory-excursion "build"
+ (invoke "pdflatex" "p2e-drivers.dtx")
+ (delete-file "p2e-drivers.dtx")
+ ;; texlive.tlpbd expects a "pict2e.cfg" configuration file
+ ;; instead of "pict2e-example.cfg". Please it.
+ (rename-file "pict2e-example.cfg" "pict2e.cfg"))))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://ctan.org/pkg/pict2e")
+ (native-inputs
+ (list (texlive-updmap.cfg)))
+ (synopsis "New implementation of picture commands")
+ (description
+ "This package extends the existing LaTeX @code{picture} environment,
+using the familiar technique (the @code{graphics} and @code{color} packages)
+of driver files (at present, drivers for dvips, pdfTeX, LuaTeX, XeTeX, VTeX,
+dvipdfm, and dvipdfmx are available). The package documentation has a fair
+number of examples of use, showing where things are improved by comparison
+with the LaTeX @code{picture} environment.")
+ (license license:lppl1.3+))))
+
(define-public texlive-psnfss
(let ((template (simple-texlive-package
"texlive-psnfss"
--
2.39.2
N
N
Nicolas Goaziou wrote on 21 Mar 2023 22:36
[PATCH v2 2/2] gnu: Add texlive-halloweenmath.
(address . 62331@debbugs.gnu.org)
20230321213613.372782-3-mail@nicolasgoaziou.fr
* gnu/packages/tex.scm (texlive-halloweenmath): New variable.
---
gnu/packages/tex.scm | 54 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 89f5ba2942..4b07c8fe1a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1620,6 +1620,60 @@ (define-public texlive-tex-plain
discussed in the book).")
(license license:knuth)))
+(define-public texlive-halloweenmath
+ (let ((template (simple-texlive-package
+ "texlive-halloweenmath"
+ (list "doc/latex/halloweenmath/"
+ "source/latex/halloweenmath/"
+ "tex/latex/halloweenmath/")
+ (base32
+ "1xq72k1p820b5q3haxf936g69p6gv34hr30870l96jnxa3ad7y05"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "latex/halloweenmath")
+ ((#:build-targets _ '()) '(list "halloweenmath.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/halloweenmath/")))
+ (add-after 'chdir 'non-interactive-build
+ ;; When it realizes it cannot employ the usedir directive, the
+ ;; build process stops and waits for an input before inserting
+ ;; generated files in the working directory. Do not ask for
+ ;; an input.
+ (lambda _
+ (substitute* "halloweenmath.ins"
+ (("\\Ask.*") "")
+ (("\\(your .*? will be ignored\\).*") ""))))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (native-inputs
+ (list texlive-bin
+ texlive-kpathsea
+ (texlive-updmap.cfg))) ;for psfonts.map
+ (propagated-inputs
+ (list texlive-amsmath texlive-pict2e))
+ (home-page "https://ctan.org/pkg/halloweenmath")
+ (synopsis "Scary and creepy math symbols with AMS-LaTeX integration")
+ (description
+ "The package defines a handful of commands for typesetting mathematical
+symbols of various kinds, ranging from large operators to extensible
+arrow-like relations and growing arrow-like math accents that all draw from
+the classic Halloween-related iconography (pumpkins, witches, ghosts, cats,
+and so on) while being, at the same time, seamlessly integrated within the
+rest of the mathematics produced by (AmS-)LaTeX.")
+ (license license:lppl1.3+))))
+
(define-public texlive-hardwrap
(package
(inherit (simple-texlive-package
--
2.39.2
N
N
Nicolas Goaziou wrote on 30 Mar 2023 18:19
Re: [bug#62331] [PATCH v2 0/2] Add texlive-halloweenmath.
(address . 62331-done@debbugs.gnu.org)
875yaimcu4.fsf@nicolasgoaziou.fr
Toggle quote (6 lines)
> There was some artefact in the first patch, which I removed.
>
> Nicolas Goaziou (2):
> gnu: Add texlive-pict2e.
> gnu: Add texlive-halloweenmath.

Applied. Closing.
Closed
?