[PATCH core-updates 0/2] Fix qemu build

  • Done
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Josselin Poiret
Severity
normal
J
J
Josselin Poiret wrote on 20 Mar 2023 23:23
(address . guix-patches@gnu.org)(name . Josselin Poiret)(address . dev@jpoiret.xyz)
cover.1679350685.git.dev@jpoiret.xyz
Hi,

Quick patches to fix some dependencies of QEMU that didn't build on my side!

Best,

Josselin Poiret (2):
opensbi: Build with default gcc, with microarch rv64g
u-boot: Fix build under Python 3.10.

gnu/local.mk | 1 +
gnu/packages/bootloaders.scm | 3 ++
gnu/packages/firmware.scm | 4 ++-
.../u-boot-fix-build-python-3.10.patch | 35 +++++++++++++++++++
4 files changed, 42 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/u-boot-fix-build-python-3.10.patch

--
2.39.2
J
J
Josselin Poiret wrote on 20 Mar 2023 23:26
[PATCH core-updates 1/2] opensbi: Build with default gcc, with microarch rv64g
b08b5b8076d362a44f0043c50e7c999be0d5b9f0.1679350685.git.dev@jpoiret.xyz
* gnu/packages/firmware.scm (make-opensbi-package): Do it.
---
gnu/packages/firmware.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 956ece5d6d..9b9443effe 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -486,7 +486,7 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
(native-inputs
`(,@(if (and (not (string-prefix? "riscv64" (%current-system)))
(string-prefix? "riscv64" arch))
- `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu" #:xgcc gcc-7))
+ `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu"))
("cross-binutils" ,(cross-binutils "riscv64-linux-gnu")))
'())))
(arguments
@@ -499,6 +499,8 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
`("CC=gcc"))
"FW_PAYLOAD=n"
"V=1")
+ ;; fence.i instructions are used, so we need a non-default micro arch
+ #:configure-flags (list "-march=rv64g")
#:phases
(modify-phases %standard-phases
(delete 'configure)
--
2.39.2
J
J
Josselin Poiret wrote on 20 Mar 2023 23:26
[PATCH core-updates 2/2] u-boot: Fix build under Python 3.10.
63a067a83bcb04fae466b42c818abef4859dfffc.1679350685.git.dev@jpoiret.xyz
* gnu/packages/patches/u-boot-fix-build-python-3.10.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/bootloaders.scm (u-boot): Apply patch.
---
gnu/local.mk | 1 +
gnu/packages/bootloaders.scm | 3 ++
.../u-boot-fix-build-python-3.10.patch | 35 +++++++++++++++++++
3 files changed, 39 insertions(+)
create mode 100644 gnu/packages/patches/u-boot-fix-build-python-3.10.patch

Toggle diff (69 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 058b23c683..20bf2bea77 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1936,6 +1936,7 @@ dist_patch_DATA = \
%D%/packages/patches/tuxpaint-stamps-path.patch \
%D%/packages/patches/twinkle-bcg729.patch \
%D%/packages/patches/u-boot-allow-disabling-openssl.patch \
+ %D%/packages/patches/u-boot-fix-build-python-3.10.patch \
%D%/packages/patches/u-boot-infodocs-target.patch \
%D%/packages/patches/u-boot-patman-guix-integration.patch \
%D%/packages/patches/u-boot-nintendo-nes-serial.patch \
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index ac269807be..457f3b3994 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -655,6 +655,9 @@ (define u-boot
%u-boot-allow-disabling-openssl-patch
%u-boot-sifive-prevent-relocating-initrd-fdt
%u-boot-rk3399-enable-emmc-phy-patch
+ ;; FIXME The following patch is backported from 2023.01,
+ ;; remove when updating.
+ (search-patch "u-boot-fix-build-python-3.10.patch")
(search-patch "u-boot-infodocs-target.patch")
(search-patch "u-boot-patman-guix-integration.patch")))
(method url-fetch)
diff --git a/gnu/packages/patches/u-boot-fix-build-python-3.10.patch b/gnu/packages/patches/u-boot-fix-build-python-3.10.patch
new file mode 100644
index 0000000000..27c03f92f4
--- /dev/null
+++ b/gnu/packages/patches/u-boot-fix-build-python-3.10.patch
@@ -0,0 +1,35 @@
+From 7d01bb1c5a1daef0187c9ea276bde19a8d0e7fde Mon Sep 17 00:00:00 2001
+From: Michal Suchanek <msuchanek@suse.de>
+Date: Thu, 13 Oct 2022 22:43:41 +0200
+Subject: [PATCH] libfdt: Fix build with python 3.10
+
+Python 3.10 requires defining PY_SSIZE_T_CLEAN. This will be fixed in
+swig 4.10 but it is not clear when it will be released. There was a
+warning since python 3.8.
+
+Link: https://github.com/swig/swig/pull/2277
+
+Signed-off-by: Michal Suchanek <msuchanek@suse.de>
+Reviewed-by: Simon Glass <sjg@chromium.org>
+---
+ scripts/dtc/pylibfdt/libfdt.i_shipped | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/scripts/dtc/pylibfdt/libfdt.i_shipped b/scripts/dtc/pylibfdt/libfdt.i_shipped
+index 27c29ea260..56cc5d48f4 100644
+--- a/scripts/dtc/pylibfdt/libfdt.i_shipped
++++ b/scripts/dtc/pylibfdt/libfdt.i_shipped
+@@ -7,6 +7,10 @@
+
+ %module libfdt
+
++%begin %{
++#define PY_SSIZE_T_CLEAN
++%}
++
+ %include <stdint.i>
+
+ %{
+--
+GitLab
+
--
2.39.2
M
M
Maxim Cournoyer wrote on 21 Mar 2023 02:29
Re: bug#62309: [PATCH core-updates 0/2] Fix qemu build
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62309@debbugs.gnu.org)
87pm923n92.fsf_-_@gmail.com
Hi Josselin,

Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (2 lines)
> * gnu/packages/firmware.scm (make-opensbi-package): Do it.

Nitpick: The change log should state the change; it took me an instant
to realize the "Do it" meant implement the git summary description. The
summary can be more brief (or it could say the same if it fits under 80
chars).

Toggle quote (23 lines)
> gnu/packages/firmware.scm | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
> index 956ece5d6d..9b9443effe 100644
> --- a/gnu/packages/firmware.scm
> +++ b/gnu/packages/firmware.scm
> @@ -486,7 +486,7 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
> (native-inputs
> `(,@(if (and (not (string-prefix? "riscv64" (%current-system)))
> (string-prefix? "riscv64" arch))
> - `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu" #:xgcc gcc-7))
> + `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu"))
> ("cross-binutils" ,(cross-binutils "riscv64-linux-gnu")))
> '())))
> (arguments
> @@ -499,6 +499,8 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
> `("CC=gcc"))
> "FW_PAYLOAD=n"
> "V=1")
> + ;; fence.i instructions are used, so we need a non-default micro arch
> + #:configure-flags (list "-march=rv64g")

I don't quite understand, but then I don't know what is opensbi either,
so I'd have to read more. Or if you can expound a bit that comment for
neophytes like me, that'd be nice.

Thanks for the fix!

--
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 02:32
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62309@debbugs.gnu.org)
87lejq3n58.fsf_-_@gmail.com
Hello,

Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (20 lines)
> * gnu/packages/patches/u-boot-fix-build-python-3.10.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Register it.
> * gnu/packages/bootloaders.scm (u-boot): Apply patch.
> ---
> gnu/local.mk | 1 +
> gnu/packages/bootloaders.scm | 3 ++
> .../u-boot-fix-build-python-3.10.patch | 35 +++++++++++++++++++
> 3 files changed, 39 insertions(+)
> create mode 100644 gnu/packages/patches/u-boot-fix-build-python-3.10.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 058b23c683..20bf2bea77 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1936,6 +1936,7 @@ dist_patch_DATA = \
> %D%/packages/patches/tuxpaint-stamps-path.patch \
> %D%/packages/patches/twinkle-bcg729.patch \
> %D%/packages/patches/u-boot-allow-disabling-openssl.patch \
> + %D%/packages/patches/u-boot-fix-build-python-3.10.patch \

It probably doesn't matter too much, but the other lines use tabs to
align the backslash, while your change uses spaces.

Toggle quote (59 lines)
> %D%/packages/patches/u-boot-infodocs-target.patch \
> %D%/packages/patches/u-boot-patman-guix-integration.patch \
> %D%/packages/patches/u-boot-nintendo-nes-serial.patch \
> diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
> index ac269807be..457f3b3994 100644
> --- a/gnu/packages/bootloaders.scm
> +++ b/gnu/packages/bootloaders.scm
> @@ -655,6 +655,9 @@ (define u-boot
> %u-boot-allow-disabling-openssl-patch
> %u-boot-sifive-prevent-relocating-initrd-fdt
> %u-boot-rk3399-enable-emmc-phy-patch
> + ;; FIXME The following patch is backported from 2023.01,
> + ;; remove when updating.
> + (search-patch "u-boot-fix-build-python-3.10.patch")
> (search-patch "u-boot-infodocs-target.patch")
> (search-patch "u-boot-patman-guix-integration.patch")))
> (method url-fetch)
> diff --git a/gnu/packages/patches/u-boot-fix-build-python-3.10.patch b/gnu/packages/patches/u-boot-fix-build-python-3.10.patch
> new file mode 100644
> index 0000000000..27c03f92f4
> --- /dev/null
> +++ b/gnu/packages/patches/u-boot-fix-build-python-3.10.patch
> @@ -0,0 +1,35 @@
> +From 7d01bb1c5a1daef0187c9ea276bde19a8d0e7fde Mon Sep 17 00:00:00 2001
> +From: Michal Suchanek <msuchanek@suse.de>
> +Date: Thu, 13 Oct 2022 22:43:41 +0200
> +Subject: [PATCH] libfdt: Fix build with python 3.10
> +
> +Python 3.10 requires defining PY_SSIZE_T_CLEAN. This will be fixed in
> +swig 4.10 but it is not clear when it will be released. There was a
> +warning since python 3.8.
> +
> +Link: https://github.com/swig/swig/pull/2277
> +
> +Signed-off-by: Michal Suchanek <msuchanek@suse.de>
> +Reviewed-by: Simon Glass <sjg@chromium.org>
> +---
> + scripts/dtc/pylibfdt/libfdt.i_shipped | 4 ++++
> + 1 file changed, 4 insertions(+)
> +
> +diff --git a/scripts/dtc/pylibfdt/libfdt.i_shipped b/scripts/dtc/pylibfdt/libfdt.i_shipped
> +index 27c29ea260..56cc5d48f4 100644
> +--- a/scripts/dtc/pylibfdt/libfdt.i_shipped
> ++++ b/scripts/dtc/pylibfdt/libfdt.i_shipped
> +@@ -7,6 +7,10 @@
> +
> + %module libfdt
> +
> ++%begin %{
> ++#define PY_SSIZE_T_CLEAN
> ++%}
> ++
> + %include <stdint.i>
> +
> + %{
> +--
> +GitLab
> +

The rest LGTM.

--
Thanks,
Maxim
J
J
Josselin Poiret wrote on 21 Mar 2023 09:59
[PATCH core-updates v2 0/2] Fix qemu build
(address . 62309@debbugs.gnu.org)
cover.1679389017.git.dev@jpoiret.xyz
Hi Maxim,

Thanks for the review! Here's an updated patchset with the requested changes.
To be honest, I don't think anyone would care about gnu/local.mk alignment, but
that's a discussion for another time.

By the way, I don't really know what opensbi is for either :)

Best,

Josselin Poiret (2):
opensbi: Build with default gcc, with microarch rv64g
u-boot: Fix build under Python 3.10.

gnu/local.mk | 1 +
gnu/packages/bootloaders.scm | 3 ++
gnu/packages/firmware.scm | 7 +++-
.../u-boot-fix-build-python-3.10.patch | 35 +++++++++++++++++++
4 files changed, 45 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/u-boot-fix-build-python-3.10.patch

--
2.39.2
J
J
Josselin Poiret wrote on 21 Mar 2023 09:59
[PATCH core-updates v2 1/2] opensbi: Build with default gcc, with microarch rv64g
(address . 62309@debbugs.gnu.org)
f1b2b70c8fca32f850c453775d2e5ad7de5c8ebf.1679389017.git.dev@jpoiret.xyz
* gnu/packages/firmware.scm (make-opensbi-package): Remove specific #:xgcc for
the cross-toolchain, there is not reason for it now. Also set the microarch to
rv64g, so that it builds.
---
gnu/packages/firmware.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 956ece5d6d..0b7fff035a 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -486,7 +486,7 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
(native-inputs
`(,@(if (and (not (string-prefix? "riscv64" (%current-system)))
(string-prefix? "riscv64" arch))
- `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu" #:xgcc gcc-7))
+ `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu"))
("cross-binutils" ,(cross-binutils "riscv64-linux-gnu")))
'())))
(arguments
@@ -499,6 +499,11 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
`("CC=gcc"))
"FW_PAYLOAD=n"
"V=1")
+ ;; Direct __asm__ is used with fence.i instructions, which are not
+ ;; available in the generic riscv ISA. We need a micro-arch with
+ ;; support for it, and rv64g is the official ISA with support for
+ ;; fence.i.
+ #:configure-flags (list "-march=rv64g")
#:phases
(modify-phases %standard-phases
(delete 'configure)
--
2.39.2
J
J
Josselin Poiret wrote on 21 Mar 2023 09:59
[PATCH core-updates v2 2/2] u-boot: Fix build under Python 3.10.
(address . 62309@debbugs.gnu.org)
1896443a4ab3038fdbd1077a625178eeae1f737b.1679389017.git.dev@jpoiret.xyz
* gnu/packages/patches/u-boot-fix-build-python-3.10.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/bootloaders.scm (u-boot): Apply patch.
---
gnu/local.mk | 1 +
gnu/packages/bootloaders.scm | 3 ++
.../u-boot-fix-build-python-3.10.patch | 35 +++++++++++++++++++
3 files changed, 39 insertions(+)
create mode 100644 gnu/packages/patches/u-boot-fix-build-python-3.10.patch

Toggle diff (69 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 058b23c683..73cf7b89a1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1936,6 +1936,7 @@ dist_patch_DATA = \
%D%/packages/patches/tuxpaint-stamps-path.patch \
%D%/packages/patches/twinkle-bcg729.patch \
%D%/packages/patches/u-boot-allow-disabling-openssl.patch \
+ %D%/packages/patches/u-boot-fix-build-python-3.10.patch \
%D%/packages/patches/u-boot-infodocs-target.patch \
%D%/packages/patches/u-boot-patman-guix-integration.patch \
%D%/packages/patches/u-boot-nintendo-nes-serial.patch \
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index ac269807be..457f3b3994 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -655,6 +655,9 @@ (define u-boot
%u-boot-allow-disabling-openssl-patch
%u-boot-sifive-prevent-relocating-initrd-fdt
%u-boot-rk3399-enable-emmc-phy-patch
+ ;; FIXME The following patch is backported from 2023.01,
+ ;; remove when updating.
+ (search-patch "u-boot-fix-build-python-3.10.patch")
(search-patch "u-boot-infodocs-target.patch")
(search-patch "u-boot-patman-guix-integration.patch")))
(method url-fetch)
diff --git a/gnu/packages/patches/u-boot-fix-build-python-3.10.patch b/gnu/packages/patches/u-boot-fix-build-python-3.10.patch
new file mode 100644
index 0000000000..27c03f92f4
--- /dev/null
+++ b/gnu/packages/patches/u-boot-fix-build-python-3.10.patch
@@ -0,0 +1,35 @@
+From 7d01bb1c5a1daef0187c9ea276bde19a8d0e7fde Mon Sep 17 00:00:00 2001
+From: Michal Suchanek <msuchanek@suse.de>
+Date: Thu, 13 Oct 2022 22:43:41 +0200
+Subject: [PATCH] libfdt: Fix build with python 3.10
+
+Python 3.10 requires defining PY_SSIZE_T_CLEAN. This will be fixed in
+swig 4.10 but it is not clear when it will be released. There was a
+warning since python 3.8.
+
+Link: https://github.com/swig/swig/pull/2277
+
+Signed-off-by: Michal Suchanek <msuchanek@suse.de>
+Reviewed-by: Simon Glass <sjg@chromium.org>
+---
+ scripts/dtc/pylibfdt/libfdt.i_shipped | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/scripts/dtc/pylibfdt/libfdt.i_shipped b/scripts/dtc/pylibfdt/libfdt.i_shipped
+index 27c29ea260..56cc5d48f4 100644
+--- a/scripts/dtc/pylibfdt/libfdt.i_shipped
++++ b/scripts/dtc/pylibfdt/libfdt.i_shipped
+@@ -7,6 +7,10 @@
+
+ %module libfdt
+
++%begin %{
++#define PY_SSIZE_T_CLEAN
++%}
++
+ %include <stdint.i>
+
+ %{
+--
+GitLab
+
--
2.39.2
M
M
Maxim Cournoyer wrote on 21 Mar 2023 17:07
Re: [PATCH core-updates v2 1/2] opensbi: Build with default gcc, with microarch rv64g
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62309@debbugs.gnu.org)
874jqeozpy.fsf@gmail.com
Hello!

Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (33 lines)
> * gnu/packages/firmware.scm (make-opensbi-package): Remove specific #:xgcc for
> the cross-toolchain, there is not reason for it now. Also set the microarch to
> rv64g, so that it builds.
> ---
> gnu/packages/firmware.scm | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
> index 956ece5d6d..0b7fff035a 100644
> --- a/gnu/packages/firmware.scm
> +++ b/gnu/packages/firmware.scm
> @@ -486,7 +486,7 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
> (native-inputs
> `(,@(if (and (not (string-prefix? "riscv64" (%current-system)))
> (string-prefix? "riscv64" arch))
> - `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu" #:xgcc gcc-7))
> + `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu"))
> ("cross-binutils" ,(cross-binutils "riscv64-linux-gnu")))
> '())))
> (arguments
> @@ -499,6 +499,11 @@ (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
> `("CC=gcc"))
> "FW_PAYLOAD=n"
> "V=1")
> + ;; Direct __asm__ is used with fence.i instructions, which are not
> + ;; available in the generic riscv ISA. We need a micro-arch with
> + ;; support for it, and rv64g is the official ISA with support for
> + ;; fence.i.
> + #:configure-flags (list "-march=rv64g")
> #:phases
> (modify-phases %standard-phases
> (delete 'configure)

LGTM, thanks for expounding the comment as suggested!

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 21 Mar 2023 17:14
Re: [PATCH core-updates v2 2/2] u-boot: Fix build under Python 3.10.
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62309@debbugs.gnu.org)
87zg86nksl.fsf@gmail.com
Hi Josselin,

Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (33 lines)
> * gnu/packages/patches/u-boot-fix-build-python-3.10.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Register it.
> * gnu/packages/bootloaders.scm (u-boot): Apply patch.
> ---
> gnu/local.mk | 1 +
> gnu/packages/bootloaders.scm | 3 ++
> .../u-boot-fix-build-python-3.10.patch | 35 +++++++++++++++++++
> 3 files changed, 39 insertions(+)
> create mode 100644 gnu/packages/patches/u-boot-fix-build-python-3.10.patch
>
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 058b23c683..73cf7b89a1 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -1936,6 +1936,7 @@ dist_patch_DATA = \
> %D%/packages/patches/tuxpaint-stamps-path.patch \
> %D%/packages/patches/twinkle-bcg729.patch \
> %D%/packages/patches/u-boot-allow-disabling-openssl.patch \
> + %D%/packages/patches/u-boot-fix-build-python-3.10.patch \
> %D%/packages/patches/u-boot-infodocs-target.patch \
> %D%/packages/patches/u-boot-patman-guix-integration.patch \
> %D%/packages/patches/u-boot-nintendo-nes-serial.patch \
> diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
> index ac269807be..457f3b3994 100644
> --- a/gnu/packages/bootloaders.scm
> +++ b/gnu/packages/bootloaders.scm
> @@ -655,6 +655,9 @@ (define u-boot
> %u-boot-allow-disabling-openssl-patch
> %u-boot-sifive-prevent-relocating-initrd-fdt
> %u-boot-rk3399-enable-emmc-phy-patch
> + ;; FIXME The following patch is backported from 2023.01,
> + ;; remove when updating.

FIXME and other similar comment prefixes are more conventionally used
with a colon (FIXME: ...), I think. I also prefer to keep the patch
origin tracking in the patch itself (and 'guix lint' checks for that
nowadays, at least in some cases). The patch should fail to apply when
after it's included in a release.

Feel free to push with these suggested changes.

--
Thanks,
Maxim
J
J
Josselin Poiret wrote on 21 Mar 2023 19:32
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 62309@debbugs.gnu.org)
87zg86q7jo.fsf@jpoiret.xyz
Hi Maxim,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (6 lines)
> FIXME and other similar comment prefixes are more conventionally used
> with a colon (FIXME: ...), I think. I also prefer to keep the patch
> origin tracking in the patch itself (and 'guix lint' checks for that
> nowadays, at least in some cases). The patch should fail to apply when
> after it's included in a release.

Right, I added this FIXME in the heat of the moment. I don't really
mind either way, although I find it nice that when it fails to apply,
anyone can see this comment and conclude that it should be ok to remove
(as opposed to some patches failing because they're not up to date).
What do you mean by "patch origin tracking", and it being taken care of
by `guix lint`?

Toggle quote (2 lines)
> Feel free to push with these suggested changes.

I don't know if this was directed at me or committers, but I'll just add
that I do not have commit rights, if anyone else wants to have a look
and push :)

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmQZ+EsQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5FhcaivcoC/kBVQSdlRYUm2pM1KY4y7uPKfjnLbAH/Nry
gmhmJQKKPY5VLUsw68pzFRDAoMCyxEXw7Qhyu3//j3S8WE9jGKy/9GUWUlRlq5PX
aGps4xcPfkCDonSd7cX9avEH4lGwZEpL9uCf3DpBtLSPCYtB8xDOBP5w0KUqYh6C
86DOV+KSVuedGJHSGEzddDXaxc5PeK9+GI3UxAH9jaAaKWlAF6FtGLd6bXRrece6
86VR1Ml6bY8SSWjgCSBdA48WKDVx6d58MkWOD41Or6aT5URTMYgbdGhXpfa8zMRq
EZFCdSPSRRVEOMvz9GsZ8BBJ6mt8Sjh9g4hpspV5Qh5xYqPaCfzjzHvUWZ+TbSj5
kyi1kWA8/Mq/qc7196eOfvmsazCEYB60gYndHzpDdCFZFnkcJKsxV7VhJP+sHVRZ
/EaEnAODXiSPZft3N/4kUGQnKQP9giHqEDQ1L6h61uSsz37lQdPICecK0dNJPHT5
VZgT14+M5sdatAiHTugQmk1OmCcr8kI=
=bKxN
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 22 Mar 2023 19:23
(name . Josselin Poiret)(address . dev@jpoiret.xyz)(address . 62309@debbugs.gnu.org)
87v8isfxvn.fsf@gmail.com
Hi,

Josselin Poiret <dev@jpoiret.xyz> writes:

Toggle quote (23 lines)
> Hi Maxim,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> FIXME and other similar comment prefixes are more conventionally used
>> with a colon (FIXME: ...), I think. I also prefer to keep the patch
>> origin tracking in the patch itself (and 'guix lint' checks for that
>> nowadays, at least in some cases). The patch should fail to apply when
>> after it's included in a release.
>
> Right, I added this FIXME in the heat of the moment. I don't really
> mind either way, although I find it nice that when it fails to apply,
> anyone can see this comment and conclude that it should be ok to remove
> (as opposed to some patches failing because they're not up to date).
> What do you mean by "patch origin tracking", and it being taken care of
> by `guix lint`?
>
>> Feel free to push with these suggested changes.
>
> I don't know if this was directed at me or committers, but I'll just add
> that I do not have commit rights, if anyone else wants to have a look
> and push :)

It was directed at you, I thought you already had commit rights :-).

--
Thanks,
Maxim
L
L
Ludovic Courtès wrote on 26 Mar 2023 22:30
Re: bug#62309: [PATCH core-updates 0/2] Fix qemu build
(name . Josselin Poiret)(address . dev@jpoiret.xyz)
87edpbb6hu.fsf_-_@gnu.org
Hi,

Pushed both patches as 68793b702e4295d011c89e72826fd15ce18e0b95, with
the cosmetic changes Maxim proposed.

Thanks!

Ludo’.
Closed
?