[PATCH] gnu: Add payload-dumper.

  • Done
  • quality assurance status badge
Details
5 participants
  • Andrew Tropin
  • conses
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Miguel Ángel Moreno
Owner
unassigned
Submitted by
conses
Severity
normal
C
C
conses wrote on 15 Mar 2023 13:34
(address . guix-patches@gnu.org)(address . contact@conses.eu)
863566xkg6.fsf@conses.eu
* gnu/packages/android.scm (payload-dumper): New variable.
---
gnu/packages/android.scm | 53 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 53 insertions(+)

Toggle diff (79 lines)
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 881b75d763..d7a308775f 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -51,6 +51,7 @@ (define-module (gnu packages android)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
#:use-module (gnu packages pcre)
+ #:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
@@ -982,6 +983,58 @@ (define-public git-repo
script that you can put anywhere in your path.")
(license license:asl2.0)))
+(define-public payload-dumper
+ (let ((commit "35134a28d641deda899c30aed57aace21bfd4a3c")
+ (revision "0"))
+ (package
+ (name "payload-dumper")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/vm03/payload_dumper")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sdq6dgva5yxz147bkv8xbf79pz60vwc33f0cmj9awgfbxha2b43"))))
+ (inputs
+ (list python-3 python-protobuf python-six python-bsdiff4))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:use-setuptools? #f
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (begin
+ (use-modules (guix build utils))
+ (let* ((python (string-append
+ #$(this-package-input "python")
+ "/bin"))
+ (bin (string-append #$output "/bin"))
+ (target (string-append bin "/payload_dumper"))
+ (version (python-version
+ #$(this-package-input "python")))
+ (pydir (string-append #$output "/lib/python"
+ version "/site-packages")))
+ (mkdir-p bin)
+ (copy-file (string-append #$source "/payload_dumper.py")
+ target)
+ (install-file "update_metadata_pb2.py" pydir)
+ (substitute* target
+ (("/usr/bin/env python") (which "python3")))
+ (chmod target #o555))))))))
+ (synopsis "Android OTA payload dumper")
+ (description "Script to extract the payload of incremental and full
+OTA's.")
+ (home-page "https://github.com/vm03/payload_dumper")
+ (license license:gpl3+))))
+
(define-public abootimg
(package
(name "abootimg")
--
2.39.1



--
Best regards,
conses
A
A
Andrew Tropin wrote on 13 Jun 2023 12:58
87r0qf1vda.fsf@trop.in
On 2023-03-15 13:34, conses wrote:

Toggle quote (79 lines)
> * gnu/packages/android.scm (payload-dumper): New variable.
> ---
> gnu/packages/android.scm | 53 ++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 53 insertions(+)
>
> diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
> index 881b75d763..d7a308775f 100644
> --- a/gnu/packages/android.scm
> +++ b/gnu/packages/android.scm
> @@ -51,6 +51,7 @@ (define-module (gnu packages android)
> #:use-module (gnu packages java)
> #:use-module (gnu packages linux)
> #:use-module (gnu packages pcre)
> + #:use-module (gnu packages protobuf)
> #:use-module (gnu packages python)
> #:use-module (gnu packages python-crypto)
> #:use-module (gnu packages python-web)
> @@ -982,6 +983,58 @@ (define-public git-repo
> script that you can put anywhere in your path.")
> (license license:asl2.0)))
>
> +(define-public payload-dumper
> + (let ((commit "35134a28d641deda899c30aed57aace21bfd4a3c")
> + (revision "0"))
> + (package
> + (name "payload-dumper")
> + (version (git-version "0" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/vm03/payload_dumper")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1sdq6dgva5yxz147bkv8xbf79pz60vwc33f0cmj9awgfbxha2b43"))))
> + (inputs
> + (list python-3 python-protobuf python-six python-bsdiff4))
> + (build-system python-build-system)
> + (arguments
> + (list
> + #:use-setuptools? #f
> + #:tests? #f
> + #:phases
> + #~(modify-phases %standard-phases
> + (delete 'build)
> + (replace 'install
> + (lambda* (#:key outputs #:allow-other-keys)
> + (begin
> + (use-modules (guix build utils))
> + (let* ((python (string-append
> + #$(this-package-input "python")
> + "/bin"))
> + (bin (string-append #$output "/bin"))
> + (target (string-append bin "/payload_dumper"))
> + (version (python-version
> + #$(this-package-input "python")))
> + (pydir (string-append #$output "/lib/python"
> + version "/site-packages")))
> + (mkdir-p bin)
> + (copy-file (string-append #$source "/payload_dumper.py")
> + target)
> + (install-file "update_metadata_pb2.py" pydir)
> + (substitute* target
> + (("/usr/bin/env python") (which "python3")))
> + (chmod target #o555))))))))
> + (synopsis "Android OTA payload dumper")
> + (description "Script to extract the payload of incremental and full
> +OTA's.")
> + (home-page "https://github.com/vm03/payload_dumper")
> + (license license:gpl3+))))
> +
> (define-public abootimg
> (package
> (name "abootimg")
> --
> 2.39.1

Hi Miguel!

I can't find the license for this project, can you ask an author to
specify it, please?

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmSIS/EACgkQIgjSCVjB
3rA0XQ//bBAsOlbOX71BwgwZ+QGgRHWnwpfkUFH6HHbYVc1+63MB8RHFEGEEGy2y
J7R+xZo8+h3wPB8fIOKSJS2oOTKoVGlN4drsKkC32qtRjcvj8d3dxPct4ziaxsda
J0hOV1DmPPfE0SfzovQDzadUz2buZV28pSQD4eIG3vMJcLsZWY7IUVwFY28PA2Nl
eAOOHHmk/QVH8144aWQtz7C6U4Oe1ni7mCBpAb2uKQ9VblB4zSbiv5r8T+i4Ok2n
3oUVMBcOx/xFpfVwXiDydN9MnzSMaN4r1pmTxZeCccwdVTrplya54ePU9teSwN1i
QYjdb6r6L/WrSWthccCambbraCkJgfqM2ZcRmVmQTETxC8cE7zhz/6yhIo0wtMlC
zhfysokhqF3Te9Fo0fLlOqZEsnURHjLuty8HbtR8tpuH4Buqhz4NnZWnjKz/24Iz
dd9PCerqk13swKbB2EE/iCwN7U6o9u9cUAiWBdGWdgcAGDfhp1lPuVr1icD+Jeby
0OzJLy14yXuiFQhWfntJeqjtEJIqMQreokRsKiLobaJaH18TskyN/lALg4OZDgz0
thRKX5Ll2l5gi510rtSeQWH5ZQbGPeGTvMPwM0i++U5IDI2asPgEukLPf7w6+eOv
hlS3nMTAZCPiReCCViltfQXeMvo4GCNZMJwnHSyIqOUMliKf7ZQ=
=DdT8
-----END PGP SIGNATURE-----

M
M
Miguel Ángel Moreno wrote on 28 Jun 2023 09:51
Re: [PATCH] gnu: Add payload-dumper.
(address . 62201@debbugs.gnu.org)
86o7l010tu.fsf@migalmoreno.com
Hi Andrew,

Thanks for having a look. I raised an issue on the repo, but
the maintainer told me he isn't the original author of the tool and thus
doesn't feel comfortable adding a license to it, see
proceed in this case?

--
Best regards,
Miguel Ángel Moreno
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEESVbayLB3FeqfFOE67x9pv18j9FgFAmSb5o0ACgkQ7x9pv18j
9Fi6cw/+MdJtljMcxUEpuZeTLQXY86jjGs+CozHatVZaP5kLj0/GbT6QoKQBooxM
1JZLk0ABLhNO38F0fHg7A4wkoLAY7zZMSWk9ouIdJ8FxzbOM13kzysBgmBncd3ed
dhTEsS1+/MeI/kVhFprSMrLR1gNxhXYhfxbCxpE1nvqQAszj5FUA1qA4BVnzTyVf
5ri9c42UDU4uzDKpbPLyZRZXY6wBz3lwKnL2AdmYRCsKqlCMAAOw/Gecf58No2KB
CSE7Uumd9eXLvGQ/H62tBeSexGM1oOPWrdwC8XQIGkkq5lzHvPTpcQAKL2Gh6n5P
sQgS18Pbl602wOXOzdbIF3Ejrd9WxVkowSDkG3EAgN0uHr8Ngp7BRZpqFRrrW6z1
n6j7eR47AVsqKbDUGq50HVIyweXXRQ5p3PhKnTCq+zXUh6lqmb8sjIoZVGiiE2Tv
IMKm4YO9xL8KhYBN4JVHMl3w+DpbbeejO/ZcM9M6357nVMdxgJuOPdFQdpu65CiI
tmjU+t8jQjNahcqRbljSFHYtKaRzZmtWufj1MQpijxyUCMLp9zllda2wIspvMoMl
5Twya4QEtabmzReXkkkO3KVYo/sWoY3Dvx1vFecuN1K9636TgLy/dXOy0nR2lfPq
LMav6Xp6ydoZwR9neoybjoZwdzfHlSk1on2J1K2jpuQuzxgJLEU=
=FSxL
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 29 Jun 2023 15:14
87bkgyfm1o.fsf@trop.in
On 2023-06-28 09:51, Miguel Ángel Moreno wrote:

Toggle quote (8 lines)
> Hi Andrew,
>
> Thanks for having a look. I raised an issue on the repo, but
> the maintainer told me he isn't the original author of the tool and thus
> doesn't feel comfortable adding a license to it, see
> <https://github.com/vm03/payload_dumper/issues/58>. How should we
> proceed in this case?

I would summon more advanced in this topic colleagues :)

CCed Ludo and Liliana.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmSdg6MACgkQIgjSCVjB
3rBULg/+N4EUEAoyBxmbq5uTnafFqv34HCgE3lLgATRZtYNa3oeBd6UG+PMzCOjI
BMgENtaNFk1v1e02iD+qTbTEsrjb/Rw2Av0n+XxE6D6d2iTBP3g5dB724/Tv4RAu
2sLInPI7pzt7gbtUT4/+f79QRQwx4btECmdt/6fD8km81uAWHkfpocPCr/h2hLiE
B0xV7Cnekz7SOOV3KBSGTRt9ltA8qspZmh8Np92DTDOrd3lBPJTF35VHTJ3pRuEp
rncpeYloEyRrCv2Dxm+PW/SbRBPaEUEeN3OTPRteld2+8jL+xR7qnjYwJMwxB3N8
AoQy2szRTrFtgO5i1olcvIBcS8FjVU87/kw7Cr55DIZ+cRMj/R50wC+Jsryj53r/
B+drxeVnlEVSMdbECMaozNSy5jEheruQJ4skEERkusPyfIYdYt2+E+C8OuCciDfJ
aJpU6KsTKr4z4UI69dqRkTXjoInJbkheps9fasIOJAuNnXVwbZ1S1GioiMGG1+ve
+uaCpcBwV6fIpb7OENzjTe/qKnCH0WfVDQXd6OsqpTwb3uoM4ej6czAPQrvC305u
9uxjt97iOANfeQwA0HPd/hN3XCS1+bsO7re/AyBZ0phMQ6O+gTslYx+fSXPP57MT
i4p+dc6GcODjMj5N9UYDUbUDPiYptvx/z1REfn8C52zIXw1Ioio=
=HyRr
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 29 Jun 2023 18:59
(name . Ludovic Courtès)(address . ludo@gnu.org)
3c0e73e6fab7fbb8394f509a427315aee6f299a6.camel@gmail.com
Am Donnerstag, dem 29.06.2023 um 17:14 +0400 schrieb Andrew Tropin:
Toggle quote (13 lines)
> On 2023-06-28 09:51, Miguel Ángel Moreno wrote:
>
> > Hi Andrew,
> >
> > Thanks for having a look.  I raised an issue on the repo, but
> > the maintainer told me he isn't the original author of the tool and
> > thus doesn't feel comfortable adding a license to it, see
> > <https://github.com/vm03/payload_dumper/issues/58>.  How should we
> > proceed in this case?
>
> I would summon more advanced in this topic colleagues :)
>
> CCed Ludo and Liliana.
No license, no original source? No, thanks.  
For more background, see [1,2].

Cheers

M
M
Miguel Ángel Moreno wrote on 30 Jun 2023 10:52
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
86jzvlbade.fsf@migalmoreno.com
On 2023-06-29 18:59, Liliana Marie Prikler wrote:

Toggle quote (22 lines)
> Am Donnerstag, dem 29.06.2023 um 17:14 +0400 schrieb Andrew Tropin:
>> On 2023-06-28 09:51, Miguel Ángel Moreno wrote:
>>
>> > Hi Andrew,
>> >
>> > Thanks for having a look.  I raised an issue on the repo, but
>> > the maintainer told me he isn't the original author of the tool and
>> > thus doesn't feel comfortable adding a license to it, see
>> > <https://github.com/vm03/payload_dumper/issues/58>.  How should we
>> > proceed in this case?
>>
>> I would summon more advanced in this topic colleagues :)
>>
>> CCed Ludo and Liliana.
> No license, no original source? No, thanks.  
> For more background, see [1,2].
>
> Cheers
>
> [1] https://www.gnu.org/licenses/license-list.html#NoLicense
> [2] https://www.gnu.org/licenses/license-list.html.en#NoLicense

Thanks for the heads up. Unless Ludo or someone else has some pointers
on what could be done to tackle this scenario, I'll try to package this
elsewhere.

--
Best regards,
Miguel Ángel Moreno
L
L
Ludovic Courtès wrote on 10 Jul 2023 23:29
(name . Miguel Ángel Moreno)(address . mail@migalmoreno.com)
87r0pf78vv.fsf@gnu.org
Hi,

Miguel Ángel Moreno <mail@migalmoreno.com> skribis:

Toggle quote (28 lines)
> On 2023-06-29 18:59, Liliana Marie Prikler wrote:
>
>> Am Donnerstag, dem 29.06.2023 um 17:14 +0400 schrieb Andrew Tropin:
>>> On 2023-06-28 09:51, Miguel Ángel Moreno wrote:
>>>
>>> > Hi Andrew,
>>> >
>>> > Thanks for having a look.  I raised an issue on the repo, but
>>> > the maintainer told me he isn't the original author of the tool and
>>> > thus doesn't feel comfortable adding a license to it, see
>>> > <https://github.com/vm03/payload_dumper/issues/58>.  How should we
>>> > proceed in this case?
>>>
>>> I would summon more advanced in this topic colleagues :)
>>>
>>> CCed Ludo and Liliana.
>> No license, no original source? No, thanks.  
>> For more background, see [1,2].
>>
>> Cheers
>>
>> [1] https://www.gnu.org/licenses/license-list.html#NoLicense
>> [2] https://www.gnu.org/licenses/license-list.html.en#NoLicense
>
> Thanks for the heads up. Unless Ludo or someone else has some pointers
> on what could be done to tackle this scenario, I'll try to package this
> elsewhere.

Sorry for the delay! If there’s no license, it’s indeed not
even distributable, so definitely not suitable for Guix.

Ludo’.
Closed
?