[PATCH] gnu: Add emacs-nyxt.

  • Done
  • quality assurance status badge
Details
2 participants
  • conses
  • Nicolas Goaziou
Owner
unassigned
Submitted by
conses
Severity
normal
C
C
conses wrote on 15 Mar 2023 13:19
(address . guix-patches@gnu.org)(address . contact@conses.eu)
867cvixl4p.fsf@conses.eu
* gnu/packages/emacs-xyz.scm (emacs-nyxt): New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c067fe16c..fdd2202b3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27498,6 +27498,27 @@ (define-public emacs-nix-mode
comments.")
(license license:lgpl2.1+)))
+(define-public emacs-nyxt
+ (package
+ (name "emacs-nyxt")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~conses/nyxt.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hgb10pk5m3v2gsl4h6i821nyzksss0rk4hhjnfb7nm98lalzbl6"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-sly))
+ (home-page "https://git.sr.ht/~conses/nyxt.el")
+ (synopsis "Interact with Nyxt from Emacs.")
+ (description "This package consists of custom logic to interact with
+Nyxt from Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-libmpdel
(package
(name "emacs-libmpdel")
--
2.39.1



--
Best regards,
conses
N
N
Nicolas Goaziou wrote on 21 Mar 2023 10:04
(name . conses)(address . contact@conses.eu)(address . 62200@debbugs.gnu.org)
87bkkm326c.fsf@nicolasgoaziou.fr
Hello,

conses <contact@conses.eu> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-nyxt): New variable.

Thank you.

Toggle quote (4 lines)
> + (synopsis "Interact with Nyxt from Emacs.")
> + (description "This package consists of custom logic to interact with
> +Nyxt from Emacs.")

Should Nyxt be an input? In this case, you need to set `nyxt-path'
variable accordingly.

Regards,
--
Nicolas Goaziou
C
C
conses wrote on 21 Mar 2023 12:17
[PATCH v2] gnu: Add emacs-nyxt.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
86lejq1hho.fsf@conses.eu
* gnu/packages/emacs-xyz.scm (emacs-nyxt): New variable.
---
* Add nyxt as input.
* Fix nyxt-path executable.
gnu/packages/emacs-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b1f72ee009..2e70baf5a0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -256,6 +256,7 @@ (define-module (gnu packages emacs-xyz)
#:use-module (gnu packages erlang)
#:use-module (gnu packages statistics)
#:use-module (gnu packages libcanberra)
+ #:use-module (gnu packages web-browsers)
#:use-module (gnu packages wget)
#:use-module (guix utils)
#:use-module (srfi srfi-1)
@@ -27628,6 +27629,36 @@ (define-public emacs-nix-mode
comments.")
(license license:lgpl2.1+)))
+(define-public emacs-nyxt
+ (package
+ (name "emacs-nyxt")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~conses/nyxt.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hgb10pk5m3v2gsl4h6i821nyzksss0rk4hhjnfb7nm98lalzbl6"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "nyxt.el"
+ ("nyxt-path"
+ (search-input-file inputs "/bin/nyxt"))))))))
+ (inputs (list nyxt))
+ (propagated-inputs (list emacs-sly))
+ (home-page "https://git.sr.ht/~conses/nyxt.el")
+ (synopsis "Interact with Nyxt from Emacs")
+ (description "This package consists of custom logic to interact with
+Nyxt from Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-libmpdel
(package
(name "emacs-libmpdel")
--
2.39.1



--
Best regards,
conses
N
N
Nicolas Goaziou wrote on 24 Mar 2023 10:17
(name . conses)(address . contact@conses.eu)(address . 62200-done@debbugs.gnu.org)
874jqazex1.fsf@nicolasgoaziou.fr
Hello,

conses <contact@conses.eu> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-nyxt): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?