[PATCH 0/3] Add youplot.

  • Done
  • quality assurance status badge
Details
2 participants
  • gemmaro
  • Nicolas Goaziou
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 13 Mar 2023 14:49
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cover.1678715004.git.gemmaro.dev@gmail.com
Hello,

This patch series adds YouPlot, a command line tool that draws plots on the
terminal.

Thank you,
gemmaro.

gemmaro (3):
gnu: Add ruby-enumerable-statistics.
gnu: Add ruby-unicode-plot.
gnu: Add youplot.

gnu/packages/plotutils.scm | 55 +++++++++++++++++++++++++++++++++++++
gnu/packages/statistics.scm | 40 +++++++++++++++++++++++++++
2 files changed, 95 insertions(+)


base-commit: 1ed227d7952af48efe50a2f6c9537e17c356daa1
--
2.39.2
G
G
gemmaro wrote on 13 Mar 2023 14:53
[PATCH 1/3] gnu: Add ruby-enumerable-statistics.
(address . 62161@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
fa06331dc62e3df4133f401151c8f3560f9459a9.1678715004.git.gemmaro.dev@gmail.com
* gnu/packages/statistics.scm (ruby-enumerable-statistics): Add new variable.
---
gnu/packages/statistics.scm | 40 +++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 4037eec768..a3cc79cbde 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,7 @@ (define-module (gnu packages statistics)
#:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
+ #:use-module (guix build-system ruby)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -82,6 +84,7 @@ (define-module (gnu packages statistics)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages ssh)
@@ -7365,3 +7368,40 @@ (define-public r-mumin
weights derived from information criteria (AICc and alike) or custom model
weighting schemes.")
(license license:gpl2)))
+
+(define-public ruby-enumerable-statistics
+ (package
+ (name "ruby-enumerable-statistics")
+ (version "2.0.7")
+ ;; Source at RubyGems.org doesn't have tests.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkn/enumerable-statistics.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a8k2dvm1v0g6hcrbnzy0f7d63hdmpmldfdkl8wr32nbl05xnifa"))
+ (modules '((guix build utils)))
+ (snippet `(begin
+ (substitute* "enumerable-statistics.gemspec"
+ ;; benchmark-driver gem is used for
+ ;; performance benchmarking, and isn't
+ ;; needed for tests.
+ (("spec.add_development_dependency \"benchmark-driver\"\n")
+ ""))))))
+ (build-system ruby-build-system)
+ (native-inputs (list bundler
+ ruby-rake
+ ruby-rake-compiler
+ ruby-rspec
+ ruby-test-unit
+ ruby-fuubar
+ ruby-yard))
+ (synopsis "Library which provides statistics features for Enumerable")
+ (description
+ "@code{Enumerable::Statistics} provides some methods to calculate
+statistical summary in arrays and enumerables.")
+ (home-page "https://github.com/mrkn/enumerable-statistics")
+ (license license:expat)))
--
2.39.2
G
G
gemmaro wrote on 13 Mar 2023 14:53
[PATCH 2/3] gnu: Add ruby-unicode-plot.
(address . 62161@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
27b987b3ea326da884b88b2dc210584da1fc2faa.1678715004.git.gemmaro.dev@gmail.com
* gnu/packages/plotutils.scm (ruby-unicode-plot): New variable.
---
gnu/packages/plotutils.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 963587ca2e..34f507e825 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@ (define-module (gnu packages plotutils)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system ruby)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
@@ -50,7 +52,9 @@ (define-module (gnu packages plotutils)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages statistics)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tex)
#:use-module (gnu packages web)
@@ -427,3 +431,28 @@ (define-public asymptote
;; noted otherwise, are released under version 3 (or later) of the GNU
;; Lesser General Public License"
(license license:lgpl3+)))
+
+(define-public ruby-unicode-plot
+ (package
+ (name "ruby-unicode-plot")
+ (version "0.0.5")
+ ;; Source at RubyGems.org doesn't have test fixtures.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/red-data-tools/unicode_plot.rb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g67brnb7zp1xx9cp1x7bmyxwnvi2i8gplw7p1j7cppzin4kr1vj"))))
+ (build-system ruby-build-system)
+ (native-inputs (list bundler ruby-rake ruby-test-unit ruby-yard))
+ (propagated-inputs (list ruby-enumerable-statistics))
+ (synopsis "Library to plot your data by Unicode characters")
+ (description "UnicodePlot provides the feature to make charts with Unicode
+characters. Supported charts are: barplot, boxplot, densityplot,
+histogram, lineplot, and scatterplot.")
+ (home-page "https://github.com/red-data-tools/unicode_plot.rb")
+ (license license:expat)))
--
2.39.2
G
G
gemmaro wrote on 13 Mar 2023 14:53
[PATCH 3/3] gnu: Add youplot.
(address . 62161@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
a9012126839e6944d6f07a73adfbbdd184c2a249.1678715004.git.gemmaro.dev@gmail.com
* gnu/packages/plotutils.scm (youplot): New variable.
---
gnu/packages/plotutils.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 34f507e825..fdda6d4871 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -456,3 +456,29 @@ (define-public ruby-unicode-plot
histogram, lineplot, and scatterplot.")
(home-page "https://github.com/red-data-tools/unicode_plot.rb")
(license license:expat)))
+
+(define-public youplot
+ (package
+ (name "youplot")
+ (version "0.4.5")
+ ;; Source at RubyGems.org doesn't have tests.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/red-data-tools/YouPlot")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1y54apw7hx9mhjnf277w9wayvq954mdnip4dpajhc0qjg2464c2b"))))
+ (build-system ruby-build-system)
+ (native-inputs (list ruby-rake ruby-simplecov ruby-test-unit))
+ (propagated-inputs (list ruby-unicode-plot))
+ (synopsis "Command line tool that draw plots on the terminal")
+ (description
+ "YouPlot is a command line tool that draws plots on the terminal,
+powered by UnicodePlot gem. It provides commands @command{youplot}
+and @command{uplot} (shorthand) are provided, and supports chart types
+of barplot, histogram, lineplot, scatter, density, boxplot, and count.")
+ (home-page "https://github.com/red-data-tools/YouPlot")
+ (license license:expat)))
--
2.39.2
N
N
Nicolas Goaziou wrote on 2 Apr 2023 22:31
Re: [bug#62161] [PATCH 0/3] Add youplot.
(name . gemmaro)(address . gemmaro.dev@gmail.com)(address . 62161-done@debbugs.gnu.org)
878rfajaaa.fsf@nicolasgoaziou.fr
Hello,

gemmaro <gemmaro.dev@gmail.com> writes:

Toggle quote (3 lines)
> This patch series adds YouPlot, a command line tool that draws plots on the
> terminal.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?