[PATCH] gnu: Add dvisvgm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Thomas Albers
Owner
unassigned
Submitted by
Thomas Albers
Severity
normal
T
T
Thomas Albers wrote on 8 Mar 2023 19:32
(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20230308183241.11930-1-thomas@thomaslabs.org
* gnu/packages/tex.scm (dvisvgm): New variable.
---
gnu/packages/tex.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f178bafcc2..c03885b268 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2022 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +64,8 @@ (define-module (gnu packages tex)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages lisp)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
@@ -8297,6 +8300,47 @@ (define-public texmaker
develop documents with LaTeX, in a single application.")
(license license:gpl2+)))
+(define-public dvisvgm
+ (package
+ (name "dvisvgm")
+ (version "3.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mgieseki/dvisvgm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11r401yqbw61n1mwsfk5qmwx2c92djwpl0q756qkds5kh25l9ci8"))))
+ (native-inputs (list pkg-config
+ autoconf
+ autoconf-archive
+ automake
+ python-wrapper
+ libtool))
+ (inputs (list texlive-libkpathsea
+ freetype
+ fontforge
+ clipper
+ ghostscript
+ xxhash
+ google-brotli
+ woff2
+ zlib))
+ (build-system gnu-build-system)
+ (synopsis "Command-line utility for generating SVG from DVI, EPS and PDF
+files")
+ (description
+ "Dvisvgm converts TeX DVI, EPS and PDF files into an
+SVG (Scalable Vector Graphics) image. It provides full font support including
+virtual fonts, font maps and sub-fonts. The embedded SVG fonts can optionally
+be replaced with graphics paths for applications that do not support SVG
+fonts. Dvisvgm supports also colors, emTeX, tpic, papersize, PDF mapfile
+and PostScript specials. A working TeX installation in needed.")
+ (home-page "https://dvisvgm.de/")
+ (license license:gpl3+)))
+
(define-public teximpatient
;; The homepage seems to be distributing this version which is currently the
;; most recent commit
--
2.39.1
T
T
Thomas Albers Raviola wrote on 8 Mar 2023 19:48
Typo
(address . 62057@debbugs.gnu.org)
871qlzgjul.fsf@alpha.mail-host-address-is-not-set
Too late I noticed a typo in the description. A fixed patch follows.

Sorry,

Thomas
T
T
Thomas Albers wrote on 8 Mar 2023 19:49
[PATCH] gnu: Add dvisvgm.
(address . 62057@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20230308184908.13234-1-thomas@thomaslabs.org
* gnu/packages/tex.scm (dvisvgm): New variable.
---
gnu/packages/tex.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f178bafcc2..5c47619f18 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2022 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -63,6 +64,8 @@ (define-module (gnu packages tex)
#:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
+ #:use-module (gnu packages digest)
#:use-module (gnu packages lisp)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
@@ -8297,6 +8300,47 @@ (define-public texmaker
develop documents with LaTeX, in a single application.")
(license license:gpl2+)))
+(define-public dvisvgm
+ (package
+ (name "dvisvgm")
+ (version "3.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mgieseki/dvisvgm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11r401yqbw61n1mwsfk5qmwx2c92djwpl0q756qkds5kh25l9ci8"))))
+ (native-inputs (list pkg-config
+ autoconf
+ autoconf-archive
+ automake
+ python-wrapper
+ libtool))
+ (inputs (list texlive-libkpathsea
+ freetype
+ fontforge
+ clipper
+ ghostscript
+ xxhash
+ google-brotli
+ woff2
+ zlib))
+ (build-system gnu-build-system)
+ (synopsis "Command-line utility for generating SVG from DVI, EPS and PDF
+files")
+ (description
+ "Dvisvgm converts TeX DVI, EPS and PDF files into an
+SVG (Scalable Vector Graphics) image. It provides full font support including
+virtual fonts, font maps and sub-fonts. The embedded SVG fonts can optionally
+be replaced with graphics paths for applications that do not support SVG
+fonts. Dvisvgm supports also colors, emTeX, tpic, papersize, PDF mapfile
+and PostScript specials. A working TeX installation is needed.")
+ (home-page "https://dvisvgm.de/")
+ (license license:gpl3+)))
+
(define-public teximpatient
;; The homepage seems to be distributing this version which is currently the
;; most recent commit
--
2.39.1
L
L
Ludovic Courtès wrote on 21 Mar 2023 19:01
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 62057-done@debbugs.gnu.org)
87mt46dlv6.fsf_-_@gnu.org
Hi,

Thomas Albers <thomas@thomaslabs.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/tex.scm (dvisvgm): New variable.

Applied, thanks!

Ludo’.
Closed
?