[PATCH] gnu: Add pdpmake.

  • Done
  • quality assurance status badge
Details
2 participants
  • jlicht
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jlicht
Severity
normal
J
J
jlicht wrote on 26 Feb 2023 22:07
(address . guix-patches@gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
3b71ad97ddce58927caa0e716acfa0f441e10d4e.1677445672.git.jlicht@fsfe.org
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/build-tools.scm (pdpmake): New variable.
---

gnu/packages/build-tools.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 28ab77bbb4..3e63f87d73 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -1006,3 +1006,35 @@ (define-public gnulib
#:version "2022-12-31"
#:commit "875461ffdf58ac04677957b4ae4160465b83b940"
#:hash (base32 "0bf7a6wdns9c5wwv60qfcn9llg0j6jz5ryd2qgsqqx2i6xkmp77c")))
+
+(define-public pdpmake
+ (package
+ (name "pdpmake")
+ (version "1.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rmyorston/pdpmake")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fjx5imd7s0h0yy8h2qc4vkdq7kxqcljnrw6h8n88720xha5z3cb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:test-target "test"
+ #:parallel-tests? #f
+ #:make-flags #~(list "DESTDIR=\"\""
+ (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://frippery.org/make/")
+ (synopsis "POSIX make")
+ (description
+ "This package contains an implementation of POSIX make. The default
+configuration enables extensions. Generally these extensions are compatible
+with GNU make.")
+ (license license:public-domain)))
--
2.39.1
J
J
jlicht wrote on 9 Mar 2023 17:27
[PATCH v2] gnu: Add pdpmake.
(address . 61827@debbugs.gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
ff2634d5f29ee7653d44029e79f38914979a45f2.1678379251.git.jlicht@fsfe.org
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/build-tools.scm (pdpmake): New variable.

---

Changes in v2:
- Clarify license of testsuite code (gplv2)

gnu/packages/build-tools.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 28ab77bbb4..b803a7342e 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -1006,3 +1006,37 @@ (define-public gnulib
#:version "2022-12-31"
#:commit "875461ffdf58ac04677957b4ae4160465b83b940"
#:hash (base32 "0bf7a6wdns9c5wwv60qfcn9llg0j6jz5ryd2qgsqqx2i6xkmp77c")))
+
+(define-public pdpmake
+ (package
+ (name "pdpmake")
+ (version "1.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rmyorston/pdpmake")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fjx5imd7s0h0yy8h2qc4vkdq7kxqcljnrw6h8n88720xha5z3cb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:test-target "test"
+ #:parallel-tests? #f
+ #:make-flags #~(list "DESTDIR=\"\""
+ (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://frippery.org/make/")
+ (synopsis "POSIX make")
+ (description
+ "This package contains an implementation of POSIX make. The default
+configuration enables extensions. Generally these extensions are compatible
+with GNU make.")
+ ;; pdpmake is distributed under the public domain, but the sources include
+ ;; tests under the GPL license version 2.
+ (license (list license:gpl2 license:public-domain)))
--
2.39.1
J
J
jlicht wrote on 10 Mar 2023 12:32
[PATCH v3] gnu: Add pdpmake.
(address . 61827@debbugs.gnu.org)(name . Jelle Licht)(address . jlicht@fsfe.org)
2c3f599e298d094ffc449bee267787c56b8bfb73.1678447940.git.jlicht@fsfe.org
From: Jelle Licht <jlicht@fsfe.org>

* gnu/packages/build-tools.scm (pdpmake): New variable.

---

Changes in v3:
- PEBKAC mistake with patman.

Changes in v2:
- Clarify license of testsuite code (gplv2)

gnu/packages/build-tools.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 28ab77bbb4..1348529360 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -1006,3 +1006,37 @@ (define-public gnulib
#:version "2022-12-31"
#:commit "875461ffdf58ac04677957b4ae4160465b83b940"
#:hash (base32 "0bf7a6wdns9c5wwv60qfcn9llg0j6jz5ryd2qgsqqx2i6xkmp77c")))
+
+(define-public pdpmake
+ (package
+ (name "pdpmake")
+ (version "1.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rmyorston/pdpmake")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fjx5imd7s0h0yy8h2qc4vkdq7kxqcljnrw6h8n88720xha5z3cb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:test-target "test"
+ #:parallel-tests? #f
+ #:make-flags #~(list "DESTDIR=\"\""
+ (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX="
+ #$output))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://frippery.org/make/")
+ (synopsis "POSIX make")
+ (description
+ "This package contains an implementation of POSIX make. The default
+configuration enables extensions. Generally these extensions are compatible
+with GNU make.")
+ ;; pdpmake is distributed under the public domain, but the sources include
+ ;; tests under the GPL license version 2.
+ (license (list license:gpl2 license:public-domain))))
--
2.39.1
N
N
Nicolas Goaziou wrote on 3 Apr 2023 18:33
(address . jlicht@fsfe.org)(address . 61827-done@debbugs.gnu.org)
87y1n9ncwb.fsf@nicolasgoaziou.fr
Hello,

jlicht@fsfe.org writes:

Toggle quote (2 lines)
> * gnu/packages/build-tools.scm (pdpmake): New variable.

Applied (yesterday)! Thank you.

Regards,
--
Nicolas Goaziou
Closed
?