[PATCH] gnu: Add tmux-plugin-continuum.

  • Done
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • EuAndreh
  • Ludovic Courtès
Owner
unassigned
Submitted by
EuAndreh
Severity
normal
E
E
EuAndreh wrote on 26 Feb 2023 21:14
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20230226201456.26435-1-eu@euandre.org
* gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
---

Notes:
I've ran guix lint and style locally successfully, and also built twice
with --rounds=2 to verify determinism.
The lint says it can be upgraded to v3.1.0, but that version is older
then the packaged commit, from around ~2015. There hasn't been any Git
tag ever since.

gnu/packages/tmux.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 67ce18fea1..ec6bf78559 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -317,3 +317,43 @@ (define-public tmux-plugin-resurrect
@end itemize")
(home-page "https://github.com/tmux-plugins/tmux-resurrect/")
(license license:expat))))
+
+(define-public tmux-plugin-continuum
+ (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
+ (revision "0"))
+ (package
+ (name "tmux-plugin-continuum")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tmux-plugins/tmux-continuum/")
+ (commit commit)))
+ (sha256
+ (base32
+ "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((out (string-append %output
+ "/share/tmux-plugins/continuum/")))
+ (mkdir-p out)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ out)))))
+ (synopsis "Continous saving of tmux environment")
+ (description
+ "Features:
+
+@itemize
+@item continuous saving of tmux environment
+@item automatic tmux start when computer/server is turned on
+@item automatic restore when tmux is started
+@end itemize
+
+Together, these features enable uninterrupted tmux usage. No matter the
+computer or server restarts, if the machine is on, tmux will be there how you
+left it off the last time it was used.")
+ (home-page "https://github.com/tmux-plugins/tmux-continuum/")
+ (license license:expat))))
--
2.39.1
E
E
EuAndreh wrote on 11 Mar 2023 22:01
(address . 61823@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20230311210134.12015-1-eu@euandre.org
* gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
---

This version addresses the new linter offense that the CI raised.

gnu/packages/tmux.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 67ce18fea1..9a2ab7ffbe 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -317,3 +317,44 @@ (define-public tmux-plugin-resurrect
@end itemize")
(home-page "https://github.com/tmux-plugins/tmux-resurrect/")
(license license:expat))))
+
+(define-public tmux-plugin-continuum
+ (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
+ (revision "0"))
+ (package
+ (name "tmux-plugin-continuum")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tmux-plugins/tmux-continuum/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((out (string-append %output
+ "/share/tmux-plugins/continuum/")))
+ (mkdir-p out)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ out)))))
+ (synopsis "Continous saving of tmux environment")
+ (description
+ "Features:
+
+@itemize
+@item continuous saving of tmux environment
+@item automatic tmux start when computer/server is turned on
+@item automatic restore when tmux is started
+@end itemize
+
+Together, these features enable uninterrupted tmux usage. No matter the
+computer or server restarts, if the machine is on, tmux will be there how you
+left it off the last time it was used.")
+ (home-page "https://github.com/tmux-plugins/tmux-continuum/")
+ (license license:expat))))
--
2.39.2
G
G
Greg Hogan wrote on 16 May 2023 22:01
(name . EuAndreh)(address . eu@euandre.org)(address . 61823@debbugs.gnu.org)
CA+3U0Zk6gCit9u6BUupJM6PMRcxLMSe=1UwpG_rHTkQMGHGJhw@mail.gmail.com
On Sat, Mar 11, 2023 at 4:21?PM EuAndreh via Guix-patches via
<guix-patches@gnu.org> wrote:
Toggle quote (45 lines)
>
> * gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
> ---
>
> This version addresses the new linter offense that the CI raised.
>
> gnu/packages/tmux.scm | 41 +++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 41 insertions(+)
>
> diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
> index 67ce18fea1..9a2ab7ffbe 100644
> --- a/gnu/packages/tmux.scm
> +++ b/gnu/packages/tmux.scm
> @@ -317,3 +317,44 @@ (define-public tmux-plugin-resurrect
> @end itemize")
> (home-page "https://github.com/tmux-plugins/tmux-resurrect/")
> (license license:expat))))
> +
> +(define-public tmux-plugin-continuum
> + (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
> + (revision "0"))
> + (package
> + (name "tmux-plugin-continuum")
> + (version (git-version "0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/tmux-plugins/tmux-continuum/")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
> + (build-system trivial-build-system)
> + (arguments
> + `(#:modules ((guix build utils))
> + #:builder (begin
> + (use-modules (guix build utils))
> + (let ((out (string-append %output
> + "/share/tmux-plugins/continuum/")))
> + (mkdir-p out)
> + (copy-recursively (assoc-ref %build-inputs "source")
> + out)))))
> + (synopsis "Continous saving of tmux environment")

Continous -> Continuous (thanks spell check!)

Toggle quote (17 lines)
> + (description
> + "Features:
> +
> +@itemize
> +@item continuous saving of tmux environment
> +@item automatic tmux start when computer/server is turned on
> +@item automatic restore when tmux is started
> +@end itemize
> +
> +Together, these features enable uninterrupted tmux usage. No matter the
> +computer or server restarts, if the machine is on, tmux will be there how you
> +left it off the last time it was used.")
> + (home-page "https://github.com/tmux-plugins/tmux-continuum/")
> + (license license:expat))))
> --
> 2.39.2

I am able to load and configure settings for this plugin. I have not
been able to fully test the operation due to my use of "oh my tmux"
and the challenges of integrating into the status bar. The patch looks
good to my eyes other than the synopsis spelling noted above.
E
E
EuAndreh wrote on 17 May 2023 14:24
[PATCH] gnu: Add tmux-plugin-continuum.
(address . 61823@debbugs.gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20230517122405.13299-1-eu@euandre.org
* gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
---

Notes:
Fixed the spelling XD

gnu/packages/tmux.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 67ce18fea1..7ed3c6aef3 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -317,3 +317,44 @@ (define-public tmux-plugin-resurrect
@end itemize")
(home-page "https://github.com/tmux-plugins/tmux-resurrect/")
(license license:expat))))
+
+(define-public tmux-plugin-continuum
+ (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
+ (revision "0"))
+ (package
+ (name "tmux-plugin-continuum")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tmux-plugins/tmux-continuum/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((out (string-append %output
+ "/share/tmux-plugins/continuum/")))
+ (mkdir-p out)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ out)))))
+ (synopsis "Continuous saving of tmux environment")
+ (description
+ "Features:
+
+@itemize
+@item continuous saving of tmux environment
+@item automatic tmux start when computer/server is turned on
+@item automatic restore when tmux is started
+@end itemize
+
+Together, these features enable uninterrupted tmux usage. No matter the
+computer or server restarts, if the machine is on, tmux will be there how you
+left it off the last time it was used.")
+ (home-page "https://github.com/tmux-plugins/tmux-continuum/")
+ (license license:expat))))

base-commit: c8e599b9391f789a8a3e2183fc8f0c2a5061ceb0
--
2.39.2
E
E
EuAndreh wrote on 17 May 2023 14:27
(name . Greg Hogan)(address . code@greghogan.com)(address . 61823@debbugs.gnu.org)
b3819728-0678-601f-6405-05ab55a2acfe@euandre.org
Also, I have been running the
tmux-plugin-continuum+tmux-plugin-resurrect combo for some months now
with no hiccups so far.
E
E
EuAndreh wrote on 17 May 2023 14:28
(address . 61823@debbugs.gnu.org)
1c8e92fe-5567-7661-3576-75f494f3d436@euandre.org
This version was rebased with master.
L
L
Ludovic Courtès wrote on 8 Jun 2023 23:43
Re: bug#61823: [PATCH] gnu: Add tmux-plugin-continuum.
(name . EuAndreh)(address . eu@euandre.org)(address . 61823-done@debbugs.gnu.org)
87y1kty6j4.fsf_-_@gnu.org
Hi,

EuAndreh <eu@euandre.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.

Finally applied, thanks!

Ludo’.
Closed
?