EuAndreh wrote 2 years ago
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
* gnu/packages/tmux.scm (tmux-plugin-continuum): New variable.
---
Notes:
I've ran guix lint and style locally successfully, and also built twice
with --rounds=2 to verify determinism.
The lint says it can be upgraded to v3.1.0, but that version is older
then the packaged commit, from around ~2015. There hasn't been any Git
tag ever since.
gnu/packages/tmux.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)
Toggle diff (50 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 67ce18fea1..ec6bf78559 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -317,3 +317,43 @@ (define-public tmux-plugin-resurrect
@end itemize")
(home-page "https://github.com/tmux-plugins/tmux-resurrect/")
(license license:expat))))
+
+(define-public tmux-plugin-continuum
+ (let ((commit "3e4bc35da41f956c873aea716c97555bf1afce5d")
+ (revision "0"))
+ (package
+ (name "tmux-plugin-continuum")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tmux-plugins/tmux-continuum/")
+ (commit commit)))
+ (sha256
+ (base32
+ "1py8qfs2f93hkxhk039m813bjgcs5k54si662gx05g3czqy06pb7"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((out (string-append %output
+ "/share/tmux-plugins/continuum/")))
+ (mkdir-p out)
+ (copy-recursively (assoc-ref %build-inputs "source")
+ out)))))
+ (synopsis "Continous saving of tmux environment")
+ (description
+ "Features:
+
+@itemize
+@item continuous saving of tmux environment
+@item automatic tmux start when computer/server is turned on
+@item automatic restore when tmux is started
+@end itemize
+
+Together, these features enable uninterrupted tmux usage. No matter the
+computer or server restarts, if the machine is on, tmux will be there how you
+left it off the last time it was used.")
+ (home-page "https://github.com/tmux-plugins/tmux-continuum/")
+ (license license:expat))))
--
2.39.1