[PATCH] gnu: swig: Update to 4.1.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 20 Feb 2023 02:31
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230220013133.5643-1-atai@atai.org
* gnu/packages/swig.scm (swig): update to 4.1.1
---
gnu/packages/swig.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 1f4bd0922a..b02fd3e4be 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -35,7 +35,7 @@ (define-module (gnu packages swig)
(define-public swig
(package
(name "swig")
- (version "4.0.2")
+ (version "4.1.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/"
@@ -43,10 +43,10 @@ (define-public swig
name "-" version ".tar.gz"))
(sha256
(base32
- "1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))))
+ "16xc767gf5ip40jh698wbdrxrghli5v2c966bkdmrmpwv378mw1a"))))
(build-system gnu-build-system)
(native-inputs (list boost
- `(,pcre "bin") ;for 'pcre-config'
+ pcre2
;; The following are for tests and examples:
guile-3.0
perl))

base-commit: 037c1b254a84d656b87b6bbb9c339bc04cfdb0a8
prerequisite-patch-id: e6b6a6497169170006695e94999cab21cfb49152
prerequisite-patch-id: 6cf6e26806f47b9f8b8592138dab5a51a4224b89
--
2.39.1
A
A
Andy Tai wrote on 20 Feb 2023 08:06
[PATCH v2] gnu: swig: Update to 4.1.1
(address . 61644@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230220070614.23663-1-atai@atai.org
* gnu/packages/swig.scm (swig): update to 4.1.1
---
gnu/packages/swig.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 1f4bd0922a..b02fd3e4be 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -35,7 +35,7 @@ (define-module (gnu packages swig)
(define-public swig
(package
(name "swig")
- (version "4.0.2")
+ (version "4.1.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/"
@@ -43,10 +43,10 @@ (define-public swig
name "-" version ".tar.gz"))
(sha256
(base32
- "1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))))
+ "16xc767gf5ip40jh698wbdrxrghli5v2c966bkdmrmpwv378mw1a"))))
(build-system gnu-build-system)
(native-inputs (list boost
- `(,pcre "bin") ;for 'pcre-config'
+ pcre2
;; The following are for tests and examples:
guile-3.0
perl))

base-commit: 037c1b254a84d656b87b6bbb9c339bc04cfdb0a8
prerequisite-patch-id: e6b6a6497169170006695e94999cab21cfb49152
prerequisite-patch-id: 6cf6e26806f47b9f8b8592138dab5a51a4224b89
--
2.39.1
A
A
Andy Tai wrote on 21 Feb 2023 00:28
[PATCH v3] gnu: swig: Update to 4.1.1
(address . 61644@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230220232835.12694-1-atai@atai.org
* gnu/packages/swig.scm (swig): update to 4.1.1
---
gnu/packages/swig.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 1f4bd0922a..c45a6a5b2b 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -35,7 +35,7 @@ (define-module (gnu packages swig)
(define-public swig
(package
(name "swig")
- (version "4.0.2")
+ (version "4.1.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/" name "/" name "/"
@@ -43,15 +43,15 @@ (define-public swig
name "-" version ".tar.gz"))
(sha256
(base32
- "1z06m5zv87mha6hvys1iay810ghc1jngilfby1ms2n4d1mryjfym"))))
+ "16xc767gf5ip40jh698wbdrxrghli5v2c966bkdmrmpwv378mw1a"))))
(build-system gnu-build-system)
(native-inputs (list boost
- `(,pcre "bin") ;for 'pcre-config'
+ pcre2
;; The following are for tests and examples:
guile-3.0
perl))
;;("python" ,python-wrapper)
- (inputs (list pcre))
+ (inputs (list pcre2))
(home-page "http://swig.org/")
(synopsis
"Interface compiler that connects C/C++ code to higher-level languages")

base-commit: 037c1b254a84d656b87b6bbb9c339bc04cfdb0a8
prerequisite-patch-id: e6b6a6497169170006695e94999cab21cfb49152
prerequisite-patch-id: 6cf6e26806f47b9f8b8592138dab5a51a4224b89
--
2.39.1
A
A
Andy Tai wrote on 23 Mar 2023 06:34
[PATCH v4] gnu: Add swig-next
(address . 61644@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20230323053437.11875-1-atai@atai.org
* gnu/packages/swig.scm (swig-next): New variable.
---
gnu/packages/swig.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index b5195e2cc5..74f42a3b52 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -65,3 +65,21 @@ (define-public swig
;; See http://www.swig.org/Release/LICENSE for details.
(license gpl3+)))
+
+(define-public swig-next
+ ;; a number of packages using swig do not build with this version
+ ;; so we need to keep swig 4.0.2 above and place the current release
+ ;; as swig-next
+ (package
+ (inherit swig)
+ (name "swig")
+ (version "4.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "/"
+ name "-" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16xc767gf5ip40jh698wbdrxrghli5v2c966bkdmrmpwv378mw1a"))))
+ (inputs (list pcre2))))

base-commit: 5174820753be045ba4fc7cc93da33f4e0b730bc3
prerequisite-patch-id: 88a340e0d72bd9cd0531b3441c54210b443c4318
--
2.39.2
L
L
Ludovic Courtès wrote on 8 Jun 2023 23:21
Re: bug#61644: [PATCH] gnu: swig: Update to 4.1.1
(name . Andy Tai)(address . atai@atai.org)(address . 61644-done@debbugs.gnu.org)
87ilbxzm4h.fsf_-_@gnu.org
Andy Tai <atai@atai.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/swig.scm (swig-next): New variable.

Finally applied, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 61644@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 61644
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch