[PATCH] gnu: Add labwc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Feng Shu
Owner
unassigned
Submitted by
Feng Shu
Severity
normal
F
F
Feng Shu wrote on 7 Feb 2023 06:18
(name . guix-patches)(address . guix-patches@gnu.org)
87sffiuk8l.fsf@163.com
From: Feng Shu <tumashu@163.com>

* gnu/packages/wm.scm (labwc): New variable.
---
gnu/packages/wm.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 32aa5f39e5..ae9bf46623 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -109,6 +109,7 @@
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gawk)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gperf)
@@ -2712,6 +2713,48 @@ for wayland conceptually based on the X11 window manager
@command{ratpoison}.")
(license license:expat)))
+(define-public labwc
+ (package
+ (name "labwc")
+ (version "0.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/labwc/labwc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ap1d0p2fs3c4yj0v82hb3x4s5699wsf6a79sgnmpkw0nhsyvyrx"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config gettext-minimal))
+ (inputs
+ (list cairo
+ glib
+ libxcb
+ libxml2
+ pango
+ scdoc
+ wlroots))
+ (home-page "https://labwc.github.io")
+ (synopsis "Labwc is a wlroots-based window-stacking compositor for wayland")
+ (description
+ "Labwc is light-weight and independent with a focus on simply stacking
+windows well and rendering some window decorations, it is inspired by openbox.
+It takes a no-bling/frills approach and says no to features such as icons
+(except window buttons), animations, decorative gradients and any other
+options not required to reasonably render common themes. It relies on clients
+for panels, screenshots, wallpapers and so on to create a full desktop
+environment.
+
+Labwc tries to stay in keeping with wlroots and sway in terms of general
+approach and coding style.
+
+Labwc has no reliance on any particular Desktop Environment, Desktop Shell or
+session. Nor does it depend on any UI toolkits such as Qt or GTK.")
+ (license license:gpl2)))
+
(define-public libucl
(package
(name "libucl")
--
2.30.2


--
F
F
Feng Shu wrote on 10 May 2023 05:07
(address . 61338@debbugs.gnu.org)
87y1lwj33s.fsf@163.com
From aba920372c247046088a34bdd20b514ba8706786 Mon Sep 17 00:00:00 2001
Date: Wed, 10 May 2023 10:38:48 +0800

* gnu/packages/wm.scm (labwc): New variable.
---
gnu/packages/wm.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 28e4c04814..954f0d3971 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -112,6 +112,7 @@
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gawk)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gperf)
@@ -2808,6 +2809,48 @@ for wayland conceptually based on the X11 window manager
read and write, and compatible with JSON.")
(license license:bsd-2)))
+(define-public labwc
+ (package
+ (name "labwc")
+ (version "0.6.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/labwc/labwc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zbgj8r8ppvqnz2imh6f825f2lvsqpiqfa0r5g5r4nsvadiipivp"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config gettext-minimal))
+ (inputs
+ (list cairo
+ glib
+ libxcb
+ libxml2
+ pango
+ scdoc
+ wlroots))
+ (home-page "https://labwc.github.io")
+ (synopsis "Labwc is a wlroots-based window-stacking compositor for wayland")
+ (description
+ "Labwc is light-weight and independent with a focus on simply stacking
+windows well and rendering some window decorations, it is inspired by openbox.
+It takes a no-bling/frills approach and says no to features such as icons
+(except window buttons), animations, decorative gradients and any other
+options not required to reasonably render common themes. It relies on clients
+for panels, screenshots, wallpapers and so on to create a full desktop
+environment.
+
+Labwc tries to stay in keeping with wlroots and sway in terms of general
+approach and coding style.
+
+Labwc has no reliance on any particular Desktop Environment, Desktop Shell or
+session. Nor does it depend on any UI toolkits such as Qt or GTK.")
+ (license license:gpl2)))
+
(define-public hikari
(package
(name "hikari")
--
2.30.2
F
F
Feng Shu wrote on 10 May 2023 05:12
(address . 61338@debbugs.gnu.org)
87ttwkj2vn.fsf@163.com
From 080f2324c3beb4f40a3ee3aa9d85b24ddcf86d5c Mon Sep 17 00:00:00 2001
Date: Wed, 10 May 2023 10:38:48 +0800

* gnu/packages/wm.scm (labwc): New variable.
---
gnu/packages/wm.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 28e4c04814..bb613d5ff9 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2808,6 +2808,48 @@ for wayland conceptually based on the X11 window manager
read and write, and compatible with JSON.")
(license license:bsd-2)))
+(define-public labwc
+ (package
+ (name "labwc")
+ (version "0.6.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/labwc/labwc")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zbgj8r8ppvqnz2imh6f825f2lvsqpiqfa0r5g5r4nsvadiipivp"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config gettext-minimal))
+ (inputs
+ (list cairo
+ glib
+ libxcb
+ libxml2
+ pango
+ scdoc
+ wlroots))
+ (home-page "https://labwc.github.io")
+ (synopsis "Labwc is a wlroots-based window-stacking compositor for wayland")
+ (description
+ "Labwc is light-weight and independent with a focus on simply stacking
+windows well and rendering some window decorations, it is inspired by openbox.
+It takes a no-bling/frills approach and says no to features such as icons
+(except window buttons), animations, decorative gradients and any other
+options not required to reasonably render common themes. It relies on clients
+for panels, screenshots, wallpapers and so on to create a full desktop
+environment.
+
+Labwc tries to stay in keeping with wlroots and sway in terms of general
+approach and coding style.
+
+Labwc has no reliance on any particular Desktop Environment, Desktop Shell or
+session. Nor does it depend on any UI toolkits such as Qt or GTK.")
+ (license license:gpl2)))
+
(define-public hikari
(package
(name "hikari")
--
2.30.2


--
E
E
Efraim Flashner wrote on 6 Jun 2023 08:03
(name . Feng Shu)(address . tumashu@163.com)(address . 61338-done@debbugs.gnu.org)
ZH7MLAdZ7NYC4VKH@3900XT
Patch was pushed, closing!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR+zCwACgkQQarn3Mo9
g1H3/hAAl5l8JC5SRO85/9Y7JlXFv+S1k4wo0oARb5mZj6+ofOcGbYeNZKYwUERN
e7OKA7ECmj5fDf91vXoWFE/TM8W2DjBCUBEyNwD79dTX5lG/RcmQblYc3sxysQzC
z/oyTOVW49OrtvYnfhQ+KD3uqbBvKplwmiae7lMg6qtuoBjgkz1jsRBeHTzCVe/R
Y+4wnzHW+eYKBfS6tUXHc2t9QB3nkCY2kIUW5DnKCWd0xRRNpLTiP+u5AkkUU31J
6a/uPpPqUs4lZCDKjpH9u3/munsgWvgC9QTfLgaaZth4uOB23qGLJM1rGybdwmDC
wwQzR0RLYL3WOJvy4Zck+4XO0UYrIJdTHC//83yytPeSmKUz4SYCz/4n4uCXLnDB
bzHOb5uvsdf1sIkU1RYCLi7RBlC8Y8BJt98KYOxEXmXNlXz7ylpbCkYyWBl0UEiM
loh9yI2yVv+6Q01SzD/lnlAzOMbOHvkCCgYZ/OqQ4/xF80tuheiOkguEtzxbvTUL
lywBOVtFb/92qEXOIwCqS3Cq1Vy+JvQToN//CFT7qv8Ras9OhWU7OZvEcqzEonWS
SZIN/0mqo4L2oqrbwb5toWU/+2ImKtyxtQZv7/BOoV1C8RHyFiWXEeKjRO4XpkEV
2zK7+/IC334bWrT2fPV9WkSDCQ94TTTom7FEClVbxrlCY4Vi7Yg=
=kIqi
-----END PGP SIGNATURE-----


Closed
?