[PATCH 0/3] Update zig to 0.10.1

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 24 Jan 2023 10:42
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
cover.1674553213.git.efraim@flashner.co.il
After looking heavily through the sources I'm of the opinion that zig
0.10.1 doesn't use the new binary bootstrap that they've developed.

I'm unsure what to do with $output/bin/zig not finding ld-linux in its
RUNPATH, but it's the only thing that's left me unhappy.

I wasn't sure if we wanted to keep 0.9 around also, but I didn't want to
be responsible for updating zig-zls so I figured we'd keep it for now,
especially since they make a point of saying that the language isn't
finalized at its 1.0 release yet.


Efraim Flashner (2):
gnu: zig: Update to 0.10.1.
gnu: ncdu: Update to 2.2.2.

gnu/packages/ncdu.scm | 6 +--
gnu/packages/zig-xyz.scm | 2 +-
gnu/packages/zig.scm | 100 +++++++++++++++++++++++++++++++--------
3 files changed, 85 insertions(+), 23 deletions(-)


base-commit: 5965d74c8ce53d0861af9ad3744844ac925c4a12
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
E
E
Efraim Flashner wrote on 24 Jan 2023 10:46
[PATCH 1/2] gnu: zig: Update to 0.10.1.
(address . 61036@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
1dee6b1c8526e33669f70550f1a387c9a26930a5.1674553213.git.efraim@flashner.co.il
* gnu/packages/zig.scm (zig-0.10): New variable.
(zig-0.9): Rename from zig-0.9. Inherit from zig-0.10.
(zig): Define as zig-0.10.
* gnu/packages/ncdu.scm (ncdu)[native-inputs]: Use zig-0.9.
* gnu/packages/zig-xyz.scm (zig-zls)[inputs]: Use zig-0.9.
---
gnu/packages/ncdu.scm | 2 +-
gnu/packages/zig-xyz.scm | 2 +-
gnu/packages/zig.scm | 100 +++++++++++++++++++++++++++++++--------
3 files changed, 83 insertions(+), 21 deletions(-)

Toggle diff (184 lines)
diff --git a/gnu/packages/ncdu.scm b/gnu/packages/ncdu.scm
index feea8f8819..7e47314351 100644
--- a/gnu/packages/ncdu.scm
+++ b/gnu/packages/ncdu.scm
@@ -97,7 +97,7 @@ (define-public ncdu
(when tests?
(invoke "zig" "test" "build.zig")))))))
(native-inputs
- (list perl zig))))
+ (list perl zig-0.9))))
(define-public ncdu-2
(deprecated-package "ncdu2" ncdu))
diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 3812aa0125..fd42c21638 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -41,7 +41,7 @@ (define-public zig-zls
(base32
"1hhs7dz9rpshfd1a7x5swmix2rmh53vsqskh3mzqlrj2lgb3cnii"))))
(build-system gnu-build-system)
- (inputs (list zig python))
+ (inputs (list zig-0.9 python))
(arguments
(list #:phases #~(modify-phases %standard-phases
(delete 'configure)
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
index cda93bed2e..b30e691bc5 100644
--- a/gnu/packages/zig.scm
+++ b/gnu/packages/zig.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2021 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
-;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,12 +25,14 @@ (define-module (gnu packages zig)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
+ #:use-module (gnu packages bootstrap)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages llvm))
-(define-public zig
+(define-public zig-0.10
(package
(name "zig")
- (version "0.9.1")
+ (version "0.10.1")
(source
(origin
(method git-fetch)
@@ -39,21 +41,25 @@ (define-public zig
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0nfvgg23sw50ksy0z0ml6lkdsvmd0278mq29m23dbb2jsirkhry7"))
- (patches (search-patches "zig-use-system-paths.patch"))))
+ (base32 "1sh5xjsksl52i4cfv1qj36sz5h0ln7cq4pdhgs3960mk8a90im7b"))))
(build-system cmake-build-system)
(inputs
- (list clang-13 ; Clang propagates llvm.
- lld-13))
+ (list clang-15 ; Clang propagates llvm.
+ lld-15
+ zlib
+ (list zstd "lib")))
;; Zig compiles fine with GCC, but also needs native LLVM libraries.
(native-inputs
- (list llvm-13))
+ (list llvm-15))
(arguments
`(#:configure-flags
(list ,@(if (%current-target-system)
- (string-append "-DZIG_TARGET_TRIPLE="
- (%current-target-system))
- '()))
+ '(string-append "-DZIG_TARGET_TRIPLE="
+ (%current-target-system))
+ '())
+ (string-append "-DZIG_LIB_DIR=" (assoc-ref %outputs "out")
+ "/lib/zig"))
+ #:validate-runpath? #f ; TODO: zig binary can't find ld-linux.
#:out-of-source? #f ; for tests
#:phases
(modify-phases %standard-phases
@@ -62,17 +68,20 @@ (define-public zig
;; Set cache dir, otherwise Zig looks for `$HOME/.cache'.
(setenv "ZIG_GLOBAL_CACHE_DIR"
(string-append (getcwd) "/zig-cache"))))
+ (add-after 'patch-source-shebangs 'patch-more-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Zig uses information about /usr/bin/env to determine the
+ ;; version of glibc and other data.
+ (substitute* "lib/std/zig/system/NativeTargetInfo.zig"
+ (("/usr/bin/env") (search-input-file inputs "/bin/env")))))
(delete 'check)
(add-after 'install 'check
(lambda* (#:key outputs tests? #:allow-other-keys)
(when tests?
(invoke (string-append (assoc-ref outputs "out") "/bin/zig")
- ;; Testing the standard library takes >7.5GB RAM, and
- ;; will fail if it is OOM-killed. The 'test-toolchain'
- ;; target skips standard library and doc tests.
- "build" "test-toolchain"
- ;; Stage 2 is experimental, not what we run with `zig',
- ;; and stage 2 tests require a lot of RAM.
+ "build" "test"
+ ;; We're not testing the compiler bootstrap chain.
+ "-Dskip-stage1"
"-Dskip-stage2-tests"
;; Non-native tests try to link and execute non-native
;; binaries.
@@ -100,7 +109,60 @@ (define-public zig
@item concurrency via async functions.
@end itemize")
(home-page "https://github.com/ziglang/zig")
+ (license license:expat)))
+
+(define-public zig-0.9
+ (package
+ (inherit zig-0.10)
+ (name "zig")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ziglang/zig.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nfvgg23sw50ksy0z0ml6lkdsvmd0278mq29m23dbb2jsirkhry7"))
+ (patches (search-patches "zig-use-system-paths.patch"))))
+ (inputs
+ (list clang-13 ; Clang propagates llvm.
+ lld-13))
+ ;; Zig compiles fine with GCC, but also needs native LLVM libraries.
+ (native-inputs
+ (list llvm-13))
+ (arguments
+ `(#:configure-flags
+ (list ,@(if (%current-target-system)
+ (string-append "-DZIG_TARGET_TRIPLE="
+ (%current-target-system))
+ '()))
+ #:out-of-source? #f ; for tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'set-cache-dir
+ (lambda _
+ ;; Set cache dir, otherwise Zig looks for `$HOME/.cache'.
+ (setenv "ZIG_GLOBAL_CACHE_DIR"
+ (string-append (getcwd) "/zig-cache"))))
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key outputs tests? #:allow-other-keys)
+ (when tests?
+ (invoke (string-append (assoc-ref outputs "out") "/bin/zig")
+ ;; Testing the standard library takes >7.5GB RAM, and
+ ;; will fail if it is OOM-killed. The 'test-toolchain'
+ ;; target skips standard library and doc tests.
+ "build" "test-toolchain"
+ ;; Stage 2 is experimental, not what we run with `zig',
+ ;; and stage 2 tests require a lot of RAM.
+ "-Dskip-stage2-tests"
+ ;; Non-native tests try to link and execute non-native
+ ;; binaries.
+ "-Dskip-non-native")))))))
;; Currently building zig can take up to 10GB of RAM for linking stage1:
;; https://github.com/ziglang/zig/issues/6485
- (supported-systems %64bit-supported-systems)
- (license license:expat)))
+ (supported-systems %64bit-supported-systems)))
+
+(define-public zig zig-0.10)
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
E
E
Efraim Flashner wrote on 24 Jan 2023 10:46
[PATCH 2/2] gnu: ncdu: Update to 2.2.2.
(address . 61036@debbugs.gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
d79132585488f44698cfc18f6e619f3165d34a11.1674553213.git.efraim@flashner.co.il
* gnu/packages/ncdu.scm (ncdu): Update to 2.2.2.
[native-inputs]: Switch from zig-0.9 to zig.
---
gnu/packages/ncdu.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/ncdu.scm b/gnu/packages/ncdu.scm
index 7e47314351..39cf48273e 100644
--- a/gnu/packages/ncdu.scm
+++ b/gnu/packages/ncdu.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,14 +62,14 @@ (define-public ncdu
(package
(inherit ncdu-1)
(name "ncdu")
- (version "2.2.1")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append "https://dev.yorhel.nl/download/ncdu-"
version ".tar.gz"))
(sha256
(base32
- "0hfimrr7z9zrfkiyj09i8nh4a1rjn7d00y9xzpc7mkyqpkvghjjy"))
+ "14zrmcxnrczamqjrib99jga05ixk0dzfav3pd6s1h8vm9q121nch"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -97,7 +97,7 @@ (define-public ncdu
(when tests?
(invoke "zig" "test" "build.zig")))))))
(native-inputs
- (list perl zig-0.9))))
+ (list perl zig))))
(define-public ncdu-2
(deprecated-package "ncdu2" ncdu))
--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
E
E
Efraim Flashner wrote on 6 Jun 2023 07:57
Re: [PATCH 1/2] gnu: zig: Update to 0.10.1.
(address . 61036-done@debbugs.gnu.org)
ZH7Kr6rWxRXUhnQ6@3900XT
Patch was pushed a few months ago. Closing!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmR+yq8ACgkQQarn3Mo9
g1GZARAAjTJnJ2uGcHKI/qGFQ0qirjblKWbNqn25e7p1HUC4uQ9cEpqg/v8CazBY
FMlCYAo8RZqF3cpjD3WqxCvdZz4sgsbgZWt3NirRYnXYiEdz8xM4Dbj0PMaEWiMf
JaRq1eOlZ9HMo7EirS2ky68HAuUHYuzjqGHeac9IxzagG5FgMX+3hZMSAG48WENd
QreO9+H29wElX7/02NnSBIn/clrgiPQaeZaSORka0dX6rvhbIyYiQpyh9lsauNIn
VIRP9JKnEzjtdFchBke1HpMc1XsPevJYlYyxHHXe6NkHq6UV8RIR3biLjypRJ+bb
VXSsIK/6ZzCynMmxuC0Wv2yfcicyZVO12yIY9+JxipEd7jz6HNQhHVw9pwyFDPYN
RiGyrZe+0b53NKKwgfTK0JYqcw20SVzjhGaOWKIexDQ9VL0GRdI6Mc1wwBpk6Qa0
1Q0G6robs+dD1iAM5Rge3hBAwVTP8Tp3y1kTYC0KgQYEkRK+rYJfHBvIF9EgNTOa
ZUbzqft5xEzwp5mLmjb9vmw5y7hyIllzioQnOvPwSYvxrDBgEfEHDGoJ1gFyDTbE
HysA1lKlgx0jpN3Xo+FrbSWajyu/fl8sMANpoZWhpB7dUWoO6eqMA6/D5NJJEVCQ
AGCyy4FPc5fo+KwhDsGEOWboVddz5J+Z8rhAAbAAI6GGw7KAHdk=
=WFIE
-----END PGP SIGNATURE-----


Closed
?