[PATCH] Building Icecat and jemalloc on aarch64-linux

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Christopher Baines
  • Roman Scherer
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal
R
R
Roman Scherer wrote on 22 Jan 2023 21:06
(name . Guix Patches)(address . guix-patches@gnu.org)
86ilgyuyc1.fsf@burningswell.com
Hi Guix,

I'm trying to build Icecat on an aarch64-linux based Guix system. I got it
working with the patches attached to this mail. I would like to include this
into Guix but I am not sure about the following issues:

1. jemalloc

I'm using the kernel configuration from the Asahi Linux project which uses 16K
as the kernel page size. Because of this I get an "Unsupported system page
size" error from the jemalloc package when building Icecat.

I fixed this issue by setting the page size in the jemalloc package to 16K,
when building for an aarch64-linux system. I got this from the PKGBUILD [1] of
ARM Arch Linux.

I'm new to ARM and now I'm wondering:

- What is the default kernel page size on an aarch64-linux system?

- If there is none, is there one that is most commonly used?

- Why does ARM Arch Linux default to 16K and should we too?

- Which kernel page size is used on CI to build jemalloc and Icecat on the
aarch64-linux builders?

- Did Icecat ever built on aarch64-linux on CI?

I also updated the version of jemalloc to 5.3.0, because I thought they also
addressed this issue for my particular aarch64-linux system [2]. This new
version sets the page size also to 16K, but only when building for an
aarch64-apple-darwin system, and not for aarch64-linux systems. So I'm not
sure only updating the version would fix the kernel page size issue here.

More than 5000 packages depend on jemalloc, so this should probably go into
the core-updates branch? The changes to jemalloc caused my world to rebuild
locally, but I ended up with a working Icecat.

2. Disable EME on aarch64-linux

I removed the --disable-eme option on aarch64-linux because the configure
script failed an error saying this option is not supported on this
architecture. Since EME stands for Encrypted Media Extensions and is a
JavaScript API for playing DRMed video content in HTML, I'm not sure if this
is ok, or what to best do here?

Could someone please review the patches and give me some advice on how to
proceed with these issues?

Thanks, Roman.

From 87b3983e2981fc433b4b7e24f6d3b13f17d90c56 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 22 Jan 2023 19:30:12 +0100
Subject: [PATCH 1/3] gnu: jemalloc: Update to 5.3.0.

* gnu/packages/jemalloc.scm (jemalloc): Update to 5.3.0.
---
gnu/packages/jemalloc.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 2e25780257..354f07a838 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -75,7 +75,7 @@ (define-public jemalloc-4.5.0
(define-public jemalloc
(package
(inherit jemalloc-4.5.0)
- (version "5.2.1")
+ (version "5.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -83,7 +83,7 @@ (define-public jemalloc
version "/jemalloc-" version ".tar.bz2"))
(sha256
(base32
- "1xl7z0vwbn5iycg7amka9jd6hxd8nmfk7nahi4p9w2bnw9f0wcrl"))))
+ "1apyxjd1ixy4g8xkr61p0ny8jiz8vyv1j0k4nxqkxpqrf4g2vf1d"))))
(arguments
(substitute-keyword-arguments (package-arguments jemalloc-4.5.0)
;; Disable the thread local storage model in jemalloc 5 to prevent
--
2.38.1
From ff4f0076185143436058315a9d8ae74830c84eff Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 22 Jan 2023 19:31:37 +0100
Subject: [PATCH 2/3] gnu: jemalloc: Build with large page size on aarch64.

* gnu/packages/jemalloc.scm (jemalloc): Build with large page size on aarch64.
---
gnu/packages/jemalloc.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 354f07a838..877b026fda 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -58,6 +58,8 @@ (define-public jemalloc-4.5.0
'(,@(match (%current-system)
((or "i686-linux" "x86_64-linux")
'())
+ ("aarch64-linux"
+ (list "--with-lg-page=14"))
("powerpc-linux"
(list "--disable-thp" "CPPFLAGS=-maltivec"))
(_
--
2.38.1
From 71bf3cf7187de92f7974bedc2d0291a78a0754bc Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 22 Jan 2023 19:33:13 +0100
Subject: [PATCH 3/3] gnu: icecat: Fix --disable-eme option on aarch64.

* gnu/packages/gnuzilla.scm (icecat): Fix --disable-eme option on aarch64.
---
gnu/packages/gnuzilla.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 23249791bb..95c8be5f1b 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -756,7 +756,8 @@ (define-public icecat
"--disable-tests"
"--disable-updater"
"--disable-crashreporter"
- "--disable-eme"
+ ;; The --disable-eme option is not available on aarch64.
+ #$(if (target-aarch64?) "" "--disable-eme")
;; Building with debugging symbols takes ~5GiB, so disable it.
"--disable-debug"
--
2.38.1
-----BEGIN PGP SIGNATURE-----

iQFTBAEBCAA9FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmPNl64fHHJvbWFuLnNj
aGVyZXJAYnVybmluZ3N3ZWxsLmNvbQAKCRA92lJSfSrBmeCTCACOPRGUqtSsZ8eS
YIAe2RM4VKQla2PPWrolCqP6Ts52ehME25vZv7KHvjCrowVx2DHPrObSWKcH1GJM
D049lB5nEmnDtU1XTLFH//UJZMDr2Oui4F+D0XKmnfT98p5O3oIyAuaXXOuoOkEP
Unql6gDfiSo0xznarWJ/6nnaYtQuxkyzedAHSokN9qlqWvYSZe1DJiWPSrrxYuuw
JuNUCletNAp1D621RD5r/oTn5MW9DMRk37zMooNLUrltVXC3Kj8kRDVfrWqAGMEm
lHPWkR4qoXiwFhA95xRbSNrq1DVnEyh52fVQpcYUUA72TVH7EEjNiWfHUdKf0SNL
1fvkouUn
=y9uY
-----END PGP SIGNATURE-----

R
R
Roman Scherer wrote on 5 Feb 2023 17:35
[PATCH v2] Building Icecat and jemalloc on aarch64-linux
(address . 61009@debbugs.gnu.org)
86mt5s9i3a.fsf@burningswell.com
Hi Guix,

here is another approach to this. This patch series updates jemalloc to
v5.3.0 and does not disable transparent huge pages on aarch64-linux,
similar to what we do on i686-linux and x86_64-linux. So I think this
would support now building binaries for Rust and Icecat on CI for 4K but
also larger kernel page sizes.

Could you please review the patches?

Thanks, Roman.
From ae69696267b0651fb2be40e4b31584d1c84647b6 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 5 Feb 2023 10:57:15 +0100
Subject: [PATCH 1/3] gnu: jemalloc: Update to 5.3.0.

* gnu/packages/jemalloc.scm (jemalloc): Update to 5.3.0.
---
gnu/packages/jemalloc.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 2e25780257..354f07a838 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -75,7 +75,7 @@ (define-public jemalloc-4.5.0
(define-public jemalloc
(package
(inherit jemalloc-4.5.0)
- (version "5.2.1")
+ (version "5.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -83,7 +83,7 @@ (define-public jemalloc
version "/jemalloc-" version ".tar.bz2"))
(sha256
(base32
- "1xl7z0vwbn5iycg7amka9jd6hxd8nmfk7nahi4p9w2bnw9f0wcrl"))))
+ "1apyxjd1ixy4g8xkr61p0ny8jiz8vyv1j0k4nxqkxpqrf4g2vf1d"))))
(arguments
(substitute-keyword-arguments (package-arguments jemalloc-4.5.0)
;; Disable the thread local storage model in jemalloc 5 to prevent
--
2.38.1
From c228faf06983c1e36f633bad6a015dfe177a1702 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 5 Feb 2023 10:59:06 +0100
Subject: [PATCH 2/3] gnu: jemalloc: Build with transparent huge pacges on
aarch64.

* gnu/packages/jemalloc.scm (jemalloc-4.5.0): Build with transparent huge pacges on aarch64.
---
gnu/packages/jemalloc.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/jemalloc.scm b/gnu/packages/jemalloc.scm
index 354f07a838..6c6ba0f568 100644
--- a/gnu/packages/jemalloc.scm
+++ b/gnu/packages/jemalloc.scm
@@ -56,7 +56,7 @@ (define-public jemalloc-4.5.0
#t)))
#:configure-flags
'(,@(match (%current-system)
- ((or "i686-linux" "x86_64-linux")
+ ((or "aarch64-linux" "i686-linux" "x86_64-linux")
'())
("powerpc-linux"
(list "--disable-thp" "CPPFLAGS=-maltivec"))
--
2.38.1
From 0311f5812ab091dabb0686a6373c0d17e006e0c5 Mon Sep 17 00:00:00 2001
From: r0man <roman@burningswell.com>
Date: Sun, 5 Feb 2023 11:01:17 +0100
Subject: [PATCH 3/3] gnu: icecat: Remove unsupported --disable-eme option on
aarch64.

* gnu/packages/gnuzilla.scm (icecat): Remove unsupported --disable-eme option on aarch64.
---
gnu/packages/gnuzilla.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index b507ec0406..ad051e71f7 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -756,7 +756,8 @@ (define-public icecat
"--disable-tests"
"--disable-updater"
"--disable-crashreporter"
- "--disable-eme"
+ ;; The --disable-eme option is not available on aarch64.
+ #$(if (target-aarch64?) "" "--disable-eme")
;; Building with debugging symbols takes ~5GiB, so disable it.
"--disable-debug"
--
2.38.1
-----BEGIN PGP SIGNATURE-----

iQFTBAEBCAA9FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmPf3SofHHJvbWFuLnNj
aGVyZXJAYnVybmluZ3N3ZWxsLmNvbQAKCRA92lJSfSrBmXvhCACzFnF6KVnIkWiF
g04T3CxR+l61WpzWST7e/AW5isUpilrGgAk+c1RF+DiueG4+sS3ec1tnptzmGAcb
c6MFvD3vML6WmfJ2DpUQ3hwhcbh86tZ7MymXcfAxjFa+VkSQ8YhRCCkS5tWuA+tr
DFez3ZA2x9T5f5zy0AoqKahuD8y66mV7nLXvKMcqzBzR0nxiflDH09BlbYmKsdMR
YzXURPaqGkH/ZtyTnOwzn9awB1K5zcLu7MXERz3oebAG7RzgONUQnSbDhw2QyUQY
ML+w48JyiWag7GVxRKLeV832WfyCnCOL8/n9DNsyd44Ih9U5Ek6pjb0EgK2tH5/l
jNGcNy1F
=yqKJ
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 5 Feb 2023 18:32
Re: [bug#61009] [PATCH] Building Icecat and jemalloc on aarch64-linux
(name . Roman Scherer)(address . roman.scherer@burningswell.com)(address . 61009@debbugs.gnu.org)
Y9/oOdnBZpzPxml5@jasmine.lan
On Sun, Jan 22, 2023 at 09:06:43PM +0100, Roman Scherer wrote:
Toggle quote (8 lines)
> 2. Disable EME on aarch64-linux
>
> I removed the --disable-eme option on aarch64-linux because the configure
> script failed an error saying this option is not supported on this
> architecture. Since EME stands for Encrypted Media Extensions and is a
> JavaScript API for playing DRMed video content in HTML, I'm not sure if this
> is ok, or what to best do here?

Guix adheres to the Free System Distribution Guidelines, which
explicitly forbids browsers with EME support:


Unfortunately, I don't know the answers to your other questions.
R
R
Roman Scherer wrote on 6 Feb 2023 20:52
(name . Leo Famulari)(address . leo@famulari.name)(address . 61009@debbugs.gnu.org)
86zg9q1ryl.fsf@burningswell.com
Hi Leo,

thanks for your reply. Ok, I understand. I try to see if I can disable
it in some other way then. Are you familiar with this? Do you have any
tips to share?

I think the v2 patches about transparent huge pages for jemalloc could
still be an improvement, if it's a compatible change. It would enable
the use of rust substitutes that depend on jemalloc on aarch64 that run
with kernel pages > 4K.

Roman

Leo Famulari <leo@famulari.name> writes:

Toggle quote (16 lines)
> On Sun, Jan 22, 2023 at 09:06:43PM +0100, Roman Scherer wrote:
>> 2. Disable EME on aarch64-linux
>>
>> I removed the --disable-eme option on aarch64-linux because the configure
>> script failed an error saying this option is not supported on this
>> architecture. Since EME stands for Encrypted Media Extensions and is a
>> JavaScript API for playing DRMed video content in HTML, I'm not sure if this
>> is ok, or what to best do here?
>
> Guix adheres to the Free System Distribution Guidelines, which
> explicitly forbids browsers with EME support:
>
> https://guix.gnu.org/en/about/
> https://www.gnu.org/distros/free-system-distribution-guidelines.en.html
>
> Unfortunately, I don't know the answers to your other questions.
-----BEGIN PGP SIGNATURE-----

iQFTBAEBCAA9FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmPhXTIfHHJvbWFuLnNj
aGVyZXJAYnVybmluZ3N3ZWxsLmNvbQAKCRA92lJSfSrBmY1hCACw/0wWxJl0Cj7J
zy8jgxBbcTfQySj+FSJZYgrllNaR93NLuQ/OLTXvMB5EdO8+HBO9Okk47nQ067TU
r30Z9iS+aJYB7fnRUEkRuJkDwRhey6qGz7BqM1F20RTidcfpvj6rwpyv252+XrVq
evYjEIAiuk3DmTEtYVKw14sZTS+NFAY+K8bY4uxTNmugws/8kxf/DXGqXp/g4HIF
8e+n2SGRmIOh6EbZHQ9KPq9nImh3XZ7G3nKahqdA9gobLQRiAkHjguxunLvDwi2r
YPRQuYX2ON++n9xN5pah12jvqyFOt5hKpCTigvEAGRwW7ua32MX88QzAgEWmZbJR
/1gw+b4b
=t7a8
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 9 Feb 2023 13:49
(name . Roman Scherer)(address . roman.scherer@burningswell.com)(address . 61009@debbugs.gnu.org)
Y+Tr9FUOyJPI3QYT@jasmine.lan
On Mon, Feb 06, 2023 at 08:52:43PM +0100, Roman Scherer wrote:
Toggle quote (4 lines)
> thanks for your reply. Ok, I understand. I try to see if I can disable
> it in some other way then. Are you familiar with this? Do you have any
> tips to share?

No, I don't have any specific knowledge about IceCat or aarch64.

Mark Weaver is the primary maintainer of our IceCat package.

It seems like a mistake that IceCat would require EME on a particular
architecture. Maybe the name of the configure option has changed.
R
R
Roman Scherer wrote on 11 Feb 2023 10:44
(name . Leo Famulari)(address . leo@famulari.name)(address . 61009@debbugs.gnu.org)
86y1p4wn76.fsf@burningswell.com
Alright, thanks Leo!

Leo Famulari <leo@famulari.name> writes:

Toggle quote (11 lines)
> On Mon, Feb 06, 2023 at 08:52:43PM +0100, Roman Scherer wrote:
>> thanks for your reply. Ok, I understand. I try to see if I can disable
>> it in some other way then. Are you familiar with this? Do you have any
>> tips to share?
>
> No, I don't have any specific knowledge about IceCat or aarch64.
>
> Mark Weaver is the primary maintainer of our IceCat package.
>
> It seems like a mistake that IceCat would require EME on a particular
> architecture. Maybe the name of the configure option has changed.
-----BEGIN PGP SIGNATURE-----

iQFTBAEBCAA9FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmPnY40fHHJvbWFuLnNj
aGVyZXJAYnVybmluZ3N3ZWxsLmNvbQAKCRA92lJSfSrBmXWXCAC4CBG4muhyyToq
azJKBD84Hi3tPXcMUIyp9rA2rcFNe96VOj1WTMob++Kb29qrnFWmECwShz7+7QIq
/ggl//LxtRUwj+KVl24zeCZFSGVe2qqCdhB2EZBJmDc0zQpkflZMTCpX+FolI97+
u3tD2EA/Dg6h7vtIgHH7UT9SSQGLdv9nOMVOUWyphv3+MoUKOtnXX0SYiwe/2mV6
vCceYBLBk7KsqBa/XF/RRfH36hBaUPYRdLGgZEMsYEzmARkncyNCAFol6wZ1rAem
DjDdyd23+xDVLljkpgrxjFlUr6eeyogkBynC++h756UzLMOaZFv4yj+b1Ww+ztvg
77AR6+Nw
=UO6F
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 1 Mar 2023 16:46
(name . Roman Scherer)(address . roman.scherer@burningswell.com)
87v8jkwjzp.fsf@cbaines.net
Roman Scherer <roman.scherer@burningswell.com> writes:

Toggle quote (16 lines)
> Alright, thanks Leo!
>
> Leo Famulari <leo@famulari.name> writes:
>
>> On Mon, Feb 06, 2023 at 08:52:43PM +0100, Roman Scherer wrote:
>>> thanks for your reply. Ok, I understand. I try to see if I can disable
>>> it in some other way then. Are you familiar with this? Do you have any
>>> tips to share?
>>
>> No, I don't have any specific knowledge about IceCat or aarch64.
>>
>> Mark Weaver is the primary maintainer of our IceCat package.
>>
>> It seems like a mistake that IceCat would require EME on a particular
>> architecture. Maybe the name of the configure option has changed.

I've pushed one of these patches now as
72ec11d24f34104efce0d91050a3faba4e2c7242. I missed any other patches
that were sent to this issue.

I think removing the --disable-eme option is OK on aarch64 as it's
probably not an option since I'm guessing EME isn't available on
aarch64. Anyway, Icecat looks to add these disable options by default so
I'm not sure we need it for any architecture in the guix package.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmP/c8pfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdUvQ//ce4gg6zpixGnYYqpQyuwVUrjNC2K9lEt
gYlTAqoDqp4GWoB8M0L9daYyO5k32GFiQJFhZx8X0B/pZT4SwGMnjXJzBqUinYiu
tMH01x22YpQvWPGEczHHBFcZsP28sE/ewsmu4I8Elo4Iby8TLFRfff4NlRrF8WLv
5GZBEfkdy2yoLYSm6+EQHHSHVwKo9eI7IqC2jK7zv27uofOg6aJnavymVGyY7zbR
dSG0scNRTdbNDPVZS8YJel6PNp3B1FcXOjwdytyJiWq1BrHlLD+ABKu2iuD5hvmG
x1Qcthj2RihlpQrzuE++0mWV9SPPoVm1y2KFrgWPBtNnj4RLJfzcjpA7rJWjDfOH
yTKJU5tzL7lexyIUIUxWlcbHNVLNBHrl6WZfQy718+zYNT+os9sqsi6mRh6tlHLs
8jFQvi+Zp11puuMbanI9j4QQ+v8RF33YPRiR3Q47ClG+QM7z11g9l50JdcZ0cWiP
z8kMYD7YMI/D/YDLdBcMI91rh+NrBagIq9zcUxF7dYEomGUObF4dsTWGKkl0YS/Q
GNgKx63PJx+B76OYWmvWAbvR6Nsehyfym9LO7JaBaiLbKV+8AYpSQo4WGYB7dnOX
ycUW4g2+Z6Igdn/wDGKrgxzX86/SPc8scwQwbTCfubO/GOnnzfTBz18FJne21jT0
1eg34SDbjTg=
=lk0D
-----END PGP SIGNATURE-----

R
R
Roman Scherer wrote on 1 Mar 2023 19:05
(name . Christopher Baines)(address . mail@cbaines.net)
87v8jkqqwd.fsf@burningswell.com
Hi Christopher,

thanks for applying the patch and for the explanation.

Not sure what you meant by "missed". But, I sent an improved version of
the jemalloc patches as a separate issue a while ago. They are here:


Without the jemalloc patches, Icecat and all other packages using
jemalloc crash with the error `<jemalloc>: Unsupported system page size`
on aarch64 systems that run with kernel page sizes > 4K.

If you are familiar with this, I could need some help here as well ;)

Thanks, Roman.

Christopher Baines <mail@cbaines.net> writes:

Toggle quote (30 lines)
> [[PGP Signed Part:Undecided]]
>
> Roman Scherer <roman.scherer@burningswell.com> writes:
>
>> Alright, thanks Leo!
>>
>> Leo Famulari <leo@famulari.name> writes:
>>
>>> On Mon, Feb 06, 2023 at 08:52:43PM +0100, Roman Scherer wrote:
>>>> thanks for your reply. Ok, I understand. I try to see if I can disable
>>>> it in some other way then. Are you familiar with this? Do you have any
>>>> tips to share?
>>>
>>> No, I don't have any specific knowledge about IceCat or aarch64.
>>>
>>> Mark Weaver is the primary maintainer of our IceCat package.
>>>
>>> It seems like a mistake that IceCat would require EME on a particular
>>> architecture. Maybe the name of the configure option has changed.
>
> I've pushed one of these patches now as
> 72ec11d24f34104efce0d91050a3faba4e2c7242. I missed any other patches
> that were sent to this issue.
>
> I think removing the --disable-eme option is OK on aarch64 as it's
> probably not an option since I'm guessing EME isn't available on
> aarch64. Anyway, Icecat looks to add these disable options by default so
> I'm not sure we need it for any architecture in the guix package.
>
> [[End of PGP Signed Part]]
-----BEGIN PGP SIGNATURE-----

iQFTBAEBCAA9FiEE0iajOdjfRIFd3gygPdpSUn0qwZkFAmP/llcfHHJvbWFuLnNj
aGVyZXJAYnVybmluZ3N3ZWxsLmNvbQAKCRA92lJSfSrBmVnMB/9BAordBQ1ziHUF
wgRPWwZK/nv1GzrAUbCbcw2M1wzUbHi0YRWedVRr3U7yOwvXibaxpLDlHsPe7++M
/tXsH9qZ+vWPAB1msJDJuj601A1C6I9p1ICpQ0M3kDu27+N0slk2LkNoMRhRNvNr
lrbhDbeMQQdjZDuH8rR4YlJZzB5Sw1zf1F6sjTVLWkwZyheBXZU3nhIEqEjfdiD0
VhweTvUPxmOP9RgLMUlvmo6JwN8OEqPfH/sxklr4Vrf7+b2E5EMRzwPlHk64gVxk
g8Jbjbjay0e7PaJVCvk+0VHPe0Q33dK6a9DI8cZukB166WucGbdCOZ+NDj/0CGJ5
PwTaD6Ai
=si1o
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 2 Mar 2023 11:07
(name . Roman Scherer)(address . roman.scherer@burningswell.com)
877cvzv4fe.fsf@cbaines.net
Roman Scherer <roman.scherer@burningswell.com> writes:

Toggle quote (15 lines)
> Hi Christopher,
>
> thanks for applying the patch and for the explanation.
>
> Not sure what you meant by "missed". But, I sent an improved version of
> the jemalloc patches as a separate issue a while ago. They are here:
>
> https://lists.gnu.org/archive/html/guix-patches/2023-02/msg00698.html
>
> Without the jemalloc patches, Icecat and all other packages using
> jemalloc crash with the error `<jemalloc>: Unsupported system page size`
> on aarch64 systems that run with kernel page sizes > 4K.
>
> If you are familiar with this, I could need some help here as well ;)

Sending the jemalloc patch seperately sounds good. I'm going to mark
this issue as done since that's tracked separately.

I've replied to that separate issue, but I think that these changes may
already be in place on core-updates. I'm going to have a go at merging
master in to core-updates which should allow for testing icecat in
core-updates with the changes I've merged in master.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmQAeNVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XesBxAAuZlyQteBLTc0M/NXXHCuYY1cjKfUiBtM
n+IpcvdeaoA+kUPY5kvkD0hKFuBDRiKVuZmVwe52E/VFrmDKx5/WJHlZjzN4hdd/
3kOvh+3Wi70eqZ5IwhlSinQsVzrewZ83LPonCMwjkHt7f/j5rUtvbGSxqBHQq+wN
Nm7zHCEKqP/YfhkqNDxu2ju47AuPu29x4RqyxSOeZ1lviYdwlrFsD2bQV+If29va
Wvj8ZbpQcjATZgWXyIcgSmRAK/VFhTT5XeVgiwYk6NszTz5XLokY/VKIYOY4OBnS
w13UKk75LHgEp3wtgI7n4tYYdx3L6k9wPYZjkVXPBgE4nWXNcdnE0GRVJGZ0k1Oy
gJt/aIf96KthC73DBaP5TpofVcYJnYnaLwdyWZYETU8lCBpF93HCOjthaAVZHInO
LBn7jxHPFYwNWKcpmwcHMkNvd1bTsrGwxQW95oWiaf6y6UUbdDdiV6cYzs50KGlr
B4jGwlCJj5n2uc3EDddMesfsYj4sgWG2bjasYoheRUySknm52DtOxXYQAekhSQt4
OpI3kOMi31h8VsS0ZhOYsNvGzbRV6+vothL3huwlvU9Hr6mU4XgeAwBwBRUIxOnq
d5YhAUVcJkw19SHaX9/0163QXayhaJkYW3LGsNs7v3HuQGxVuzK1/wRNud/T+xsY
+f9qSNPgMLY=
=zcJx
-----END PGP SIGNATURE-----

?