New package: python-scapy
(address . guix-patches@gnu.org)
Hi!
I had time to pack some more software for our favorite distro: Python
Scapy. It's a powerful tool which allows the creation and inspection
of ethernet frames and other network traffic packets from within Python.
From f2ca7968afdc5013d78f38e47bf9bfc34af2baa0 Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Mon, 9 Jan 2023 16:06:20 +0100
Subject: [PATCH] gnu: Add package python-scapy
* gnu/packages/python-xyz.scm (python-scapy): New variable.
---
gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Toggle diff (42 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d826d3c5..7e6704f4aa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -132,6 +132,7 @@
;;; Copyright � 2022 Garek Dyszel <garekdyszel@disroot.org>
;;; Copyright � 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright � 2022 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright � 2023 Gabriel Wicki <gabriel@erlikon.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1462,6 +1463,27 @@ (define-public python-psutil
iotop, uptime, pidof, tty, taskset, pmap.")
(license license:bsd-3)))
+(define-public python-scapy
+ (package
+ (name "python-scapy")
+ (version "2.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "scapy" version))
+ (sha256
+ (base32
+ "1hpbbmpcn4dwj3z7i7sz4cnbpkaf57p7mvl3p84x9n2gflmhq9jv"))))
+ (arguments
+ '(#:tests? #f)) ;no test
+ (build-system python-build-system)
+ (home-page "https://scapy.net")
+ (synopsis "Python network packet crafting library")
+ (description
+ "Scapy is a powerful interactive packet manipulation program.
+It is able to forge or decode packets of a wide number of protocols, send them
+on the wire, capture them, match requests and replies, and much more.")
+ (license license:gpl2)))
+
(define-public python-shapely
(package
(name "python-shapely")
--
2.38.1