[PATCH] gnu: Add fbgrab.

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 30 Dec 2022 02:14
(address . guix-patches@gnu.org)
20221230011422.32343-1-maxim.cournoyer@gmail.com
* gnu/packages/linux.scm (fbgrab): New variable.
---

gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 568c2b6b92..8fb43963ea 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -127,6 +127,7 @@ (define-module (gnu packages linux)
#:use-module (gnu packages gtk)
#:use-module (gnu packages haskell-apps)
#:use-module (gnu packages haskell-xyz)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages llvm)
@@ -8480,6 +8481,38 @@ (define-public fbcat
emulates the behaviour of Gunnar Monell's older fbgrab utility.")
(license license:gpl2)))
+(define-public fbgrab
+ (package
+ (name "fbgrab")
+ (version "1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/GunnarMonell/fbgrab")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1npn7l8jg0nhjraybjl38v8635zawzmn06ql3hs3vhci1vi1r90r"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "DESTDIR=" #$output))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'strip-/usr-prefix
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr") ""))))
+ (delete 'configure))))
+ (inputs (list libpng zlib))
+ (home-page "https://github.com/GunnarMonell/fbgrab")
+ (synopsis "Linux framebuffer screenshot/conversion utility")
+ (description "FBGrab is a framebuffer screenshot program that captures the
+Linux framebuffer and converts it to a PNG image. It can also convert a
+framebuffer dump file (copy) to a PNG image.")
+ (license license:gpl2))) ;GPL 2.0 only (per SPDX identifier in fbgrab.c)
+
(define-public libcgroup
(package
(name "libcgroup")

base-commit: fa0cb6d2eb3762067c69bcb0671e75d93d4d306c
--
2.38.1
M
M
Maxim Cournoyer wrote on 14 Jan 04:35 +0100
control message for bug #60414
(address . control@debbugs.gnu.org)
87edrxeqkf.fsf@gmail.com
close 60414
quit
?