[PATCH] gnu: Add emacs-eat.

  • Done
  • quality assurance status badge
Details
3 participants
  • Akib Azmain Turja
  • Zhu Zihao
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 28 Dec 2022 16:17
(address . guix-patches@gnu.org)(name . Zhu Zihao)(address . all_but_last@163.com)
20221228151728.17015-1-all_but_last@163.com
* gnu/packages/emacs-xyz.scm (emacs-eat): New variable.
---
gnu/packages/emacs-xyz.scm | 48 +++++++++++++++++++++++++++++++++++++-
1 file changed, 47 insertions(+), 1 deletion(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8b0bb58275..9765ca2bbf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -81,7 +81,7 @@
;;; Copyright © 2020, 2021, 2022 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Marco Grassi <marco.au.grassi98@protonmail.com>
;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
-;;; Copyright © 2020, 2021 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2020, 2021, 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
@@ -26592,6 +26592,52 @@ (define-public emacs-navigel
tabulated-lists).")
(license license:gpl3+)))
+(define-public emacs-eat
+ (package
+ (name "emacs-eat")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/akib/emacs-eat")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ha9qc8ll41bc187vzpnnwb06jywvfzh7kxy4rfcdj6dc21wvb87"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; Remove generated terminfo database.
+ (delete-file-recursively "terminfo")
+ #t))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:include #~(cons* "^term/"
+ "^terminfo/"
+ "^integration/"
+ "\\.ti$"
+ %default-include)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'build-info
+ (lambda _
+ (invoke "make" "info")))
+ (add-before 'install 'build-terminfo-database
+ (lambda _
+ (invoke "make" "terminfo"))))))
+ (native-inputs
+ (list ncurses texinfo))
+ (home-page "https://codeberg.org/akib/emacs-eat")
+ (synopsis "Terminal emulator in Emacs")
+ (description
+ "This package provides a terminal emulator in Emacs, written in pure
+Elisp. It has features like complete mouse support and shell integration.")
+ (license license:gpl3+)))
+
(define-public emacs-vterm
(let ((version "0.0.1")
(revision "1")
--
2.38.1
A
A
Akib Azmain Turja wrote on 28 Dec 2022 18:04
(address . 60380@debbugs.gnu.org)
87wn6bpihd.fsf@disroot.org
Thanks for submitting this.

Toggle quote (27 lines)
> * gnu/packages/emacs-xyz.scm (emacs-eat): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 48 +++++++++++++++++++++++++++++++++++++-
> 1 file changed, 47 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 8b0bb58275..9765ca2bbf 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -81,7 +81,7 @@
> ;;; Copyright © 2020, 2021, 2022 Niklas Eklund <niklas.eklund@posteo.net>
> ;;; Copyright © 2020 Marco Grassi <marco.au.grassi98@protonmail.com>
> ;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
> -;;; Copyright © 2020, 2021 Zhu Zihao <all_but_last@163.com>
> +;;; Copyright © 2020, 2021, 2022 Zhu Zihao <all_but_last@163.com>
> ;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
> ;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
> ;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
> @@ -26592,6 +26592,52 @@ (define-public emacs-navigel
> tabulated-lists).")
> (license license:gpl3+)))
>
> +(define-public emacs-eat
> + (package
> + (name "emacs-eat")
> + (version "0.3.1")

Version 0.4, maybe? (Just released now. ;))

Toggle quote (17 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://codeberg.org/akib/emacs-eat")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1ha9qc8ll41bc187vzpnnwb06jywvfzh7kxy4rfcdj6dc21wvb87"))
> + (modules '((guix build utils)))
> + (snippet
> + #~(begin
> + ;; Remove generated terminfo database.
> + (delete-file-recursively "terminfo")
> + #t))))

To build these files with Guix, I guess?

Toggle quote (22 lines)
> + (build-system emacs-build-system)
> + (arguments
> + (list
> + #:tests? #t
> + #:include #~(cons* "^term/"
> + "^terminfo/"
> + "^integration/"
> + "\\.ti$"
> + %default-include)
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-before 'install 'build-info
> + (lambda _
> + (invoke "make" "info")))
> + (add-before 'install 'build-terminfo-database
> + (lambda _
> + (invoke "make" "terminfo"))))))
> + (native-inputs
> + (list ncurses texinfo))
> + (home-page "https://codeberg.org/akib/emacs-eat")
> + (synopsis "Terminal emulator in Emacs")

I guess it'd be better to use the string "Emulate A Terminal in Emacs"
as the synopsis.

Toggle quote (6 lines)
> + (description
> + "This package provides a terminal emulator in Emacs, written in pure
> +Elisp. It has features like complete mouse support and shell integration.")
> + (license license:gpl3+)))
> +

Great description in a few words.

Toggle quote (6 lines)
> (define-public emacs-vterm
> (let ((version "0.0.1")
> (revision "1")
> --
> 2.38.1

--
Akib Azmain Turja, GPG key: 70018CE5819F17A3BBA666AFE74F0EFA922AE7F5
Fediverse: akib@hostux.social
Codeberg: akib
emailselfdefense.fsf.org | "Nothing can be secure without encryption."
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEyVTKmrtL6kNBe3FRVTX89U2IYWsFAmOsdy4ACgkQVTX89U2I
YWsQNxAAltB+shwnQQKiktOPNPJakS2VAfl6k+2et2FzpbJ+MmcSiVvS+FXpgDus
PyW0/IbqVneoKcodm6E9WSuMIr30hQiMWeseND/Ys/84DzaCgEEcmbyARM/d3lgw
qkuxc2KV21NOeyfrg6YSly8dfaUoD2iKyj0p83h2Vv4ZUdqyoyZPK1kAbtxLIOaf
lcy774unAo1j4H9MIpjtyG3Q2mzxFc4NMmmqfms5zoABT1p16ZgJZzf2PtiX4JDP
GuGCA2cK3eO3LQzzGIvJFWP5exsWhtyQsIcB1TzC8U3qNQTmUmZnovR600bKmcZg
3AMJ98YTm5IH3O7YWMsH5RoeMtTJsKCM305T0TtZANJdXngZApy5xKVhTs05u0C2
1T2k9OtMoRqc/59BYQhOY2lwObTsO8zFTT5QEDAD5z6msKsSBLlZFmcuMc2/SC6z
GQ47AAwW6tSabiIHQ4y1DQvey5M52gnhxDTB5np3way1C5/wRTsFxb0KlroBSVqK
K0V2FfH8WpWtmO0o3vicYubXRcKnbAfhM+ZvP0Oh9CdDo7KyG9tRmDiOk3kHUYQI
YVY9DBZfzWIbI4cUqSXQZ86j4e+vJtXaIugMydI8nMigmIANfCw8MDmoTA7yjKro
MnEAoFLyFa9SSuobyEU0kRhb1lGLTIDemFDXxDmmTa2MnKIFhFo=
=KarJ
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 30 Dec 2022 11:33
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 60380-done@debbugs.gnu.org)
87ilht89kn.fsf@nicolasgoaziou.fr
Hello,

Zhu Zihao <all_but_last@163.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-eat): New variable.

I updated the package to 0.4 and applied your patch. Thank you.

Toggle quote (6 lines)
> + (snippet
> + #~(begin
> + ;; Remove generated terminfo database.
> + (delete-file-recursively "terminfo")
> + #t))))

This trailing #t is not necessary. I removed it.

Regards,
--
Nicolas Goaziou
Closed
?