[PATCH] gnu: Add charls

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Tor-björn Claesson
Owner
unassigned
Submitted by
Tor-björn Claesson
Severity
normal
T
T
Tor-björn Claesson wrote on 28 Dec 2022 01:23
(address . guix-patches@gnu.org)
87lems74qk.fsf@gmail.com
gnu: Add charls
---
gnu/packages/image-processing.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index ab796d7719..70afeaa147 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1471,3 +1471,31 @@ (define-public labelme
"Image and video labeling tool supporting different shapes like
polygons, rectangles, circles, lines, points and VOC/COCO export.")
(license license:gpl3+)))
+
+(define-public charls
+ (package
+ (name "charls")
+ (version "2.3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/team-charls/charls/")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g3f1rfimk30rqmi7ic4i5vfphyqbbpsyyhwqq1iss9wjwaz2vs5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DCMAKE_BUILD_TYPE:STRING=Release"
+ "-DBUILD_SHARED_LIBS=On")))
+ (native-inputs (list git pkg-config))
+ (home-page "https://github.com/team-charls/charls")
+ (synopsis "Library for using JPEG-LS compliant images")
+ (description
+ "CharLS is a codec library that can be used to build applications that
+can handle JPEG-LS compliant images. In the application you are writing you
+can call the CharLS codec and pass it images (sometimes called raster bitmaps),
+ to have them encoded to JPEG-LS, or JPEG-LS streams, which CharLS will decode
+to images.")
+ (license license:bsd-3)))
--
2.38.1
T
T
Tor-björn Claesson wrote on 28 Dec 2022 15:09
Comments
(address . 60377@debbugs.gnu.org)
87cz837gzp.fsf@gmail.com
Hi!

Thanks for making GUIX, it is a lot of fun!

This is a package of charls, which is a dependency of gdcm, which I in
turn need and am packaging.

I'm able to build gdcm with this charls-package, and think this package
seems fairly straight forward (though I don't have previous experience
packaging for GUIX or writing Guile).

I'm not sure about the style of the description, it is from the charls
home-page, which I used since English is not my first language and I
wanted to respect the original authors.

--
Best regards,
Tor-björn Claesson
L
L
Ludovic Courtès wrote on 5 Jan 2023 23:08
Re: bug#60377: [PATCH] gnu: Add charls
(name . Tor-björn Claesson)(address . tclaesson@gmail.com)(address . 60377-done@debbugs.gnu.org)
87h6x41vp0.fsf@gnu.org
Hi,

Tor-björn Claesson <tclaesson@gmail.com> skribis:

Toggle quote (4 lines)
> gnu: Add charls
> ---
> gnu/packages/image-processing.scm | 28 ++++++++++++++++++++++++++++

Applied with a commit log that follows the ChangeLog format (see

Toggle quote (2 lines)
> Thanks for making GUIX, it is a lot of fun!

Heh, glad to share the fun. :-)

Toggle quote (11 lines)
> This is a package of charls, which is a dependency of gdcm, which I in
> turn need and am packaging.
>
> I'm able to build gdcm with this charls-package, and think this package
> seems fairly straight forward (though I don't have previous experience
> packaging for GUIX or writing Guile).
>
> I'm not sure about the style of the description, it is from the charls
> home-page, which I used since English is not my first language and I
> wanted to respect the original authors.

The package looks perfect to me. Welcome on board!

Thanks,
Ludo’.
Closed
?