[PATCH] gnu: latex2html: Update to 2022.2, use new package style.

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Christopher Baines
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 26 Dec 2022 21:55
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
20221226205516.14502-1-kiasoc5@disroot.org
* gnu/packages/documentation.scm (latex2html): Update to 2022.2.
[arguments]: Use G-expressions. Remove trailing #t. Use #$output instead of
assoc-ref.
---
gnu/packages/documentation.scm | 41 ++++++++++++++++------------------
1 file changed, 19 insertions(+), 22 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index 3ded8e1cac..f0cc10bc49 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -66,7 +66,7 @@ (define-module (gnu packages documentation)
(define-public latex2html
(package
(name "latex2html")
- (version "2020.2")
+ (version "2022.2")
(source
(origin
(method git-fetch)
@@ -76,29 +76,26 @@ (define-public latex2html
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1icyl6kl60wh7cavprgbd8q6lpjwr7wn24m34kpiif7ahknhcbcm"))))
+ (base32 "1z71anjzxy5jsdlaqba4w9spncc6iycldarnr2z1dq8xmk6yhpjn"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-configure
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "configure"
- (("/usr/local")
- (assoc-ref outputs "out"))
- (("\\$\\{CONFIG_SHELL-/bin/sh\\}")
- (which "bash")))
- #t))
- (replace 'configure
- (lambda _
- (invoke "./configure")
- #t))
- (add-after 'configure 'patch-cfgcache
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "cfgcache.pm"
- (("/usr/local")
- (assoc-ref outputs "out")))
- #t)))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "configure"
+ (("/usr/local")
+ #$output)
+ (("\\$\\{CONFIG_SHELL-/bin/sh\\}")
+ (which "bash")))))
+ (replace 'configure
+ (lambda _
+ (invoke "./configure")))
+ (add-after 'configure 'patch-cfgcache
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "cfgcache.pm"
+ (("/usr/local")
+ #$output)))))))
(inputs
(list perl))
(synopsis "LaTeX documents to HTML")

base-commit: 7c476873e0300711bf92668cf01abd28f7295ead
--
2.39.0
C
C
Christopher Baines wrote on 16 Jan 2023 21:38
(name . kiasoc5)(address . kiasoc5@disroot.org)
87cz7e43l7.fsf@cbaines.net
kiasoc5 via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (7 lines)
> * gnu/packages/documentation.scm (latex2html): Update to 2022.2.
> [arguments]: Use G-expressions. Remove trailing #t. Use #$output instead of
> assoc-ref.
> ---
> gnu/packages/documentation.scm | 41 ++++++++++++++++------------------
> 1 file changed, 19 insertions(+), 22 deletions(-)

Looks good to me :) Pushed to master as
ab09e8e578480463bafd8e21451acf9dd6ddd74f.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmPFtdRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcWchAAoZHMYuvU9FeIMcQHxXfR76zi8wCIoqcJ
236mzotayUH/HsMhcvwZi16L028mYPsEP1dpGOIIIGaWjC5MwWIdCHob+ZlmWU7u
s9evfuw03UuA/Uls8e23sJ/YUo0K5RMPZlYq10MVLVdj8bhmK/qRbYQFhRnqFWZ1
mo6mvNZwz06iqXBWrJxitpB7ru9kX1NgI9zeBIMPStqNlFrgf3CetkEeR5UsVgqP
kDXxZf5NH7ytPgyqK2kjXPjPPSTqfbhqJLs0LsxNlDmO8rKRdcNPS3Jj8ibjVAw0
gJQTDzQc9fezAnYc7Fsm3je6nGGJGE/td+CZIGigE1PZT+izGzhIQ6RI/ECnTe5M
t2j2NLYvwbxaCpab6TY4NYpKcqqZ+SWlpzJMjpv5hY2ryXs/6XbAw2WAumKTFWMk
zzMJgD9lvNXvMpr13EsuIu3LAy2/Hp2ez4gkCIDIg5jO1C2A6U7lIgB+aZwohhrT
VfSahExYeD/lMHArvtuCaV1dP7X6rdtOqoqLowsqkBCMusY6WzwGCaR8l2eviERd
jJZ1CphyoF4TtuV+Czcwr5cnFGSIG3+HwODZNuBQJDplv0zi868MMrvttuAphXld
aiOxUeKKwaV04YjDP4Iyh4BrOVRRFrESnekuG9kpmXTM8cVYxWQjslo9AqOM45bV
7FhasvPuMQw=
=Fqu/
-----END PGP SIGNATURE-----

?