[PATCH] gnu: Add python-pysimplesoap.

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Lechner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 21 Dec 2022 15:48
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
20221221144821.6208-1-felix.lechner@lease-up.com
* gnu/packages/python-web.scm (python-pysimplesoap): New variable.
---
gnu/packages/python-web.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 18c0b47b67..6daf82fea1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7964,6 +7964,26 @@ (define-public python-zeep
@end itemize")
(license license:expat)))
+(define-public python-pysimplesoap
+ (package
+ (name "python-pysimplesoap")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PySimpleSOAP" version))
+ (sha256
+ (base32
+ "1qb7dn8m1cjwzql7vqj9i1hsscb7nyhimmlp45jrpzxds38g9fxi"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:tests? #f)) ; tests fail due to attempted web access
+ (home-page "https://github.com/pysimplesoap/pysimplesoap")
+ (synopsis "Python simple and lightweight SOAP Library")
+ (description "Python simple and lightweight SOAP library for client and
+server webservices interfaces, aimed to be as small and easy as possible,
+supporting most common functionality.")
+ (license license:lgpl3+)))
+
(define-public python-http-client
(package
(name "python-http-client")
--
2.38.1
L
L
Ludovic Courtès wrote on 26 Jan 2023 11:06
(name . Felix Lechner)(address . felix.lechner@lease-up.com)(address . 60239-done@debbugs.gnu.org)
87zga5pq32.fsf@gnu.org
Hi,

Felix Lechner <felix.lechner@lease-up.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-web.scm (python-pysimplesoap): New variable.

Applied with the cosmetic changes below.

Thanks,
Ludo’.
Toggle diff (23 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5597862a5b..ac0fb6f8a7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7999,12 +7999,13 @@ (define-public python-pysimplesoap
"1qb7dn8m1cjwzql7vqj9i1hsscb7nyhimmlp45jrpzxds38g9fxi"))))
(build-system python-build-system)
(arguments
- (list #:tests? #f)) ; tests fail due to attempted web access
+ (list #:tests? #f)) ;tests fail due to attempted web access
(home-page "https://github.com/pysimplesoap/pysimplesoap")
- (synopsis "Python simple and lightweight SOAP Library")
- (description "Python simple and lightweight SOAP library for client and
-server webservices interfaces, aimed to be as small and easy as possible,
-supporting most common functionality.")
+ (synopsis "Simple and lightweight SOAP library for Python")
+ (description
+ "This package provides a simple and lightweight Python SOAP library for
+client and server webservices interfaces, aimed to be as small and easy as
+possible, supporting most common functionality.")
(license license:lgpl3+)))
(define-public python-http-client
Closed
?