[PATCH] gnu: Add d-spy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 18 Dec 2022 16:29
(address . guix-patches@gnu.org)
3a6ad45cf33fc140dc34e8f116b49207c59a9062.camel@gmail.com
* gnu/packages/gnome.scm (d-spy): New variable.
---
gnu/packages/gnome.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b6ff8d4fe7..d584d42829 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7429,6 +7429,47 @@ (define-public d-feet
of running programs and invoke methods on those interfaces.")
(license license:gpl2+)))
+(define-public d-spy
+ (package
+ (name "d-spy")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wk7i3vyq4a98g29ms7vz3wy8xkk3pgw48g0fm65qk32xa679s7a"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")))))))
+ (native-inputs
+ (list desktop-file-utils ; for update-desktop-database
+ `(,glib "bin")
+ gettext-minimal
+ pkg-config))
+ (inputs
+ (list gobject-introspection
+ gtk
+ libadwaita))
+ (home-page "https://gitlab.gnome.org/GNOME/d-spy")
+ (synopsis "D-Bus debugger")
+ (description
+ "D-Spy is a tool to explore and test end-points and interfaces of running
+programs via D-Bus. It also ships a library for integration into development
+environments.")
+ (license license:gpl2+)))
+
(define-public yelp-xsl
(package
(name "yelp-xsl")
--
2.38.1
L
L
Ludovic Courtès wrote on 17 Jan 2023 15:56
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 60179@debbugs.gnu.org)
87fsc9gqg2.fsf@gnu.org
Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (d-spy): New variable.

LGTM, thanks!
L
L
Liliana Marie Prikler wrote on 5 Feb 2023 07:18
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 60179-done@debbugs.gnu.org)
ac800dbb5c5819ec752335f58388595c66c1f27d.camel@gmail.com
Am Dienstag, dem 17.01.2023 um 15:56 +0100 schrieb Ludovic Courtès:
Toggle quote (5 lines)
> Liliana Marie Prikler <liliana.prikler@gmail.com> skribis:
>
> > * gnu/packages/gnome.scm (d-spy): New variable.
>
> LGTM, thanks!
Forgot to mark as done.

Thanks
Closed
?