[PATCH 0/2] Update samba

  • Done
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 18 Dec 2022 08:40
(address . guix-patches@gnu.org)
aaf179b125ac22625be4dd625ed00d9524091f4c.camel@gmail.com
Hi Guix,

this series updates samba to the latest version and grafts
samba/fixed (used by libsoup) to the latest patch within the
4.15.13 branch.

Cheers

Liliana Marie Prikler (2):
gnu: samba: Update to 4.17.4.
gnu: samba/fixed: Update to 4.15.13.

gnu/packages/samba.scm | 20 +++++++++++++++++---
1 file changed, 17 insertions(+), 3 deletions(-)

--
2.38.1
L
L
Liliana Marie Prikler wrote on 18 Dec 2022 08:28
[PATCH 1/2] gnu: samba: Update to 4.17.4.
(address . 60173@debbugs.gnu.org)
611434bbbe7bbfbef7c1a425833a1abe38db40b1.camel@gmail.com
* gnu/packages/samba.scm (samba): Update to 4.17.4.
---
gnu/packages/samba.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 2a01279161..64f821abc0 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -187,7 +187,7 @@ (define (install dir)
(define-public samba
(package
(name "samba")
- (version "4.16.4")
+ (version "4.17.4")
(source
;; For updaters: the current PGP fingerprint is
;; 81F5E2832BD2545A1897B713AA99442FB680B620.
@@ -196,7 +196,7 @@ (define-public samba
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
- (base32 "0bvhqinxwpbwp4ayhd9q8ga0w89gnkl1m3nrwpj1fnhjzd4ghclm"))))
+ (base32 "0ds53yz2d8s5yvkka1z9ysnb6bkbppmqmhd4rry71b2cvdwj0lf0"))))
(build-system gnu-build-system)
(arguments
(list
--
2.38.1
L
L
Liliana Marie Prikler wrote on 18 Dec 2022 08:29
[PATCH 2/2] gnu: samba/fixed: Update to 4.15.13.
(address . 60173@debbugs.gnu.org)
b322b1c7384d95742d3910805e69a6b2d41ae777.camel@gmail.com
* gnu/packages/samba.scm (samba/fixed-patched): New variable.
(samba/fixed): Add replacement for samba/fixed-patched.
---
gnu/packages/samba.scm | 16 +++++++++++++++-
1 file changed, 15 insertions(+), 1 deletion(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 64f821abc0..1f2a231596 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -295,7 +295,9 @@ (define-public samba
(define-public samba/fixed
;; Version that rarely changes, depended on by libsoup.
(hidden-package
- (package/inherit samba
+ (package
+ (inherit samba)
+ (replacement samba/fixed-patched)
(version "4.15.3")
(source
(origin
@@ -319,6 +321,18 @@ (define-public samba/fixed
libxslt
libxml2)))))
+(define-public samba/fixed-patched
+ (package
+ (inherit samba/fixed)
+ (version "4.15.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.samba.org/pub/samba/stable/"
+ "samba-" version ".tar.gz"))
+ (sha256
+ (base32 "0s29vzn5f42vjhx6h25c7v67n14ymqxn8glqa97d0rajd99y64n4"))))))
+
(define-public talloc
(package
(name "talloc")
--
2.38.1
L
L
Liliana Marie Prikler wrote on 18 Dec 2022 08:28
[PATCH v2 1/2] gnu: samba: Update to 4.16.8.
(address . 60173@debbugs.gnu.org)
ebe07f5d3bace4c2727ff7e3c67de0c2fba4817a.camel@gmail.com
* gnu/packages/samba.scm (samba): Update to 4.16.8.
---
gnu/packages/samba.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 2a01279161..2fe75d0c1a 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -187,7 +187,7 @@ (define (install dir)
(define-public samba
(package
(name "samba")
- (version "4.16.4")
+ (version "4.16.8")
(source
;; For updaters: the current PGP fingerprint is
;; 81F5E2832BD2545A1897B713AA99442FB680B620.
@@ -196,7 +196,7 @@ (define-public samba
(uri (string-append "https://download.samba.org/pub/samba/stable/"
"samba-" version ".tar.gz"))
(sha256
- (base32 "0bvhqinxwpbwp4ayhd9q8ga0w89gnkl1m3nrwpj1fnhjzd4ghclm"))))
+ (base32 "11a1vikbijaq7csg49h5ivn25gx84v6wx8z8kgsj1wmkhsf9bcmv"))))
(build-system gnu-build-system)
(arguments
(list
--
2.38.1
L
L
Liliana Marie Prikler wrote on 18 Dec 2022 08:29
[PATCH v2 2/2] gnu: samba/fixed: Update to 4.15.13.
(address . 60173@debbugs.gnu.org)
1583189a480a3ce778b9916210b50b06bea40629.camel@gmail.com
* gnu/packages/samba.scm (samba/fixed-patched): New variable.
(samba/fixed): Add replacement for samba/fixed-patched.
---
gnu/packages/samba.scm | 16 +++++++++++++++-
1 file changed, 15 insertions(+), 1 deletion(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 2fe75d0c1a..b6cb0a5941 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -295,7 +295,9 @@ (define-public samba
(define-public samba/fixed
;; Version that rarely changes, depended on by libsoup.
(hidden-package
- (package/inherit samba
+ (package
+ (inherit samba)
+ (replacement samba/fixed-patched)
(version "4.15.3")
(source
(origin
@@ -319,6 +321,18 @@ (define-public samba/fixed
libxslt
libxml2)))))
+(define-public samba/fixed-patched
+ (package
+ (inherit samba/fixed)
+ (version "4.15.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.samba.org/pub/samba/stable/"
+ "samba-" version ".tar.gz"))
+ (sha256
+ (base32 "0s29vzn5f42vjhx6h25c7v67n14ymqxn8glqa97d0rajd99y64n4"))))))
+
(define-public talloc
(package
(name "talloc")
--
2.38.1
L
L
Liliana Marie Prikler wrote on 31 Dec 2022 08:36
Re: [PATCH v2 1/2] gnu: samba: Update to 4.16.8.
(address . 60173-done@debbugs.gnu.org)
b66643811e93898fd84f18007a05b64ba34dfe59.camel@gmail.com
Am Sonntag, dem 18.12.2022 um 08:28 +0100 schrieb Liliana Marie
Prikler:
Toggle quote (2 lines)
> * gnu/packages/samba.scm (samba): Update to 4.16.8.
> ---
QA didn't test this, but rather the older one, which updated to the
incompatible 4.17 line. Pushed, because the offending package built
locally.

Cheers
Closed
?