[PATCH] image: Enhance compatibility of the root ext4 partition.

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 14 Dec 2022 03:17
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
20221214021752.23011-1-maxim.cournoyer@gmail.com
Generating a raw-with-offset image would previously not be bootable with
U-Boot.

* gnu/system/image.scm (root-partition) [file-system-options]: New field.
---
gnu/system/image.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/system/image.scm b/gnu/system/image.scm
index f07a4a5217..2bf4559501 100644
--- a/gnu/system/image.scm
+++ b/gnu/system/image.scm
@@ -138,6 +138,9 @@ (define root-partition
(size 'guess)
(label root-label)
(file-system "ext4")
+ ;; Disable the metadata_csum and 64bit features of ext4, for compatibility
+ ;; with U-Boot.
+ (file-system-options (list "-O" "^metadata_csum,^64bit"))
(flags '(boot))
(initializer (gexp initialize-root-partition))))

base-commit: 0ffa501f2b3e83ae56e9c2bd31418439090e869a
prerequisite-patch-id: 660177fb9eee55d11983ea9360c072730d0d21a5
prerequisite-patch-id: 776778c03bce9b7ad3ab94a120f42b764c00fcae
prerequisite-patch-id: 4910d08bdc27384d76030b6ac491ad2c2ed0957f
prerequisite-patch-id: fd4074fb4cf068ccac3122c19138f098a610542a
prerequisite-patch-id: b9b6f21a2db3f7a5ef82bb11ed23f69749cc6b3d
prerequisite-patch-id: 51cecbabc04c69d4338addaece536c42a075660f
prerequisite-patch-id: 2c67bfd85b343a65440e6c63451e5417129dea6f
prerequisite-patch-id: b24087b240dad97b6417e37176915c24a543e887
prerequisite-patch-id: 2b8e69760af1f7bfb66c1edb44471653b6b229d1
prerequisite-patch-id: 2cb8792eedc8cfc23b4728f9ec44366aa394b954
prerequisite-patch-id: 8684fb6949ced334698dbf32ae71dd76c5eb2cfe
prerequisite-patch-id: 4cc71f61e136fd7288e767ce02bef3b711ea1ad2
prerequisite-patch-id: 69318aca2af97593db0737a035ff646414d61016
--
2.38.1
M
M
Mathieu Othacehe wrote on 25 Dec 2022 17:09
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 60057@debbugs.gnu.org)
87lemvfort.fsf@gnu.org
Hello Maxim,

Toggle quote (6 lines)
> + ;; Disable the metadata_csum and 64bit features of ext4, for compatibility
> + ;; with U-Boot.
> + (file-system-options (list "-O" "^metadata_csum,^64bit"))
> (flags '(boot))
> (initializer (gexp initialize-root-partition))))

ext4 man page states that ^64bit will prevent images larger than 2^32
blocks but I highly doubt that we will generate someday images that big.

I think you can go ahead!

Mathieu
M
M
Maxim Cournoyer wrote on 27 Dec 2022 04:48
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 60057-done@debbugs.gnu.org)
87sfh17bi0.fsf@gmail.com
Hi Mathieu!

Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (13 lines)
> Hello Maxim,
>
>> + ;; Disable the metadata_csum and 64bit features of ext4, for compatibility
>> + ;; with U-Boot.
>> + (file-system-options (list "-O" "^metadata_csum,^64bit"))
>> (flags '(boot))
>> (initializer (gexp initialize-root-partition))))
>
> ext4 man page states that ^64bit will prevent images larger than 2^32
> blocks but I highly doubt that we will generate someday images that big.
>
> I think you can go ahead!

OK! Pushed as 60d4652c5d.

Thank you!

--
Maxim
Closed
?