[PATCH] gnu: Add nwg-launchers

  • Done
  • quality assurance status badge
Details
5 participants
  • Sughosha
  • Josselin Poiret
  • florhizome
  • (
  • Vagrant Cascadian
Owner
unassigned
Submitted by
florhizome
Severity
normal
F
F
florhizome wrote on 12 Dec 2022 11:47
(address . guix-patches@gnu.org)(name . florhizome)(address . florhizome@posteo.net)
b3796f8b6eb6b332fdbf21407972c78c978f782a.1670841891.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

* gnu/packages/wm.scm (nwg-launchers): New variable.
---
gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d3a7716c23..7f81efff96 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1806,6 +1806,31 @@ (define-public wlr-randr
(description "wlr-randr is a utility to manage outputs of a Wayland compositor.")
(license license:expat))) ; MIT license
+
+(define-public nwg-launchers
+ (package
+ (name "nwg-launchers")
+ (version "0.7.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/nwg-piotr/nwg-launchers")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0hq2qiqxvrw3g515ywcb676ljc8mdw3pyslgxr3vahizfljah1pv"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list git-minimal pkg-config))
+ (inputs
+ (list gtk-layer-shell gtkmm-3 json-modern-cxx librsvg))
+ (synopsis "GTK-based launchers")
+ (description "This package provides application grid, button bar and dmenu
+ applications for sway and other window managers.")
+ (home-page "https://github.com/nwg-piotr/nwg-launchers")
+ (license license:expat)))
+
(define-public mako
(package
(name "mako")
--
2.38.1
F
F
florhizome wrote on 12 Dec 2022 22:34
[PATCH v2] gnu: Add nwg-launchers
(address . 59999@debbugs.gnu.org)(name . florhizome)(address . florhizome@posteo.net)
1ae53429318a31f6d38ab9d3f2c489143dd83b52.1670880774.git.florhizome@posteo.net
From: florhizome <florhizome@posteo.net>

forgot to add these module references

---
gnu/packages/wm.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0068e3dfb3..5d07930976 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -103,6 +103,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages calendar)
#:use-module (gnu packages check)
#:use-module (gnu packages c)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
@@ -152,6 +153,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages textutils)
#:use-module (gnu packages time)
#:use-module (gnu packages video)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
@@ -2020,6 +2022,30 @@ (define-public wdisplays
-management-unstable-v1 protocol.")
(license license:gpl3+)))
+(define-public nwg-launchers
+ (package
+ (name "nwg-launchers")
+ (version "0.7.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/nwg-piotr/nwg-launchers")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "0hq2qiqxvrw3g515ywcb676ljc8mdw3pyslgxr3vahizfljah1pv"))))
+ (build-system meson-build-system)
+ (native-inputs
+ (list git-minimal pkg-config))
+ (inputs
+ (list gtk-layer-shell gtkmm-3 json-modern-cxx librsvg))
+ (synopsis "GTK-based launchers")
+ (description "This package provides application grid, button bar and dmenu
+ applications for sway and other window managers.")
+ (home-page "https://github.com/nwg-piotr/nwg-launchers")
+ (license license:expat)))
+
(define-public mako
(package
(name "mako")

base-commit: 0ce1f82e5aaac951b21d579eb46bf75cfe6713c0
prerequisite-patch-id: 36ae907c0ae2cbc001f774c0514ab217855270c2
prerequisite-patch-id: 2c99b804c1a929fc9d74b4c3d92263cbd296f785
prerequisite-patch-id: 2525aea715c2eb5be5f61e2e14296a36898413ca
prerequisite-patch-id: f7afbf36e2776eced1e69090ec127a40456efca4
prerequisite-patch-id: ba73cf06ab2610e36d03df1f6b6a1c4b8f271cda
prerequisite-patch-id: 9ac4b32603488e776af63831ff13406c649a8686
prerequisite-patch-id: 1cec3e6ed7a13938c53c24f816056d98b2b005c7
prerequisite-patch-id: 011ca6e0eaf4ea7077787d7030f193836c30aa82
prerequisite-patch-id: 4243cf3f6370445e6d583f03231e87921f541cc2
prerequisite-patch-id: 6c88bfec7b2fa53face9523329de4a9102149772
prerequisite-patch-id: d1bed6e8da46c3d6f4017546f7a00c001e814fe1
prerequisite-patch-id: 3096f437730db3ea683ab8eeec93d38e9cfed9e2
prerequisite-patch-id: 709b4522fd225f3c28bb2721e5dd9a20014ce131
prerequisite-patch-id: a02e8c00e53bf941c9049360c58959d2ebcf9608
prerequisite-patch-id: 859d3e5e1d8ef976bb6c4d7b6cce56ac2f138b88
prerequisite-patch-id: fc6e006241c41b19b4020981417823fd7a8cf931
prerequisite-patch-id: 4aa5ec94c128f5b6b6b6709c25baa49fffa571f6
--
2.38.1
(
CP060OR9JR9Q.GNXG2FG5TT68@guix-framework
Heya,

--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm

@@ -2020,6 +2022,30 @@ (define-public wdisplays
+ (uri
+ (git-reference
+ (commit (string-append "v" version))))

(file-name (git-file-name name version))

+ (synopsis "GTK-based launchers")

(synopsis "Application launchers for wlroots")

+ (description "This package provides application grid, button bar and dmenu
+ applications for sway and other window managers.")

(description
"This package provides an application grid, button bar, and dmenu
applications for Sway and other wlroots-based Wayland compositors.")

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmOXoGwACgkQ7ImHg/nq
I2335gv+Joe5YVuglKuNofZq5eDtqewY4Eq06156Nd4I3IKZLc3hg5lBdm1RhlIO
Tmrs3KAnPShjCXk1Iyd275SF6FfnciCpRkeGctUvQCjgmMRmrHLGzbS1zyAWIxLA
rH4XMceutVcd/wAyAnI3/WF87XcZelRWMGRJ4YJ0ueC3eOGvv52DEYJWNyLgc/aP
wwV8SuhXRobTMdjnLNfPRPVkk6lSI4nAI4Wllgju8YCLeJjg44a9Pj8V+gwFIFbW
ED+Puh8gzSFiH1s6ZZPa+dFGDFnJA5C/R5JA5RlkFlPScXhlOhYoKAJ+BXk7jG28
8aM6DgCIDwxgHsyQ5A3SNlF8ZjHGGSyD/JWHVHqeA9vP8TYVYXh1M9/Js/eOgJfk
3ToiOcQPDfwWcePBA2VFMIBYE/YY8oe+8xRYUI845UL3LuUuCPzonBmTr4hAuWWk
stj8LcH3fiaR3t6GsUYsCJfRx5rYuQh6bl+YbHVZqapfT2OOp2Rvh5vFeKWKPkTp
1lRKgCz5
=pTFq
-----END PGP SIGNATURE-----


S
S
Sughosha wrote on 27 Jan 2023 17:44
[PATCH] gnu: Add nwg-launchers.
(name . 59999@debbugs.gnu.org)(address . 59999@debbugs.gnu.org)
7kzutiqUZPVX5s3r9I5MGOLd1adGzoUH-6kWLJIiBYLsAcccd-nOZwJTZGTYA1DcKqDB_hvf7uQ8QeeQw9GtcujfeIoNq_jifECYEaa8C5I=@proton.me
I cannot merge the v2 patch into my local branch. I had nwg-launchers in my
local branch in xdisorg.scm but had not submitted the patch till now. The reason
for having it in xdisorg.scm is that I found similar packages like wofi and many
other launchers there. Here is the patch that I have.

* gnu/packages/xdisorg.scm (nwg-launchers): New variable.
---
gnu/packages/xdisorg.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index f6f0157..5f7d63d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -97,6 +97,7 @@
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
@@ -3061,6 +3062,29 @@ such as sway, similar to @command{rofi}.")
(home-page "https://hg.sr.ht/~scoopta/wofi")
(license license:gpl3+)))
+(define-public nwg-launchers
+ (package
+ (name "nwg-launchers")
+ (version "0.7.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nwg-piotr/nwg-launchers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hq2qiqxvrw3g515ywcb676ljc8mdw3pyslgxr3vahizfljah1pv"))))
+ (build-system meson-build-system)
+ (native-inputs (list json-modern-cxx pkg-config))
+ (inputs (list gtk-layer-shell gtkmm-3 librsvg))
+ (home-page "https://github.com/nwg-piotr/nwg-launchers")
+ (synopsis "GTK-based launchers")
+ (description
+ "This package provides application grid, button bar and dmenu applications
+for sway and other window managers.")
+ (license license:gpl3+)))
+
(define-public dex
(package
(name "dex")
--
libgit2 1.4.3
J
J
Josselin Poiret wrote on 3 Mar 2023 09:45
87y1oeql3j.fsf@jpoiret.xyz
Hi Sughosha,

Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> I cannot merge the v2 patch into my local branch. I had nwg-launchers in my
> local branch in xdisorg.scm but had not submitted the patch till now. The reason
> for having it in xdisorg.scm is that I found similar packages like wofi and many
> other launchers there. Here is the patch that I have.

Patch looks good to me (it is in fact GPLv3 and not Expat). I don't
think there's any other module that would be a better home for this
package, although the name itself is unfortunate.

Best,
--
Josselin Poiret
-----BEGIN PGP SIGNATURE-----

iQHEBAEBCAAuFiEEOSSM2EHGPMM23K8vUF5AuRYXGooFAmQBs7AQHGRldkBqcG9p
cmV0Lnh5egAKCRBQXkC5Fhcaio1NC/92zHejQ3YAkDwH/yWfmUAKpWIMtDmaPzkk
5O1obELbA6ekWF3hamOte0wbE30OyGZCvRKpLYkA8zujobuZo1jpQnpt7z4Rds85
HolJ0EmPb/YqIKhg8iFvtuaBXU96ET18bisw5sbgyqUlvwW3fUltSqxnMLfocSQ8
y17Ln2xkRF+m4uBcL0Cg8GlGcgQ/G2yBruemHs1yAvO3w7bZE67x/6jUTO91jINp
tNwVpmhH+ZxCVXaZwboBPkW1JHD/Y/Nzo3FfpRfMC7ftrDm4bAaEmn6IbmoDZIoh
9oGn+KgvBYyE98/hubTsdvo9siSgw5mu61uZ0d2j4aVujW1zbwItK804CbVMQFVi
BDy765V3V669k8IWsmJGWdHlZuA0d55qKizQRBZKhrwDnBWAVGNWa8JypTANg21d
ksnGkb26c6RmDpGvUDAJJhDuycTG7sdwXmJJBHJkOMOJz1GVlMNPn3bWLx5skC15
XXyU7Ok6Vuf6H1yQEBlnI2728z+aBkc=
=pi0S
-----END PGP SIGNATURE-----

F
F
florhizome wrote on 14 Mar 2023 16:40
[PATCH] gnu: Add nwg-launchers
(address . 59999@debbugs.gnu.org)
4129fb10665038093925645a13d3a31c4153042c.camel@posteo.net
Hey,
consider this a ping.
I think it would be good to have a module for general desktop utilities
, maybe desktop.scm. Maybe I will propose to open it with a new patch
for another outstanding package.
Cheers.
V
V
Vagrant Cascadian wrote on 2 Sep 2023 06:48
Re: [bug#59999] [PATCH] gnu: Add nwg-launchers.
(name . florhizome)(address . florhizome@posteo.net)
87wmx9nptk.fsf@wireframe
On 2023-01-27, Sughosha wrote:
Toggle quote (5 lines)
> +(define-public nwg-launchers
> + (package
> + (name "nwg-launchers")
> + (version "0.7.1.1")

Merged as:

39c50eb49540bbc90b20152520be4fd095d5f979 gnu: Add nwg-launchers.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPK+hwAKCRDcUY/If5cW
qv5UAQDaTFJl1yHh3SIGoZU2Osrc0sGB/RJWdOJn1xkJmIOAtgEA9GZNJbFJGqjI
xfy8AYPFr1/ttoIjaMlJpHc9cUmwkw8=
=14K8
-----END PGP SIGNATURE-----

Closed
?