[PATCH] gnu: Add emacs-islisp-mode

  • Done
  • quality assurance status badge
Details
2 participants
  • Joeke de Graaf
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Joeke de Graaf
Severity
normal
J
J
Joeke de Graaf wrote on 9 Dec 2022 22:01
(address . guix-patches@gnu.org)
87pmcse1fo.fsf@kleptop.mail-host-address-is-not-set
This patch adds emacs-islisp-mode to emacs-xyz.scm

Best regards,

Joeke de Graaf
From fc661dcc856de74034964fd0734cabce5cef4eaa Mon Sep 17 00:00:00 2001
From: Joeke <joeke@posteo.net>
Date: Fri, 9 Dec 2022 21:52:40 +0100
Subject: [PATCH] gnu: Add emacs-islisp-mode

---
gnu/packages/emacs-xyz.scm | 41 ++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0d11c59b48..4170787ca1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -118,6 +118,7 @@
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
+;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13125,6 +13126,46 @@ (define-public emacs-helm-make
target will call @code{compile} on it.")
(license license:gpl3+))))
+(define-public emacs-islisp-mode
+ (package
+ (name "emacs-islisp-mode")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/sasanidas/islisp-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s6alrv1hfi1plj5lh826j0h71xvm2v092kglj3yvy34g73dgrna"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ ;; Install Emacs Lisp files from the "advance"
+ ;; and "implementations" directories
+ (add-after 'install 'install-additional-directories
+ (lambda _
+ (let ((site-lisp-dir (string-append #$output
+ "/share/emacs/site-lisp/islisp-mode-"
+ #$version)))
+ (map (lambda (dir)
+ (with-directory-excursion dir
+ (for-each (lambda (file)
+ (install-file file
+ site-lisp-dir))
+ (find-files "." "\\.el$"))))
+ '("advance" "implementations"))))))))
+ (home-page "https://gitlab.com/sasanidas/islisp-mode")
+ (synopsis "ISLisp support for Emacs")
+ (description
+ "This package provides support for programming with ISLisp in
+Emacs. It features a major mode with syntax highlighting, symbol autocompletion
+and documentation search, among other features. It also includes an inferior
+mode with REPL integration. Currently it only supports the Easy ISLisp (eisl)
+implementation.")
+ (license license:gpl3+)))
+
(define-public emacs-cider
(package
(name "emacs-cider")
--
2.37.2
N
N
Nicolas Goaziou wrote on 14 Dec 2022 17:36
(name . Joeke de Graaf)(address . joeke@posteo.net)(address . 59930@debbugs.gnu.org)
875yeegcxa.fsf@nicolasgoaziou.fr
Hello,

Joeke de Graaf <joeke@posteo.net> writes:

Toggle quote (2 lines)
> This patch adds emacs-islisp-mode to emacs-xyz.scm

Thank you. Some comments follow.

Toggle quote (11 lines)
> + (build-system emacs-build-system)
> + (arguments
> + (list #:phases #~(modify-phases %standard-phases
> + ;; Install Emacs Lisp files from the "advance"
> + ;; and "implementations" directories
> + (add-after 'install 'install-additional-directories
> + (lambda _
> + (let ((site-lisp-dir (string-append #$output
> + "/share/emacs/site-lisp/islisp-mode-"
> + #$version)))

You can use (elpa-directory #$output) instead of (string-append ...)

Toggle quote (8 lines)
> + (map (lambda (dir)
> + (with-directory-excursion dir
> + (for-each (lambda (file)
> + (install-file file
> + site-lisp-dir))
> + (find-files "." "\\.el$"))))
> + '("advance" "implementations"))))))))

You can use for-each instead of map since you don't need the return
value. Moreover, `copy-recursively' is probably shorter.

However, this will catch neither the ".el" file nor the ".lsp" file in
"implementations/easy-islisp" directory. What should we do about the
latter ?

You also need to add `eisl' as an input, and patch "easy-islisp.el"
accordingly (see `easy-islisp-executable').

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
J
J
Joeke de Graaf wrote on 16 Dec 2022 14:14
(address . 59930@debbugs.gnu.org)
fecca502e597a46ec77484968e378fa4@posteo.net
Toggle quote (2 lines)
> You can use (elpa-directory #$output) instead of (string-append ...)

Thanks, I did not know about elpa-directory.

> You can use for-each instead of map since you don't need the return
> value. Moreover, `copy-recursively' is probably shorter.
>
> However, this will catch neither the ".el" file nor the ".lsp" file
in
> "implementations/easy-islisp" directory. What should we do about the
> latter ?

It seems Emacs has a hard time finding easy-islisp.el when using
copy-recursively, since it's put inside a directory. The easy solution
would be to 'expand' the regex in find-files like this:

(lambda _
(let ((site-lisp-dir (elpa-directory #$output)))
(for-each (lambda (dir)
(copy-recursively dir elpa-directory)
(with-directory-excursion dir
(for-each (lambda (file)
(install-file file
site-lisp-dir))
(find-files "." "\\.(lsp|el)$"))))
'("advance" "implementations"))))

Are there any objections to doing it this way? (Other than it being a
lot less pretty than a call to copy-recursively ?)

> You also need to add `eisl' as an input,
> and patch "easy-islisp.el"
> accordingly (see `easy-islisp-executable').

I incorporated this in the new patch.

I have attached an updated version below.

Thanks for reviewing!
From 19437af399658570116e403ec85162369f7db6b0 Mon Sep 17 00:00:00 2001
From: Joeke <joeke@posteo.net>
Date: Fri, 16 Dec 2022 14:05:43 +0100
Subject: [PATCH] gnu: Add emacs-islisp-mode

---
gnu/packages/emacs-xyz.scm | 52 ++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0d11c59b48..2322194d6f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -118,6 +118,7 @@
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Thiago Jung Bauermann <bauermann@kolabnow.com>
+;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -13125,6 +13126,57 @@ (define-public emacs-helm-make
target will call @code{compile} on it.")
(license license:gpl3+))))
+(define-public emacs-islisp-mode
+ (package
+ (name "emacs-islisp-mode")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/sasanidas/islisp-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s6alrv1hfi1plj5lh826j0h71xvm2v092kglj3yvy34g73dgrna"))))
+ (build-system emacs-build-system)
+ (inputs (list eisl))
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-eisl-variables
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (emacs-substitute-variables
+ "implementations/easy-islisp/easy-islisp.el"
+ ("easy-islisp-executable" (search-input-file
+ inputs "/bin/eisl"))
+ ("easy-islisp-library-directory" `(if (getenv
+ "EASY_ISLISP")
+ (getenv
+ "EASY_ISLISP")
+ ,(search-input-directory
+ inputs
+ "share/eisl/library"))))))
+ (add-after 'install 'install-additional-directories
+ (lambda _
+ (let ((site-lisp-dir (elpa-directory #$output)))
+ (for-each (lambda (dir)
+ (with-directory-excursion dir
+ (for-each (lambda (file)
+ (install-file file
+ site-lisp-dir))
+ (find-files "."
+ "\\.(lsp|el)$"))))
+ '("advance" "implementations"))))))))
+ (home-page "https://gitlab.com/sasanidas/islisp-mode")
+ (synopsis "ISLisp support for Emacs")
+ (description
+ "This package provides support for programming with ISLisp in
+Emacs. It features a major mode with syntax highlighting, symbol autocompletion
+and documentation search, among other features. It also includes an inferior
+mode with REPL integration. Currently it only supports the Easy ISLisp (eisl)
+implementation.")
+ (license license:gpl3+)))
+
(define-public emacs-cider
(package
(name "emacs-cider")
--
2.37.2
N
N
Nicolas Goaziou wrote on 16 Dec 2022 18:54
(name . Joeke de Graaf)(address . joeke@posteo.net)(address . 59930-done@debbugs.gnu.org)
874jtvdyk4.fsf@nicolasgoaziou.fr
Hello,

Joeke de Graaf <joeke@posteo.net> writes:

Toggle quote (2 lines)
> I have attached an updated version below.

Thank you. I applied it with a small refactoring.

Regards,
--
Nicolas Goaziou
Closed
?