[PATCH] gnu: go-gopkg-in-yaml-v3: update after hash mismatch

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Gleb Zakharov
Owner
unassigned
Submitted by
Gleb Zakharov
Severity
normal
G
G
Gleb Zakharov wrote on 9 Dec 2022 16:04
(address . guix-patches@gnu.org)(name . Gleb Zakharov)(address . snyssfx@gmail.com)
20221209150437.28361-1-snyssfx@gmail.com
It seems the authors of go yaml package made a bugfix
in the repository and updated the v3 branch. Because of
the resulting hash mismatch, a docker package couldn't
be built.

I updated the hash, changed a version from
a branch of the repository to the v3.0.1 tag
and applied guix style command.
---
gnu/packages/golang.scm | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 70ddef52f1..b49fe7566d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 Gleb Zakharov <snyssfx@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4520,21 +4521,20 @@ (define-public go-gopkg-in-yaml-v2
(define-public go-gopkg-in-yaml-v3
(package
(name "go-gopkg-in-yaml-v3")
- (version "3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gopkg.in/yaml.v3")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "06f4lnrp494wqaygv09dggr2dwf3z2bawqhnlnnwiamg5y787k4g"))))
+ (version "3.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/yaml.v3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "01b0wjb7yzv8wzzz2iim8mjpkwjnykcanrwiq06pkl89lr6gv8hn"))))
(build-system go-build-system)
(arguments
'(#:import-path "gopkg.in/yaml.v3"))
- (native-inputs
- (list go-gopkg-in-check-v1))
+ (native-inputs (list go-gopkg-in-check-v1))
(home-page "https://gopkg.in/yaml.v3")
(synopsis "YAML reader and writer for the Go language")
(description

base-commit: 0ffa501f2b3e83ae56e9c2bd31418439090e869a
--
2.38.1
T
T
Tobias Geerinckx-Rice wrote on 15 Feb 2023 11:51
(address . 59927-done@debbugs.gnu.org)
87k00jcher.fsf@nckx
Hi Gleb,

Thanks for this fix! I've applied it with suitable delay to the
master branch.

I added a GNU ‘Change Log’ line to follow our standards[1].
Trivial in this case but always required:

* gnu/packages/golang.scm (go-gopkg-in-yaml-v3): Update to
3.0.1.

Don't mix unrelated changes: ‘guix style’ turned this
trivially-audited patch:

-(version "3")
+(version "3.0.1")
-(base32 "foo")
+(base32 "bar")

into a 20-line diff :-)

Unfortunately, such changes are not considered copyrightable by
current standards.

I disagreed with ‘guix style's’ mangling of the source field, so I
just dropped it entirely.

Thanks again!

T G-R

[1]:
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCY+y93A0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15kVsBAIboODj+u7LTooTYY8a2KBCePhGRTmg5HNwIUgU1
GVs/AQDgJixwdanCXvrKWCboZe2LXP31n/vXYWcED7t75TL4Cw==
=PyH1
-----END PGP SIGNATURE-----

Closed
?