[PATCH] gnu: rasdaemon: Add missing inputs and rewrite using G-Exps.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • mirai
Owner
unassigned
Submitted by
mirai
Severity
normal
M
M
mirai wrote on 6 Dec 2022 16:51
(address . guix-patches@gnu.org)(name . Bruno Victal)(address . mirai@makinata.eu)
f90029d2b0646e8b97a616cbe70422b3e6df900c.1670341868.git.mirai@makinata.eu
From: Bruno Victal <mirai@makinata.eu>

* gnu/packages/linux.scm (rasdaemon)[arguments]: Rewrite using G-Expressions and add missing inputs.
---
gnu/packages/linux.scm | 50 +++++++++++++++++++++++++-----------------
1 file changed, 30 insertions(+), 20 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 49e90a9ba6..2d3d50c5e1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9472,27 +9472,37 @@ (define-public rasdaemon
(sha256
(base32 "0r0339mg4rc12p63iiq2kwdqn1zjakyiv014i2a2l9s8v5rjik41"))))
(native-inputs (list autoconf automake libtool))
- (inputs (list perl sqlite))
+ (inputs (list perl perl-dbd-sqlite sqlite dmidecode kmod))
(arguments
- `(#:configure-flags
- (list "--enable-all"
- ;; Don't install unused /etc/sysconfig/rasdaemon environment file.
- "--with-sysconfdefdir=."
- "--localstatedir=/var")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'munge-autotools
- (lambda _
- ;; For some reason upstream forces sysconfdir=/etc. This results
- ;; in EPERM during the install phase. Removing the offending
- ;; line lets sysconfdir correctly pick up DESTDIR.
- (substitute* "configure.ac"
- (("^test .* sysconfdir=/etc\n$") ""))
- ;; Upstream tries to create /var/lib/rasdaemon at install time.
- ;; This results in EPERM on guix. Instead, the service should
- ;; create this at activation time.
- (substitute* "Makefile.am"
- (("^\\s*\\$\\(install_sh\\) -d .*@RASSTATEDIR@.*$") "")))))))
+ (list
+ #:configure-flags
+ #~(list "--enable-all"
+ ;; Don't install unused /etc/sysconfig/rasdaemon environment file.
+ "--with-sysconfdefdir=."
+ "--localstatedir=/var")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'munge-autotools
+ (lambda _
+ ;; For some reason upstream forces sysconfdir=/etc. This results
+ ;; in EPERM during the install phase. Removing the offending
+ ;; line lets sysconfdir correctly pick up DESTDIR.
+ (substitute* "configure.ac"
+ (("^test .* sysconfdir=/etc\n$") ""))
+ ;; Upstream tries to create /var/lib/rasdaemon at install time.
+ ;; This results in EPERM on guix. Instead, the service should
+ ;; create this at activation time.
+ (substitute* "Makefile.am"
+ (("^\\s*\\$\\(install_sh\\) -d .*@RASSTATEDIR@.*$") ""))))
+ (add-after 'install 'fix-dmidecode-and-modprobe
+ (lambda _
+ (substitute* (string-append #$output "/sbin/ras-mc-ctl")
+ (("find_prog \\(\"dmidecode\"\\).*$") (format #f "~s;~%" (string-append #$dmidecode "/sbin/dmidecode")))
+ (("find_prog \\(\"modprobe\"\\).*$") (format #f "~s;~%" (string-append #$kmod "/bin/modprobe"))))))
+ (add-after 'wrap 'wrap-rasdaemon
+ (lambda _
+ (wrap-program (string-append #$output "/sbin/ras-mc-ctl")
+ `("PERL5LIB" ":" prefix ,(string-split (getenv "PERL5LIB") #\:))))))))
(build-system gnu-build-system)
(home-page "https://github.com/mchehab/rasdaemon")
(synopsis "Platform Reliability, Availability, and Serviceability tools")

base-commit: b94724e8b2102be0fe9d19e9dfe44d6f7101bd4b
--
2.38.1
L
L
Ludovic Courtès wrote on 14 Dec 2022 12:43
(address . mirai@makinata.eu)(address . 59859-done@debbugs.gnu.org)
87k02urz11.fsf@gnu.org
mirai@makinata.eu skribis:

Toggle quote (4 lines)
> From: Bruno Victal <mirai@makinata.eu>
>
> * gnu/packages/linux.scm (rasdaemon)[arguments]: Rewrite using G-Expressions and add missing inputs.

I adjusted the commit log to mention all changes and committed. Thanks!
Closed
?