[PATCH] gnu: Add dislocker.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 2 Dec 2022 05:52
(name . Guix Patches)(address . guix-patches@gnu.org)
13dcrROCOAZUMAyeACm23prm8ws3D8N1muEl4H76Bm4ExuaDS7YUESqMssqd9JU60lUiIHGzftJ0ZMqR22SqkJs31EV3s-wuTbgX027L2Ac=@protonmail.com
Hi,

here's a tool that allows you to access Bitlocker using Fuse.

----
Petr
Attachment: file
From d237aca245c0868df016ffa9ac49b7b3f1af11cc Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 13 Jan 2022 13:24:23 +0100
Subject: [PATCH] gnu: Add dislocker.

* gnu/packages/linux.scm (dislocker): New variable.

Toggle diff (31 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c417fb600..c398881b44 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2167,6 +2167,26 @@ (define-public ddate
by Robert Shea and Robert Anton Wilson.")
(license license:public-domain)))
+(define-public dislocker
+ (package
+ (name "dislocker")
+ (version "0.7.3")
+ (source (origin
+ (method url-fetch)
+ (uri
+ "https://github.com/Aorimn/dislocker/archive/refs/tags/v0.7.3.tar.gz")
+ (sha256
+ (base32 "1rn1nvcavpiqpl0g1vfbm5b0w757f4cxcpg0ys3vvwj4gibpalld"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f))
+ (inputs (list fuse mbedtls-apache))
+ (home-page "https://github.com/Aorimn/dislocker")
+ (synopsis "FUSE driver to read/write Windows BitLocker drives")
+ (description
+ "This package provides means to to read BitLocker encrypted
+ partitions. Write functionality is also provided but check the README.")
+ (license license:gpl2+)))
+
(define-public fbset
(package
(name "fbset")
L
L
Ludovic Courtès wrote on 8 Jan 2023 12:10
(name . phodina)(address . phodina@protonmail.com)(address . 59758@debbugs.gnu.org)
87o7r9wach.fsf@gnu.org
Hi,

phodina <phodina@protonmail.com> skribis:

Toggle quote (12 lines)
> From d237aca245c0868df016ffa9ac49b7b3f1af11cc Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Thu, 13 Jan 2022 13:24:23 +0100
> Subject: [PATCH] gnu: Add dislocker.
>
> * gnu/packages/linux.scm (dislocker): New variable.
> + (version "0.7.3")
> + (source (origin
> + (method url-fetch)
> + (uri
> + "https://github.com/Aorimn/dislocker/archive/refs/tags/v0.7.3.tar.gz")

This auto-generated tarball changes over time, as reported by ‘guix
lint’. Could you use ‘git-fetch’ instead?

Toggle quote (3 lines)
> + (build-system cmake-build-system)
> + (arguments '(#:tests? #f))

Please avoid disabling tests. If you really have to, add a short
comment explaining why it has to be disabled.

Toggle quote (5 lines)
> + (synopsis "FUSE driver to read/write Windows BitLocker drives")
> + (description
> + "This package provides means to to read BitLocker encrypted
> + partitions. Write functionality is also provided but check the README.")

Indentation is off. :-)

Could you send an updated patch?

Thanks,
Ludo’.
P
P
phodina wrote on 9 Jan 2023 00:57
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 59758@debbugs.gnu.org)
ilDQJCuPC3cdyBUT-WMogR5aH52-vj_Sam4ijFgBE45TFvsy2251LjUmB8P4OVfg8Tvwvt755nbFXOMSmhjRnC4Lr5vP8TWLbwyDavB5_yU=@protonmail.com
Hi Ludo’,

again thanks for the review and check the updated patch.


----
Petr
From bb4003c238067fed71dd7946b8108680654c5d31 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 13 Jan 2022 13:24:23 +0100
Subject: [PATCH v2] gnu: Add dislocker.

* gnu/packages/linux.scm (dislocker): New variable.

Toggle diff (33 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 568c2b6b92..9366c1c664 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2198,6 +2198,26 @@ (define-public ddate
by Robert Shea and Robert Anton Wilson.")
(license license:public-domain)))
+(define-public dislocker
+ (package
+ (name "dislocker")
+ (version "0.7.3")
+ (source (origin
+ (method url-fetch)
+ (uri
+ "https://github.com/Aorimn/dislocker/archive/refs/tags/v0.7.3.tar.gz")
+ (sha256
+ (base32 "1rn1nvcavpiqpl0g1vfbm5b0w757f4cxcpg0ys3vvwj4gibpalld"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f))
+ (inputs (list fuse mbedtls-apache))
+ (home-page "https://github.com/Aorimn/dislocker")
+ (synopsis "FUSE driver to read/write Windows BitLocker drives")
+ (description
+ "This package provides means to to read BitLocker encrypted
+ partitions. Write functionality is also provided but check the README.")
+ (license license:gpl2+)))
+
(define-public fbset
(package
(name "fbset")
--
2.38.1
P
P
phodina wrote on 9 Jan 2023 01:00
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 59758@debbugs.gnu.org)
-dgc-ZSkmwoxz2WyLij_sxULMJmgSHEdxm7zz640jRGvbi_JGjeHhQcWYr2Ys6OI7YT4NSbzwd_11Ed4DBKHDiVAihrE13ruSqFsvwN1uvs=@protonmail.com
Sorry,

my mistake. That one was generated before I did git `commit --amend`.

Here's the correct one.

----
Petr
From 0c4e34470490f4e4e1c3ee9f7239d0ce09fea81a Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 13 Jan 2022 13:24:23 +0100
Subject: [PATCH v2] gnu: Add dislocker.

* gnu/packages/linux.scm (dislocker): New variable.

Toggle diff (37 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 568c2b6b92..072d145c23 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2198,6 +2198,30 @@ (define-public ddate
by Robert Shea and Robert Anton Wilson.")
(license license:public-domain)))
+(define-public dislocker
+ (package
+ (name "dislocker")
+ (version "0.7.3")
+ (home-page "https://github.com/Aorimn/dislocker")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ak68s1v5dwh8y2dy5zjybmrh0pnqralmyqzis67y21m87g47h2k"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ;no test suite
+ (inputs (list fuse mbedtls-apache))
+ (synopsis "FUSE driver to read/write Windows BitLocker drives")
+ (description
+ "This package provides means to to read BitLocker encrypted
+partitions. Write functionality is also provided but check the README.")
+ (license license:gpl2+)))
+
(define-public fbset
(package
(name "fbset")
--
2.38.1
L
L
Ludovic Courtès wrote on 12 Jan 2023 23:33
(name . phodina)(address . phodina@protonmail.com)(address . 59758-done@debbugs.gnu.org)
87fscffknt.fsf@gnu.org
phodina <phodina@protonmail.com> skribis:

Toggle quote (7 lines)
> From 0c4e34470490f4e4e1c3ee9f7239d0ce09fea81a Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Thu, 13 Jan 2022 13:24:23 +0100
> Subject: [PATCH v2] gnu: Add dislocker.
>
> * gnu/packages/linux.scm (dislocker): New variable.

Applied, thanks!
Closed
?