[PATCH] gnu: minetest: Add minetest-oneblock.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vivien Kraus
Owner
unassigned
Submitted by
Vivien Kraus
Severity
normal
V
V
Vivien Kraus wrote on 1 Dec 2022 21:11
(address . guix-patches@gnu.org)
6fbc1b962b6bd38bb09f073e9541c0ccce8a28ce.camel@planete-kraus.eu
* gnu/packages/minetest.scm (minetest-oneblock): New variable.
---
gnu/packages/minetest.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index f5671241a7..2c26ab08a8 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -746,3 +746,25 @@ (define-public minetest-basic-trains
advtrains up to version 2.2.1.")
(license (list license:cc-by-sa3.0 license:agpl3+))
(properties `((upstream-name . "orwell/basic_trains")))))
+
+(define-public minetest-oneblock
+ (package
+ (name "minetest-oneblock")
+ (version "2022-09-01")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NO411/oneblock")
+ (commit "3582c825137e61b3d2ae3d60b8b9746acd6dfe3d")))
+ (sha256
+ (base32
+ "1pkdrj99qqwmz7c86w2mh081ynyxhiwv2rl01xjm1wfpazx5zhdg"))
+ (file-name (git-file-name name version))))
+ (build-system minetest-mod-build-system)
+ (home-page "https://github.com/NO411/oneblock")
+ (synopsis "Build your island in the sky with random items!")
+ (description
+ "Build your island in the sky. Every 30 seconds you will receive a random
+block or item from the oneblock to expand the island!")
+ (license license:gpl3)
+ (properties `((upstream-name . "NO11/oneblock")))))

base-commit: c7793b82efd3383a9f7adf0dfa82d71ee032e41b
--
2.38.1
V
V
Vivien Kraus wrote on 1 Dec 2022 22:00
Please add minetest-oneblock
(address . 59749@debbugs.gnu.org)
6911bcdeb8e1c960391cee0431351c7aa187b147.camel@planete-kraus.eu
Dear guix,

oneblock is a Minetest mod where you sit on top of an indestructible
block that generates random objects of the game every 30 seconds. It is
very fun to play, especially when you have many many mods. It’s slow to
start, because getting wood is rare enough that making a chest takes
time. Other than that, it is pretty fun!

Best regards,

Vivien
L
L
Ludovic Courtès wrote on 8 Dec 2022 13:02
Re: bug#59749: [PATCH] gnu: minetest: Add minetest-oneblock.
(name . Vivien Kraus)(address . vivien@planete-kraus.eu)(address . 59749-done@debbugs.gnu.org)
87r0xadrx7.fsf@gnu.org
Hi,

Applied with the changes below, thanks!

Ludo’.
Toggle diff (15 lines)
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 2c26ab08a8..74c8475240 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -764,7 +764,8 @@ (define-public minetest-oneblock
(home-page "https://github.com/NO411/oneblock")
(synopsis "Build your island in the sky with random items!")
(description
- "Build your island in the sky. Every 30 seconds you will receive a random
+ "This package provides an extension of the Minetest game that lets you
+build your island in the sky. Every 30 seconds you will receive a random
block or item from the oneblock to expand the island!")
- (license license:gpl3)
+ (license license:gpl3+)
(properties `((upstream-name . "NO11/oneblock")))))
Closed
?