[PATCH] gnu: Add tmux-plugin-resurrect

  • Done
  • quality assurance status badge
Details
2 participants
  • EuAndreh
  • Christopher Baines
Owner
unassigned
Submitted by
EuAndreh
Severity
normal
E
E
EuAndreh wrote on 30 Nov 2022 01:29
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221130002900.28278-1-eu@euandre.org
* gnu/packages/tmux.scm (tmux-plugin-resurrect): New variable.
---
gnu/packages/tmux.scm | 48 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 10b78cccf7..30082d22d6 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -267,3 +267,51 @@ (define-public tmux-xpanes
@item Generate command lines from standard input (Pipe mode).
@end itemize")
(license license:expat)))
+
+(define-public tmux-plugin-resurrect
+ (package
+ (name "tmux-plugin-resurrect")
+ (version "a2ddfb96b94bb64a7a2e3f5fa2a7c57dce8ad579")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tmux-plugins/tmux-resurrect/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gc8z99na1d4scn2kq4alwyn43h3r7ykz9bkhcypjh8iri6dsl0c"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils))
+ (let ((out (string-append %output
+ "/share/tmux-plugins/resurrect/")))
+ (mkdir-p out)
+ (copy-recursively (assoc-ref %build-inputs "source") out)))))
+ (synopsis "Restore tmux environment after system restart")
+ (description
+ "This plugin goes to great lengths to save and restore all the details
+from your tmux environment. Here's what's been taken care of:
+
+@itemize
+@item all sessions, windows, panes and their order
+@item current working directory for each pane
+@item exact pane layouts within windows (even when zoomed)
+@item active and alternative session
+@item active and alternative window for each session
+@item windows with focus
+@item active pane for each window
+@item \"grouped sessions\" (useful feature when using tmux with multiple monitors)
+@item programs running within a pane! More details in the restoring programs doc.
+@end itemize
+
+Optional:
+
+@itemize
+@item restoring vim and neovim sessions
+@item restoring pane contents
+@end itemize")
+ (home-page "https://github.com/tmux-plugins/tmux-resurrect/")
+ (license license:expat)))
--
2.38.1
C
C
Christopher Baines wrote on 13 Dec 2022 14:49
(name . EuAndreh)(address . eu@euandre.org)
87y1rbo1ja.fsf@cbaines.net
EuAndreh via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/tmux.scm (tmux-plugin-resurrect): New variable.
> ---
> gnu/packages/tmux.scm | 48 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 48 insertions(+)

Hey,

I've made a tweak to the version (as using the full commit is too long)
and pushed this to master as 866eb7fffbb4a011808d8231243c39c4d5e0f004.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmOYgzlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcEeQ/6A/Eaf4cxk1b/7xXQjEey3fElDvermFN/
xiUgZ8SA+rTjCFcj7WZpZIMUuXqFMshUA9XJ3ZR3axn5kDOmvqmkq1qS+5zO0URI
Zvs2bDcOmUeFSn0LwelggCtTsBYHL7YN81KoVQ3XZ/OGkJyTMAr1YRaQlEP/JcZz
ylloRklYh+5YuDL7O3yG++UeXdIRU6BrZdgvnOP0HpTbBIGEwQekbTi8ZfNuec1Z
N7kJvYvZGPfnzO2OInntfVxepUsF/NxtKLlbq2oDFD4m9oJX2e9+2kMlbHAPDubh
Hx3uxfdvf12+wlG9j3EuW0PNaMCFHuXzBaa+0AFHeYArYBio1NsMCoSPam9+1eJM
NrjMWFoX5kKkbjLBLJUbf2eTJq8bS9yCHRXR9zDO3jTtOAiIy7VoQmmKLHt/fQF7
+hEOX/2Oc1MO++Bxn1pvP04M+J05hCaVZ7BvOfbytuGubRc77bZGiMJ7oJYRAWjj
/0Hx8aadZ1awwuLx5RVkiJ2S9x6m4oC+5f1aPZNXa/IceUpo67kWVX9ujR0d4q9t
fETLmrH3KoNb/yNj1E4g0Crh47FWz35uj9JTNdmYsozlkJ8C43RVQDOmhTALGyDl
6JWmJngPN+FB5JpLCx8J1vEPGEWn0JwDgdiiue99Tbebm31mDi9lgLDuj0EXYfif
Fn1i+LLGulc=
=GSCH
-----END PGP SIGNATURE-----

?