[PATCH 1/1] services: wireguard: Use the parameterized wireguard package.

  • Done
  • quality assurance status badge
Details
2 participants
  • EuAndreh
  • 宋文武
Owner
unassigned
Submitted by
EuAndreh
Severity
normal
E
E
EuAndreh wrote on 30 Nov 2022 00:39
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221129233929.28696-1-eu@euandre.org
* gnu/services/vpn.scm (wireguard-activation): Use the "wg" binary from
the package given to <wireguard-configuration>.
---

Notes:
As of now, there is no other reference to the global "wireguard-tools"
package in the gnu/services/vpn.scm file.

gnu/services/vpn.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/services/vpn.scm b/gnu/services/vpn.scm
index def381987b..7b3bb8903c 100644
--- a/gnu/services/vpn.scm
+++ b/gnu/services/vpn.scm
@@ -833,7 +833,7 @@ (define (peer->config peer)
(define (wireguard-activation config)
(match-record config <wireguard-configuration>
- (private-key)
+ (private-key wireguard)
#~(begin
(use-modules (guix build utils)
(ice-9 popen)
@@ -842,7 +842,7 @@ (define (wireguard-activation config)
(unless (file-exists? #$private-key)
(let* ((pipe
(open-input-pipe (string-append
- #$(file-append wireguard-tools "/bin/wg")
+ #$(file-append wireguard "/bin/wg")
" genkey")))
(key (read-line pipe)))
(call-with-output-file #$private-key
--
2.38.1
宋文武 wrote on 9 Dec 2022 03:54
(name . EuAndreh)(address . eu@euandre.org)(address . 59704-done@debbugs.gnu.org)
87r0x9i8w9.fsf@envs.net
EuAndreh <eu@euandre.org> writes:

Toggle quote (8 lines)
> * gnu/services/vpn.scm (wireguard-activation): Use the "wg" binary from
> the package given to <wireguard-configuration>.
> ---
>
> Notes:
> As of now, there is no other reference to the global "wireguard-tools"
> package in the gnu/services/vpn.scm file.

Pushed, thank you!
Closed
?