[PATCH] gnu: Add guile-jtd.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Ludovic Courtès
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221129173410.25523-1-jgart@dismail.de
* gnu/packages/guile-xyz.scm (guile-jtd): New variable.
---
gnu/packages/guile-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b1620618eb..1a5fb4c319 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2022 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3546,6 +3547,29 @@ (define-public guile-jpeg
perform geometrical transforms on JPEG images.")
(license license:gpl3+))))
+(define-public guile-jtd
+ (package
+ (name "guile-jtd")
+ (version "220323")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mwette/guile-jtd")
+ (commit (string-append "v" version "a"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1l8fyqhvksarvpbr903i3ss3432jzvyvhgcqa15j922ngqh4ds6f"))))
+ (build-system guile-build-system)
+ (native-inputs
+ (list guile-3.0))
+ (home-page "https://github.com/mwette/guile-jtd")
+ (synopsis "Python's pdb.set_trace() but for Guile")
+ (description
+"The (jtd) module for Guile provides a procedure @code{jump-to-debugger}
+for escaping to the Guile REPL for the purpose of debugging code.")
+ (license license:lgpl2.1+)))
+
(define-public guile-png
(package
(name "guile-png")
--
2.38.1
L
L
Ludovic Courtès wrote on 8 Dec 2022 22:44
(name . jgart)(address . jgart@dismail.de)(address . 59685-done@debbugs.gnu.org)
87tu25bmei.fsf@gnu.org
Hi,

jgart <jgart@dismail.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/guile-xyz.scm (guile-jtd): New variable.

Applied with the changes below, thanks!

Ludo’.
Toggle diff (44 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9ce895e977..9fc6344491 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3569,24 +3569,24 @@ (define-public guile-jpeg
(define-public guile-jtd
(package
(name "guile-jtd")
- (version "220323")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mwette/guile-jtd")
- (commit (string-append "v" version "a"))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1l8fyqhvksarvpbr903i3ss3432jzvyvhgcqa15j922ngqh4ds6f"))))
+ (version "220323a")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mwette/guile-jtd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l8fyqhvksarvpbr903i3ss3432jzvyvhgcqa15j922ngqh4ds6f"))))
(build-system guile-build-system)
- (native-inputs
- (list guile-3.0))
+ (native-inputs (list guile-3.0))
(home-page "https://github.com/mwette/guile-jtd")
- (synopsis "Python's pdb.set_trace() but for Guile")
+ (synopsis "Python's @code{pdb.set_trace()} but for Guile")
(description
-"The (jtd) module for Guile provides a procedure @code{jump-to-debugger}
-for escaping to the Guile REPL for the purpose of debugging code.")
+ "The @code{(jtd)} module for Guile provides a procedure
+@code{jump-to-debugger} for escaping to the Guile REPL for the purpose of
+debugging code.")
(license license:lgpl2.1+)))
(define-public guile-png
Closed
?