[PATCH] gnu: Add buku-run.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Ludovic Courtès
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 25 Nov 2022 02:44
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
20221125014426.7275-1-hako@ultrarare.space
* gnu/packages/web.scm (buku-run): New variable.
---
gnu/packages/web.scm | 41 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d2c406915c..71241ef8d3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7701,6 +7701,47 @@ (define-public buku
@command{bukuserver}.")
(license license:gpl3+)))
+(define-public buku-run
+ (package
+ (name "buku-run")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/carnager/buku_run")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zyjjf3b8g3dnymcrg683rbnc6qrvx8ravfm833n7kjrqky3bczn"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags
+ #~(list (string-append "DESTDIR=" #$output)
+ "PREFIX=")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fixpath
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "buku_run"
+ ((" \\<(rofi)\\>" all cmd)
+ (string-append " " (search-input-file inputs "/bin/rofi")))
+ (("\\<(buku)\\> " all cmd)
+ (string-append (search-input-file inputs "/bin/buku") " "))
+ (("\\<(awk|gawk)\\>" cmd)
+ (search-input-file inputs "/bin/awk"))
+ (("/etc/buku_run.config" path)
+ (string-append #$output path))))))))
+ (inputs (list buku rofi))
+ (home-page "https://github.com/carnager/buku_run")
+ (synopsis "rofi frontend for buku bookmarks manager")
+ (description
+ "This package provides a @code{rofi} frontend for @code{buku} bookmark
+manager.")
+ (license license:gpl3)))
+
(define-public anonip
(package
(name "anonip")

base-commit: 5eb2995c006283fc0b649f10a6d002580ccac8d6
--
2.38.1
L
L
Ludovic Courtès wrote on 8 Dec 2022 22:39
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 59558-done@debbugs.gnu.org)
87y1rhbmo8.fsf@gnu.org
Hi,

Hilton Chain <hako@ultrarare.space> skribis:

Toggle quote (2 lines)
> * gnu/packages/web.scm (buku-run): New variable.

Applied with the changes below, thanks!

Ludo’.
Toggle diff (24 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e53e123e19..99b8a3698c 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -189,6 +189,7 @@ (define-module (gnu packages web)
#:use-module (gnu packages video)
#:use-module (gnu packages vim)
#:use-module (gnu packages wget)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module ((srfi srfi-1) #:select (delete-duplicates)))
@@ -7801,9 +7802,8 @@ (define-public buku-run
(home-page "https://github.com/carnager/buku_run")
(synopsis "rofi frontend for buku bookmarks manager")
(description
- "This package provides a @code{rofi} frontend for @code{buku} bookmark
-manager.")
- (license license:gpl3)))
+ "This package provides a rofi frontend for the buku bookmark manager.")
+ (license license:gpl3+)))
(define-public anonip
(package
Closed
?