[PATCH] gnu: Add cl-concurrent-hash-tables.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 25 Nov 2022 02:42
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20221125014244.136801-1-paul@apatience.com
* gnu/packages/lisp-xyz.scm (sbcl-concurrent-hash-tables,
cl-concurrent-hash-tables, ecl-concurrent-hash-tables): New variables.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 55cc90b08a..005364a5ac 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -14031,6 +14031,39 @@ (define-public cl-custom-hash-table
(define-public ecl-custom-hash-table
(sbcl-package->ecl-package sbcl-custom-hash-table))

+(define-public sbcl-concurrent-hash-tables
+ (let ((commit "1b9f0b5da54fece4f42296e1bdacfcec0c370a5a")
+ (revision "0"))
+ (package
+ (name "sbcl-concurrent-hash-tables")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/no-defun-allowed/concurrent-hash-tables")
+ (commit commit)))
+ (file-name (git-file-name "cl-concurrent-hash-tables" version))
+ (sha256
+ (base32 "03g24ycr1ngzg8bv10iwp1bmnldz5bxbfdqrzhfxhicpibh49r96"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-atomics sbcl-bordeaux-threads))
+ (home-page "https://github.com/no-defun-allowed/concurrent-hash-tables")
+ (synopsis "Portability library for concurrent hash tables in Common Lisp")
+ (description "@code{concurrent-hash-tables} is a Common Lisp portability
+library wrapping some implementations of concurrent hash tables which do not
+have to be entirely locked in their operation, including
+@code{42nd-at-threadmill}, @code{luckless}, and a fallback, segmented hash
+table.")
+ (license license:bsd-2))))
+
+(define-public cl-concurrent-hash-tables
+ (sbcl-package->cl-source-package sbcl-concurrent-hash-tables))
+
+(define-public ecl-concurrent-hash-tables
+ (sbcl-package->ecl-package sbcl-concurrent-hash-tables))
+
(define-public sbcl-collectors
(let ((commit "13acef25d8422d1d82e067b1861e513587c166ee"))
(package
--
2.38.0
G
G
Guillaume Le Vaillant wrote on 25 Nov 2022 10:32
(name . Paul A. Patience)(address . paul@apatience.com)(address . 59557-done@debbugs.gnu.org)
87ilj3gyzi.fsf@kitej
Patch pushed as 63374ef9b9c7ebd374bed6630783b020e45e576f.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCY4CL4Q8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9NDgEAibp82d+b5Na9tvQNI73oa6DPNXpqQnHr0FsG
+xD0FNgA/jSw7OasSxqR4OEgNf7cJVSzV74hPqbCVJ/23U9vXmaN
=arQb
-----END PGP SIGNATURE-----

Closed
?