[PATCH] gnu: Add emacs-org-rainbow-tags.

  • Done
  • quality assurance status badge
Details
2 participants
  • Hilton Chain
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Hilton Chain
Severity
normal
H
H
Hilton Chain wrote on 25 Nov 2022 02:20
(address . guix-patches@gnu.org)(name . Hilton Chain)(address . hako@ultrarare.space)
20221125012039.14081-1-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-org-rainbow-tags): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a6002efa51..d7bb3213a4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6105,6 +6105,31 @@ (define-public emacs-org-inline-pdf
inline PDF preview in Org buffers by using pdf2svg.")
(license license:gpl3+)))
+(define-public emacs-org-rainbow-tags
+ ;; Upstream didn't tag version.
+ (let ((commit "c6040d228c5e8c5c6d33c7f81fc09d935ad1bcbd"))
+ (package
+ (name "emacs-org-rainbow-tags")
+ (version "0.1-pre")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KaratasFurkan/org-rainbow-tags")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "006nx01sby8k0fc9lf63ldf0sl94ihldyrvqr9r18fb1gpzvivl6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/KaratasFurkan/org-rainbow-tags")
+ (synopsis
+ "Colorize org tags automatically to make them visually distinguishable")
+ (description
+ "This package adds random colors to your org tags. In order to make
+colors random but consistent between same tags, colors are generated from the
+hash of the tag names.")
+ (license license:gpl3))))
+
(define-public emacs-org-rich-yank
(package
(name "emacs-org-rich-yank")
--
2.38.1
N
N
Nicolas Goaziou wrote on 26 Nov 2022 11:42
(name . Hilton Chain via Guix-patches via)(address . guix-patches@gnu.org)
871qpqc7yn.fsf@nicolasgoaziou.fr
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-rainbow-tags): New variable.

Thank you.

Toggle quote (3 lines)
> + (synopsis
> + "Colorize org tags automatically to make them visually distinguishable")

I think "Colorize Org tags automatically" is enough as a synopsis.

Toggle quote (5 lines)
> + (description
> + "This package adds random colors to your org tags. In order to make
> +colors random but consistent between same tags, colors are generated from the
> +hash of the tag names.")

org -> Org

Also, you need to separate sentences with two spaces per Texinfo specifications.

Toggle quote (2 lines)
> + (license license:gpl3))))

License is actually gpl3+ because the main file mentions:

either version 3 of the License, or ;; (at your option) any later
version.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
H
H
Hilton Chain wrote on 26 Nov 2022 13:09
[PATCH v2] gnu: Add emacs-org-rainbow-tags.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 59555@debbugs.gnu.org)
y76wn7h7w97.wl-hako@ultrarare.space
* gnu/packages/emacs-xyz.scm (emacs-org-rainbow-tags): New variable.
---
Range-diff:
1: f0cbfb8ff1 ! 1: fc4fc395ed gnu: Add emacs-org-rainbow-tags.
@@ gnu/packages/emacs-xyz.scm: (define-public emacs-org-inline-pdf
+ "006nx01sby8k0fc9lf63ldf0sl94ihldyrvqr9r18fb1gpzvivl6"))))
+ (build-system emacs-build-system)
-+ (synopsis
-+ "Colorize org tags automatically to make them visually distinguishable")
++ (synopsis "Colorize Org tags automatically")
+ (description
-+ "This package adds random colors to your org tags. In order to make
++ "This package adds random colors to your Org tags. In order to make
+colors random but consistent between same tags, colors are generated from the
+hash of the tag names.")
-+ (license license:gpl3))))
++ (license license:gpl3+))))
+
(define-public emacs-org-rich-yank
(package

gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8eb4dab077..d2ced38a53 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6100,6 +6100,30 @@ (define-public emacs-org-inline-pdf
inline PDF preview in Org buffers by using pdf2svg.")
(license license:gpl3+)))
+(define-public emacs-org-rainbow-tags
+ ;; Upstream didn't tag version.
+ (let ((commit "c6040d228c5e8c5c6d33c7f81fc09d935ad1bcbd"))
+ (package
+ (name "emacs-org-rainbow-tags")
+ (version "0.1-pre")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KaratasFurkan/org-rainbow-tags")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "006nx01sby8k0fc9lf63ldf0sl94ihldyrvqr9r18fb1gpzvivl6"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/KaratasFurkan/org-rainbow-tags")
+ (synopsis "Colorize Org tags automatically")
+ (description
+ "This package adds random colors to your Org tags. In order to make
+colors random but consistent between same tags, colors are generated from the
+hash of the tag names.")
+ (license license:gpl3+))))
+
(define-public emacs-org-rich-yank
(package
(name "emacs-org-rich-yank")

base-commit: adf3eecedade19ce88d3df4325acef4559d05e8f
--
2.38.1
N
N
Nicolas Goaziou wrote on 27 Nov 2022 00:21
(name . Hilton Chain)(address . hako@ultrarare.space)(address . 59555-done@debbugs.gnu.org)
87v8n1mhd6.fsf@nicolasgoaziou.fr
Hello,

Hilton Chain <hako@ultrarare.space> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-rainbow-tags): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?