[PATCH v2] gnu: Add portfolio

  • Done
  • quality assurance status badge
Details
2 participants
  • conses
  • Christopher Baines
Owner
unassigned
Submitted by
conses
Severity
normal
C
C
conses wrote on 23 Nov 2022 22:58
(address . guix-patches@gnu.org)
86v8n59vu9.fsf@conses.eu
* gnu/packages/gnome-xyz.scm (portfolio): New variable.
---
gnu/packages/gnome-xyz.scm | 55 ++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b7e10100fb..5a5c5b1700 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -55,6 +55,7 @@ (define-module (gnu packages gnome-xyz)
#:use-module (gnu packages bash)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -224,6 +225,60 @@ (define-public papirus-icon-theme
and a few extra features.")
(license license:gpl3)))
+(define-public portfolio
+ (package
+ (name "portfolio")
+ (version "0.9.14")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchx84/Portfolio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ (arguments
+ (list
+ #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'rename-executable
+ (lambda _
+ (with-directory-excursion (string-append #$output "/bin")
+ (rename-file "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/portfolio")
+ `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+ ,(python:site-packages inputs outputs)))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ (build-system meson-build-system)
+ (inputs
+ (list
+ bash-minimal
+ python-pygobject
+ gtk+
+ libhandy))
+ (native-inputs
+ (list
+ (list glib "bin")
+ desktop-file-utils
+ gettext-minimal
+ python
+ (list gtk+ "bin")))
+ (home-page "https://github.com/tchx84/Portfolio")
+ (synopsis "A minimalist file manager for those who want to use Linux mobile devices.")
+ (description "Portfolio is a minimalist file manager for those who want to use Linux
+mobile devices. Tap to activate and long press to select, to browse, open, copy, move,
+delete, or edit your files.")
+ (license license:gpl3)))
+
(define-public gnome-plots
(package
(name "gnome-plots")
--
2.38.1



--
Best regards,
conses
C
C
conses wrote on 23 Nov 2022 23:30
[PATCH v3] gnu: Add portfolio.
(address . 59525@debbugs.gnu.org)
86r0xt9udb.fsf@conses.eu
* gnu/packages/gnome-xyz.scm (portfolio): New variable.
---
gnu/packages/gnome-xyz.scm | 54 ++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b7e10100fb..6f499e567e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -55,6 +55,7 @@ (define-module (gnu packages gnome-xyz)
#:use-module (gnu packages bash)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -224,6 +225,59 @@ (define-public papirus-icon-theme
and a few extra features.")
(license license:gpl3)))
+(define-public portfolio
+ (package
+ (name "portfolio")
+ (version "0.9.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchx84/Portfolio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system)
+ #:prefix python:)
+ (guix build utils))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'rename-executable
+ (lambda _
+ (with-directory-excursion (string-append #$output
+ "/bin")
+ (rename-file "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs
+ "bin/portfolio")
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH") ,(python:site-packages
+ inputs
+ outputs)))
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))))))))
+ (build-system meson-build-system)
+ (inputs (list bash-minimal python-pygobject gtk+ libhandy))
+ (native-inputs
+ (list `(,glib "bin")
+ desktop-file-utils
+ gettext-minimal
+ python
+ `(,gtk+ "bin")))
+ (home-page "https://github.com/tchx84/Portfolio")
+ (synopsis "Minimalist file manager for Linux mobile devices")
+ (description
+ "Portfolio is a minimalist file manager for those who want to use Linux
+mobile devices. Tap to activate and long press to select, to browse, open, copy, move,
+delete, or edit your files.")
+ (license license:gpl3)))
+
(define-public gnome-plots
(package
(name "gnome-plots")
--
2.38.1



--
Best regards,
conses
C
C
conses wrote on 23 Nov 2022 23:53
[PATCH v4] gnu: Add portfolio.
(address . 59525@debbugs.gnu.org)
86mt8h9tbj.fsf@conses.eu
* gnu/packages/gnome-xyz.scm (portfolio): New variable.
---
This amends native-inputs package order.
gnu/packages/gnome-xyz.scm | 54 ++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b7e10100fb..9ae48b78ae 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -55,6 +55,7 @@ (define-module (gnu packages gnome-xyz)
#:use-module (gnu packages bash)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -224,6 +225,59 @@ (define-public papirus-icon-theme
and a few extra features.")
(license license:gpl3)))
+(define-public portfolio
+ (package
+ (name "portfolio")
+ (version "0.9.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchx84/Portfolio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system)
+ #:prefix python:)
+ (guix build utils))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'rename-executable
+ (lambda _
+ (with-directory-excursion (string-append #$output
+ "/bin")
+ (rename-file "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs
+ "bin/portfolio")
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH") ,(python:site-packages
+ inputs
+ outputs)))
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))))))))
+ (build-system meson-build-system)
+ (inputs (list bash-minimal python-pygobject gtk+ libhandy))
+ (native-inputs
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
+ `(,gtk+ "bin")
+ python))
+ (home-page "https://github.com/tchx84/Portfolio")
+ (synopsis "Minimalist file manager for Linux mobile devices")
+ (description
+ "Portfolio is a minimalist file manager for those who want to use Linux
+mobile devices. Tap to activate and long press to select, to browse, open, copy, move,
+delete, or edit your files.")
+ (license license:gpl3)))
+
(define-public gnome-plots
(package
(name "gnome-plots")
--
2.38.1



--
Best regards,
conses
C
C
conses wrote on 24 Nov 2022 17:21
[PATCH v5] gnu: Add portfolio.
(address . 59525@debbugs.gnu.org)(address . contact@conses.eu)
865yf4wcft.fsf@conses.eu
* gnu/packages/gnome-xyz.scm (portfolio): New variable.
---
Symlinks executable instead of renaming it.
gnu/packages/gnome-xyz.scm | 54 ++++++++++++++++++++++++++++++++++++++
1 file changed, 54 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index b7e10100fb..9f5843b1a6 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -55,6 +55,7 @@ (define-module (gnu packages gnome-xyz)
#:use-module (gnu packages bash)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages check)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -304,6 +305,59 @@ (define-public gnome-plots
takes advantage of modern hardware using OpenGL.")
(license license:gpl3+)))
+(define-public portfolio
+ (package
+ (name "portfolio")
+ (version "0.9.14")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tchx84/Portfolio")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h09v8lhz3kv6qmwjhx3gr7rp6ccfhrzm54gjnaixl4dcg9zddls"))))
+ (arguments
+ (list #:glib-or-gtk? #t
+ #:imported-modules `(,@%meson-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build meson-build-system)
+ ((guix build python-build-system)
+ #:prefix python:)
+ (guix build utils))
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'rename-executable
+ (lambda _
+ (with-directory-excursion (string-append #$output
+ "/bin")
+ (symlink "dev.tchx84.Portfolio" "portfolio"))))
+ (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs
+ "bin/dev.tchx84.Portfolio")
+ `("GUIX_PYTHONPATH" =
+ (,(getenv "GUIX_PYTHONPATH") ,(python:site-packages
+ inputs
+ outputs)))
+ `("GI_TYPELIB_PATH" =
+ (,(getenv "GI_TYPELIB_PATH")))))))))
+ (build-system meson-build-system)
+ (inputs (list bash-minimal python-pygobject gtk+ libhandy))
+ (native-inputs
+ (list desktop-file-utils
+ gettext-minimal
+ `(,glib "bin")
+ `(,gtk+ "bin")
+ python))
+ (home-page "https://github.com/tchx84/Portfolio")
+ (synopsis "Minimalist file manager for Linux mobile devices")
+ (description
+ "Portfolio is a minimalist file manager for those who want to use Linux
+mobile devices. Tap to activate and long press to select, to browse, open, copy, move,
+delete, or edit your files.")
+ (license license:gpl3)))
+
(define-public gnome-shell-extension-unite-shell
(package
(name "gnome-shell-extension-unite-shell")
--
2.38.1



--
Best regards,
conses
C
C
Christopher Baines wrote on 25 Nov 2022 11:54
(name . conses)(address . contact@conses.eu)
87bkovz4ix.fsf@cbaines.net
conses <contact@conses.eu> writes:

Toggle quote (6 lines)
> * gnu/packages/gnome-xyz.scm (portfolio): New variable.
> ---
> Symlinks executable instead of renaming it.
> gnu/packages/gnome-xyz.scm | 54 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 54 insertions(+)

Thanks! I tweaked the license, as it looks to be gpl3+ (gpl3 or later)
rather than gpl3, and pushed to master as
6827d76d383be2a0ef655767fb1420cf641f9790.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmOAn1ZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XePHRAAoBnDOJy1lhChyGGzMAwmP2G46G7GDotx
EGquaprimUEsZDkcWj1wiKsWiCGwUK1GkyKVXHcuP0u6N5wrl9crMMHdGGmQxgCM
VO1YZnS7wd+jzD/41HomdkxyXvmG+Lfw3Pw1TmHz60QJtZb3hjGVDa53mwUVe3aR
NgTio4vcnTUXBflXZ/arJFYvMUGoKeBd+wOnEygm54Nqq8hqjuimjElBz3RxYSNC
YG26v9IBPmxE+z3z4tKnmAYK2tcIbs/Vl7TCF7z2Vq9t+mJO3jfhvQgJh2F9OV+b
09q256iJTRNBzcLiEzpZCf8guK3asej5qpcOcqG61OiteKBdYZMO1jUzu7vuCcJZ
x+A+elvNUFwcTemzXKVtPL78vhk7Z6tjCjKxKgdRJIN0mQ1cpF/+at7zO7LcuKaS
yBTEwSrBIuwnKqCV4R2uNwtzL9CNtvbPRqqbspwhwXB3ouzXgMKA6Qfi5F6QYMG9
G3jIItO2Z2EmMFItY8ecNHYLn8K8s8Xl5spAWOFQ7kqlsy5pic1UQ/k39CejmT/t
Nr1cHRANQKZ5R8YwB5Dg2Z0iYITG0jOEvNabgdVu6Md/xgPjK93OQgYkVdkzhJZZ
VdOYQuoi1gnfUrmLxA2M+YKeFOwcWgF8ERn6fSimb/pZbsGxx3r0JRZ28MLxL57N
QsL88Q/IXOQ=
=yAPs
-----END PGP SIGNATURE-----

?