Network Support for pine64 base image

  • Done
  • quality assurance status badge
Details
2 participants
  • Gabriel Wicki
  • ???
Owner
unassigned
Submitted by
Gabriel Wicki
Severity
normal
G
G
Gabriel Wicki wrote on 23 Nov 2022 10:41
(address . guix-patches@gnu.org)
87o7syknx7.fsf@erlikon.ch
Hi

Overcoming some relatively basic barriers putting my Pine64 LTS board in
operation I figured a small patch to the base-image in the Guix repo
might be a gain for all. So here is my patch go give the Pine64 DHCP,
NTP and Certificates so that a `guix pull` and potential reconfigure can
take place without great hassle.

With nothing but the best wishes

Gabriel



From 70a0f09a1ba1bdc916cebaa3f247b66a6ad0d669 Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Wed, 16 Nov 2022 20:32:10 +0100
Subject: [PATCH] system: Add networking support to pine64 image

* gnu/system/images/pine64.scm (pine64-barebones-os) [services]: Add
dhcp-client-service-type and ntp-service-type to the list of services.
[packages]: Add nss-certs to the list of packages.
---
gnu/system/images/pine64.scm | 21 ++++++++++++++-------
1 file changed, 14 insertions(+), 7 deletions(-)

Toggle diff (50 lines)
diff --git a/gnu/system/images/pine64.scm b/gnu/system/images/pine64.scm
index a2d471b802..3feb69764d 100644
--- a/gnu/system/images/pine64.scm
+++ b/gnu/system/images/pine64.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,9 +22,11 @@ (define-module (gnu system images pine64)
#:use-module (gnu bootloader u-boot)
#:use-module (gnu image)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages certs)
#:use-module (guix platforms arm)
#:use-module (gnu services)
#:use-module (gnu services base)
+ #:use-module (gnu services networking)
#:use-module (gnu system)
#:use-module (gnu system file-systems)
#:use-module (gnu system image)
@@ -47,13 +50,17 @@ (define pine64-barebones-os
(mount-point "/")
(type "ext4"))
%base-file-systems))
- (services (cons (service agetty-service-type
- (agetty-configuration
- (extra-options '("-L")) ; no carrier detect
- (baud-rate "115200")
- (term "vt100")
- (tty "ttyS0")))
- %base-services))))
+ (services (cons*
+ (service agetty-service-type
+ (agetty-configuration
+ (extra-options '("-L")) ; no carrier detect
+ (baud-rate "115200")
+ (term "vt100")
+ (tty "ttyS0")))
+ (service dhcp-client-service-type)
+ (service ntp-service-type)
+ %base-services))
+ (packages (cons nss-certs %base-packages))))
(define pine64-image-type
(image-type
--
2.38.0
?
(name . Gabriel Wicki)(address . gabriel@erlikon.ch)(address . 59511-done@debbugs.gnu.org)
87o7sdi8gp.fsf@envs.net
Gabriel Wicki <gabriel@erlikon.ch> writes:

Toggle quote (19 lines)
> Hi
>
> Overcoming some relatively basic barriers putting my Pine64 LTS board in
> operation I figured a small patch to the base-image in the Guix repo
> might be a gain for all. So here is my patch go give the Pine64 DHCP,
> NTP and Certificates so that a `guix pull` and potential reconfigure can
> take place without great hassle.
>
> With nothing but the best wishes
>
> Gabriel
>
>
>
>>From 70a0f09a1ba1bdc916cebaa3f247b66a6ad0d669 Mon Sep 17 00:00:00 2001
> From: Gabriel Wicki <gabriel@erlikon.ch>
> Date: Wed, 16 Nov 2022 20:32:10 +0100
> Subject: [PATCH] system: Add networking support to pine64 image

Applied, thank you!
Closed
?