[PATCH] gnu: Add emacs-on.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Christopher Baines
  • (
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20221120183931.14423-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-on): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5c1138e954..232a547fb0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33845,6 +33845,28 @@ (define-public emacs-mpv
process via its IPC interface.")
(license license:gpl3+))))
+(define-public emacs-on
+ (let ((commit "83baed07a105c135190d49d7ec77f95e8f38fa54")
+ (revision "0"))
+ (package
+ (name "emacs-on")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ajgrf/on.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14ly3w89hf4jgd8wacirxgd8vrgj7vc0hpfn911w5wa4k2a6nzpp"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ajgrf/on.el")
+ (synopsis "Hooks for faster Emacs startup")
+ (description
+"This package exposes a number of utility hooks and functions ported from Doom Emacs.")
+ (license license:expat))))
+
(define-public emacs-waveform
;; XXX: Upstream provides no Version keyword. Using 0 as base version.
(let ((commit "ee52c6a72b3e9890743e3a6e2fc1f3195f5687b2")
--
2.38.1
C
C
Christopher Baines wrote on 21 Nov 2022 15:40
(name . jgart)(address . jgart@dismail.de)
87o7t0tlh0.fsf@cbaines.net
jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (5 lines)
> * gnu/packages/emacs-xyz.scm (emacs-on): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
> 1 file changed, 22 insertions(+)

Thanks, I've pushed this to master as
f0cc7542f535cd0ccb75352cabc465a8dc1b1551.

Note that I did move the package definition to not be so close to the
bottom of the module. Thanks for following the comment and not putting
it right at the bottom, but the other important bit is "place them above
by existing packages with similar functionality or similar names".

The intent with that is to avoid Git conflicts when several packages are
added in the same place. For example, you also sent this patch
https://issues.guix.gnu.org/59429that adds emacs-ukrainian-holidays in
the same place. That's just asking for Git trouble!

I normally just search for the start of the package name, e.g. emacs-o
and then find a similarly named package to place the new one by,
e.g. emacs-on-screen in this case.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN7jwtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfmgQ/+P44sRA2i8x40IW406w3MfaHKQyHVba15
rVQaSzNIy0N5GiarAdNmOvpAdVMmrWLmCgJ6KRgDNJx4J6IijmddXf8UPM9oKaY4
HC6SGqbSVsrBsuX6Ch27My6j1eXw75ee11cXX/PGrxotZdI+eg3JE2M0Ft7m0OvC
WT8EgfQKN43IM3hw0qslB6llV/7vbJuqLTVZCLozjb0/qA2ld8o2VR16OoCsRiPE
p3QFbmqbp0ocDi8dydt95yY1n8hY6QPSMoBTZu8Pxgod/FfXmtlibZkQauTt2cvn
aRdFNG6eD2AmA7WciJnAzNp48Eg0/TWT39SpW4hmWCBhmBZZ/d5DJZaFkyadNgLV
ivntsXg7hmuHrxfzexGBJ7Ozs4tSSAMpIcKp5YgWDru9mM8M8DDiI9d3WrJUPCUc
VMgG/v/4Q9V4fifnnhRq8vyBdUa0/2qGOAP4F7DUeTrfpq97K+NPZ1dEzhEtnKVp
G+iy8+IBlC/NYUPWCjmDDoJsPpkGD329HiCQFdYyigJZt0qXpdhem6HmyxXUmH4F
ZeOzQAqXG9r6xRdKO/uTBFBhC1Uz8VPLl2c72Gd0Ld7JYIfgCP/rxr9llA7+ku6b
RllA7iDmWuMUueB+1Qg3JpzrDGu3HdSTL8g564f1uoesQ7TYx3q6K4DoNq+xQOnP
2SJlimyVyKw=
=WBjy
-----END PGP SIGNATURE-----

J
(name . Christopher Baines)(address . mail@cbaines.net)
20221127122316.GB8668@dismail.de
On Mon, 21 Nov 2022 14:40:58 +0000 Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (3 lines)
> Thanks, I've pushed this to master as
> f0cc7542f535cd0ccb75352cabc465a8dc1b1551.

Thanks!

Toggle quote (10 lines)
> Note that I did move the package definition to not be so close to the
> bottom of the module. Thanks for following the comment and not putting
> it right at the bottom, but the other important bit is "place them above
> by existing packages with similar functionality or similar names".
>
> The intent with that is to avoid Git conflicts when several packages are
> added in the same place. For example, you also sent this patch
> https://issues.guix.gnu.org/59429 that adds emacs-ukrainian-holidays in
> the same place. That's just asking for Git trouble!

Sorry about that! I'll keep it in mind for future patch sets. I think I'll
just start putting stuff in alphabetical order to avoid this altogether.

all best,

jgart
(
CONAFPMTTBOD.13X9GIDHUBV46@guix-framework
On Sun Nov 27, 2022 at 6:23 PM GMT, jgart via Guix-patches via wrote:
Toggle quote (3 lines)
> Sorry about that! I'll keep it in mind for future patch sets. I think I'll
> just start putting stuff in alphabetical order to avoid this altogether.

It doesn't mean alphabetical order by "similar names", so I'm pretty sure that
would still be an incorrect ordering.

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmODq8IACgkQ7ImHg/nq
I23OYgwArTBwD61JLQZ4O0FTzZ5D5zOCFnFqkl0tdox7gs/kf3kfcH1g0edSwokz
rMKGiSWvFC7UZ8jSMNi+jx7ndhjT/RUs2egxa2egtjJDoWObP65V06fYZy2CcBh2
oF4VGE3lN+BZl+WixmgfHZ5TOgn8mNMhXk64yAmEuLJZUpObbKlOTPjsaZDh3sxT
3qCOGsMoOcYhoU6Rb+LOqGbazE/r7iEjUx68fQLKuAS/0fpn6+dNzXPlUttbagIt
WaJ9ozydJmdJ6nAHSElH7HnedYFgBXWJCxWO6U+y9gflDxRYiGB2bYhnxp14D1Gc
C+p8UmPH8sP90IEsLplT51VYYaVq0YqaF+vm7VHtcXzHFfstzWdOwGQYC2KorETo
FX1z3ZcpKTV/KEXyWYTCjbQ7zA9VLbFwi/EULQp33+Mf5PuUOgtDTH0yDHl9JTmu
wZWikC4ZbcCSCd3p0v7aa6fv+ZGweJd2+Ui1+ZbQd0X9v84xZO6FH3T+NQEJufSi
gkMfMahR
=1HXD
-----END PGP SIGNATURE-----


J
(name . ()(address . paren@disroot.org)
20221127123228.GB9060@dismail.de
On Sun, 27 Nov 2022 18:26:10 +0000 "(" <paren@disroot.org> wrote:
Toggle quote (7 lines)
> On Sun Nov 27, 2022 at 6:23 PM GMT, jgart via Guix-patches via wrote:
> > Sorry about that! I'll keep it in mind for future patch sets. I think I'll
> > just start putting stuff in alphabetical order to avoid this altogether.
>
> It doesn't mean alphabetical order by "similar names", so I'm pretty sure that
> would still be an incorrect ordering.

I was thinking strict alphabetical ordering of packages like crates-io.scm

But I realize now that a given module that is not crates-io.scm might
have packages in random order...
(
(name . jgart)(address . jgart@dismail.de)
CONAZDOPBT7P.11BSUGLD7ZLTS@guix-framework
On Sun Nov 27, 2022 at 6:32 PM GMT, jgart wrote:
Toggle quote (6 lines)
> On Sun, 27 Nov 2022 18:26:10 +0000 "(" <paren@disroot.org> wrote:
> I was thinking strict alphabetical ordering of packages like crates-io.scm
>
> But I realize now that a given module that is not crates-io.scm might
> have packages in random order...

Yup, it's only the crates-*.scm files that should be alphabetically ordered, I think.

-- (
-----BEGIN PGP SIGNATURE-----

iQGzBAABCgAdFiEE6Vh10NblKE5doNlW7ImHg/nqI20FAmODsccACgkQ7ImHg/nq
I21nkgwAiNmtz69oUNxS6qLnQ/7ac63BmDyLJ0flWyUm7h8v/htgjvgTmEkpeB6B
TQyqf4H04qKy47H6Mg/RMLTlmxDeMgstXK3R8Jj1f5roRP9vwZYBAcUAMoGe0EJV
olhxTdQM9wBl9K4+m/AQpM2XIeR5uibBAvdXwM0jWFkzMomDvkmeu6dUwOQEvNIN
K48HBQq5Be6vPbBMC7uBt0TAyz3gbDVqeJe36OJkmaUUCeVoIeTuDG+kbs/tl/8j
CpC6T9HraGxIEbNrjO2V7mvYCYQ8tIv9myuBbQ/LJKwRR2DwmnvxtWEaRMPcKtNJ
x7dhbHt+ei/aqsq1wMzxEDUU9GNKQwsPnuNVRVXiJc0TTaf9OtxGdiU1KfFzrpsB
Y9Xvq82IiD8KPZCv0Kq4NuO1+4mLPLwOmTz+19GteK1ykR647rCAAhyD0ZyEGsi1
KJ0aKEN9H+tBYV1o2HHTm2MzO2dlYozlE6mXlAl6InknPWzKyElXQrNSksYTEYdT
RW73KHmr
=3PEt
-----END PGP SIGNATURE-----


?