[PATCH 0/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.

  • Open
  • quality assurance status badge
Details
One participant
  • Adam Faiz
Owner
unassigned
Submitted by
Adam Faiz
Severity
normal
A
A
Adam Faiz wrote on 18 Nov 2022 12:44
(address . guix-patches@gnu.org)
189e5e03-ab8f-58d6-46f4-59d94b44d40a@disroot.org
From 66d7d381f376168c385b2e8808e50e3b7f8b17d7 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 19:36:24 +0800
Subject: [PATCH 0/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.

*** BLURB HERE ***

AwesomeAdam54321 (1):
gnu: Add go-github-com-makeworld-the-better-one-gemget.

gnu/packages/web.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

--
2.38.0
A
A
Adam Faiz wrote on 18 Nov 2022 12:47
[PATCH] gnu: Add go-github-com-k0kubun-go-ansi.
(address . 59356@debbugs.gnu.org)
95153042-0c17-1bdb-ae5c-863e1b181471@disroot.org
From 2a2bca6bb46620ed85f1da5b920418f935dbbd4a Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 08:58:08 +0800
Subject: [PATCH] gnu: Add go-github-com-k0kubun-go-ansi.

* gnu/packages/golang.scm (go-github-com-k0kubun-go-ansi): New variable.
---
gnu/packages/golang.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index b3df51ed5f..062af7a8e0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1193,6 +1193,28 @@ (define-public go-github-com-kataras-pio
terminals.")
(license license:bsd-3)))

+(define-public go-github-com-k0kubun-go-ansi
+ (package
+ (name "go-github-com-k0kubun-go-ansi")
+ (version "0.0.0-20180517002512-3bf9e2903213")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/k0kubun/go-ansi")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "117afax4l268rbswf02icbgxncmd1pk2abkz7cv26iyszi8l26dq"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/k0kubun/go-ansi"))
+ (home-page "https://github.com/k0kubun/go-ansi")
+ (synopsis "Windows-portable ANSI escape sequence utility for Go
language")
+ (description
+ "Go-ANSI converts ANSI escape sequences to Windows API calls on
Windows environment.")
+ (license license:expat)))
+
(define-public go-github-com-kortschak-utter
(package
(name "go-github-com-kortschak-utter")
--
2.38.0
A
A
Adam Faiz wrote on 18 Nov 2022 12:49
Re: [PATCH 2/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.
(address . 59356@debbugs.gnu.org)
ea529590-1281-b921-c478-dd1e10f5e469@disroot.org
From fa36cef177596c302a35c4a7cbad04ac26ba08c7 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 09:02:06 +0800
Subject: [PATCH] gnu: Add go-github-com-mitchellh-colorstring.

* gnu/packages/golang.scm (go-github-com-mitchellh-colorstring): New
variable.
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 062af7a8e0..71aa2ec972 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5330,6 +5330,29 @@ (define-public go-github-com-mitchellh-reflectwalk
unknown structures such as those decoded from JSON.")
(license license:expat)))

+(define-public go-github-com-mitchellh-colorstring
+ (package
+ (name "go-github-com-mitchellh-colorstring")
+ (version "0.0.0-20190213212951-d06e56a500db")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mitchellh/colorstring")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d2mi5ziszfzdgaz8dg4b6sxa63nw1jnsvffacqxky6yz9m623kn"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mitchellh/colorstring"))
+ (home-page "https://github.com/mitchellh/colorstring")
+ (synopsis "Go (golang) library for colorizing strings for terminal
output")
+ (description
+ "colorstring is a Go library for outputting colored strings to a
console
+using a simple inline syntax in your string to specify the color to
print as.")
+ (license license:expat)))
+
(define-public go-github-com-mitchellh-copystructure
(package
(name "go-github-com-mitchellh-copystructure")
--
2.38.0
A
A
Adam Faiz wrote on 18 Nov 2022 12:51
[PATCH 3/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.
(address . 59356@debbugs.gnu.org)
2a800688-110b-c905-2a9e-b882dd772987@disroot.org
From d2b2741b0b800e1371b53d0f0a72cd69a35838ab Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 09:03:42 +0800
Subject: [PATCH] gnu: Add go-github-com-schollz-progressbar.

* gnu/packages/golang.scm (go-github-com-schollz-progressbar): New variable.
---
gnu/packages/golang.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 71aa2ec972..c988b50574 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1287,6 +1287,41 @@ (define-public go-github-com-schachmat-ingo
configuration file.")
(license license:isc)))

+(define-public go-github-com-schollz-progressbar
+ (package
+ (name "go-github-com-schollz-progressbar")
+ (version "3.12.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/schollz/progressbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xf6vrrvimrhb6hrkcax0ig6f0zy3skiapxjhfqc1n0lmvbxwqyf"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:tests? #f ;TestReaderToBuffer panic: runtime error:
+ ;invalid memory address or nil pointer
dereference [recovered]
+ #:import-path "github.com/schollz/progressbar/v3"))
+ (propagated-inputs
+ (list go-golang-org-x-term
+ go-golang-org-x-sys
+ go-github-com-stretchr-testify
+ go-github-com-rivo-uniseg
+ go-github-com-mitchellh-colorstring
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-isatty
+ go-github-com-k0kubun-go-ansi
+ go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/schollz/progressbar")
+ (synopsis "Basic thread-safe progress bar for Golang applications")
+ (description
+ "schollz-progressbar provides a very simple thread-safe progress
bar which should work
+on every OS without problems.")
+ (license license:expat)))
+
(define-public go-github-com-savsgio-gotils
(let ((commit "52f3993e8d6d2629f18e7b7383b7f54a3d3f1d1f")
(revision "0"))
--
2.38.0
A
A
Adam Faiz wrote on 18 Nov 2022 12:53
(address . 59356@debbugs.gnu.org)
7701a929-6357-67e8-37c1-2f3221a56c15@disroot.org
From 55e469d785c75f85898ce2f413ff5e61b89e1354 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 09:15:48 +0800
Subject: [PATCH] gnu: Add
go-github-com-makeworld-the-better-one-go-gemini.

* gnu/packages/golang.scm
(go-github-com-makeworld-the-better-one-go-gemini): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c988b50574..97c73abd9f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8009,6 +8009,32 @@ (define-public go-gopkg-in-warnings
errors (warnings).")
(license license:bsd-2)))

+(define-public go-github-com-makeworld-the-better-one-go-gemini
+ (package
+ (name "go-github-com-makeworld-the-better-one-go-gemini")
+ (version "0.13.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/makeworld-the-better-one/go-gemini")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vywbn8sh2spqa35zpk9jkkqaipm915nfb9l1v78pjfman61m6v0"))))
+ (build-system go-build-system)
+ (inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-golang-org-x-net go-golang-org-x-text))
+ (arguments
+ (list #:import-path "github.com/makeworld-the-better-one/go-gemini"))
+ (synopsis "Client library for the Gemini protocol, in Go")
+ (description
+ "go-gemini is a library that provides an easy interface to create
clients
+that speak the Gemini protocol.")
+ (home-page "https://github.com/makeworld-the-better-one/go-gemini")
+ (license license:isc)))
+
(define-public go-github-com-go-git-gcfg
(package
(name "go-github-com-go-git-gcfg")
--
2.38.0
A
A
Adam Faiz wrote on 18 Nov 2022 12:54
Re: [PATCH 5/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.
(address . 59356@debbugs.gnu.org)
e0c9b5e4-f170-8921-f5c7-ea7bfed840e9@disroot.org
From 66d7d381f376168c385b2e8808e50e3b7f8b17d7 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 09:17:41 +0800
Subject: [PATCH] gnu: Add go-github-com-makeworld-the-better-one-gemget.

* gnu/packages/web.scm (go-github-com-makeworld-the-better-one-gemget):
New variable.
---
gnu/packages/web.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d2c406915c..b1762ee9f3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7400,6 +7400,36 @@ (define-public perl-html-tidy
in Perl but is not nearly as capable as @code{HTML::Tidy}.")
(license license:artistic2.0)))

+(define-public go-github-com-makeworld-the-better-one-gemget
+ (package
+ (name "go-github-com-makeworld-the-better-one-gemget")
+ (version "1.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/makeworld-the-better-one/gemget")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ma07wlki4pgmw19yk4dzyxa6blk8ciz3wb46ipbfz7k361lhsry"))))
+ (build-system go-build-system)
+ (inputs
+ (list go-github-com-dustin-go-humanize
+ go-github-com-spf13-pflag
+ go-github-com-makeworld-the-better-one-go-gemini
+ go-golang-org-x-net
+ go-golang-org-x-text
+ go-github-com-schollz-progressbar))
+ (arguments
+ (list #:import-path "github.com/makeworld-the-better-one/gemget"))
+ (synopsis "Command line downloader for the Gemini protocol")
+ (description
+ "Gemget is a command line downloader for the Gemini protocol.
+It works well with streams and can print headers for debugging as well.")
+ (home-page "https://github.com/makeworld-the-better-one/gemget")
+ (license license:expat)))
+
(define-public geomyidae
(package
(name "geomyidae")
--
2.38.0
?