[PATCH] gnu: Add csfml.

  • Done
  • quality assurance status badge
Details
2 participants
  • Antero Mejr
  • Ludovic Courtès
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 16 Nov 2022 17:35
(address . guix-patches@gnu.org)(name . Antero Mejr)(address . antero@mailbox.org)
20221116163501.6394-1-antero@mailbox.org
* gnu/packages/game-development.scm (csfml): New variable.
---
gnu/packages/game-development.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 90205a89ab..1252bfde26 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -735,6 +735,34 @@ (define-public sfml
of five modules: system, window, graphics, audio and network.")
(license license:zlib)))
+(define-public csfml
+ (package
+ (name "csfml")
+ (version "2.5.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SFML/CSFML")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wj1p798myyavld2xdhvvflb5h4nf1vgxxzs6nh5qad44vj9b3kb"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DCSFML_BUILD_DOC=TRUE")
+ #:tests? #f)) ;no tests
+ (native-inputs (list doxygen))
+ (inputs (list sfml))
+ (synopsis "C bindings for the SFML multimedia library")
+ (description
+ "CSFML is the official C binding to the SFML libraries. SFML provides a
+simple interface to the various computer components, to ease the development of
+games and multimedia applications. It is composed of five modules: system,
+window, graphics, audio and network.")
+ (home-page "https://www.sfml-dev.org/download/csfml/")
+ (license license:zlib)))
+
(define-public sfxr
(package
(name "sfxr")
--
2.38.1
L
L
Ludovic Courtès wrote on 4 Dec 2022 22:30
(name . Antero Mejr)(address . antero@mailbox.org)
87h6yaluvx.fsf@gnu.org
Hi,

Antero Mejr <antero@mailbox.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/game-development.scm (csfml): New variable.

Applied, thanks!
Closed
?