[PATCH] services: gitolite: Use the correct variable for the user-group

  • Done
  • quality assurance status badge
Details
2 participants
  • EuAndreh
  • Christopher Baines
Owner
unassigned
Submitted by
EuAndreh
Severity
normal
E
E
EuAndreh wrote on 12 Nov 2022 19:53
(address . guix-patches@gnu.org)(name . EuAndreh)(address . eu@euandre.org)
20221112185321.17566-1-eu@euandre.org
The default value for <gitolite-configuration> has "git" for both the
values of the user and the group, as costumary, which means that unless
someone uses a custom configuration and chooses different strings for
user and group, this wouldn't show up.

* gnu/services/version-control.scm (gitolite-accounts): Use the correct
variable for the name of a (user-group ...).
---

I did a "git grep user-group gnu/services/" and looked at the returned
entries. After a quick cursory look, either all the entries had a
hard-coded string value, or picked the correct variable for the group
name. So I think this one is a one-off :)

This surfaced after a debugging session with mirai on IRC earlier today.

gnu/services/version-control.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/services/version-control.scm b/gnu/services/version-control.scm
index b6b78e504e..86d40bdbe3 100644
--- a/gnu/services/version-control.scm
+++ b/gnu/services/version-control.scm
@@ -313,7 +313,7 @@ (define gitolite-accounts
(($ <gitolite-configuration> package user group home-directory
rc-file admin-pubkey)
;; User group and account to run Gitolite.
- (list (user-group (name user) (system? #t))
+ (list (user-group (name group) (system? #t))
(user-account
(name user)
(group group)
--
2.38.1
C
C
Christopher Baines wrote on 17 Nov 2022 13:11
(name . EuAndreh)(address . eu@euandre.org)
87wn7tdbl8.fsf@cbaines.net
EuAndreh via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (33 lines)
> The default value for <gitolite-configuration> has "git" for both the
> values of the user and the group, as costumary, which means that unless
> someone uses a custom configuration and chooses different strings for
> user and group, this wouldn't show up.
>
> * gnu/services/version-control.scm (gitolite-accounts): Use the correct
> variable for the name of a (user-group ...).
> ---
>
> I did a "git grep user-group gnu/services/" and looked at the returned
> entries. After a quick cursory look, either all the entries had a
> hard-coded string value, or picked the correct variable for the group
> name. So I think this one is a one-off :)
>
> This surfaced after a debugging session with mirai on IRC earlier today.
>
> gnu/services/version-control.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/services/version-control.scm b/gnu/services/version-control.scm
> index b6b78e504e..86d40bdbe3 100644
> --- a/gnu/services/version-control.scm
> +++ b/gnu/services/version-control.scm
> @@ -313,7 +313,7 @@ (define gitolite-accounts
> (($ <gitolite-configuration> package user group home-directory
> rc-file admin-pubkey)
> ;; User group and account to run Gitolite.
> - (list (user-group (name user) (system? #t))
> + (list (user-group (name group) (system? #t))
> (user-account
> (name user)
> (group group)

Good spot! I've pushed this to master as
35ef5fca0ac997680e47942e25f403fb3ec54c7d.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN2JRNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XefeBAAh58N+l67CovzLzNcId0oVQlPcLGo2S6c
/+IX/pHrqAEe86lrhZAsV9xsA2ee5whzECnu6BXY0/1kbu/xF5CmK/OAB1/rxqLO
eyaJ4Ux6jOeXSjhIGnTJq8vyarejR5KI9JEWmDhPCeDCJZ9xgL6ui2L5XtA+JzwM
G8B1zesN3BTaKVbHhnylFneJJhKRRoVOO3rLk6DtHMC0qynXLYGHP3DcvD9Y9S3W
kSEUUr20lG4t6XiGw5/bP06JZxqanZV5/11CeOYlE2TIw41nLiHoLem7jNeogq+F
yo7gkXSpOIBa7ns2iKigc8K+tdNN1nc48IuuByD7wJpHjXmtuZfSF89UU5TMNYY2
6vH0JDBz2nDO1872BLGFd1fd6oYgOcnb3QEhp6HTog/WCPPYpxmVb7WEM0XRgnJm
/SpWHYxrJSw7DCty18JYgwSQN6los0vwrP+vDnzAHnIj6lKuNSrLyoxcWPIPN5k0
2tz2nEIxq7yMkl1M9YEHkoL1WyDXKy+gFPpvW7TtHi+s+FTgx33dpa8bZyQ9ZY0D
EXd2iHWirHyCfNrzN0ejMwadsJ/j+bRPfjy8YD99glhBlACxEUBgdvhg5p6VyQOk
sRzs+NYFdCjKvsCiyTlQAdTA92bQyRwqDaODtK6Bf8ftG42tFhI5OL9xgQpB3JWB
Tn9+At4ocJ8=
=MClf
-----END PGP SIGNATURE-----

?