[PATCH 0/4] Update spdlog.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ludovic Courtès
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal
G
G
Greg Hogan wrote on 7 Nov 2022 20:46
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1667849907.git.code@greghogan.com
All dependent packages build except hyperledger-iroha.

Greg Hogan (4):
gnu: Add spdlog-1.10.
gnu: bear: Replace spdlog with spdlog-1.10.
gnu: spdlog: Update to 1.11.0.
gnu: waybar: Update to 0.9.15.

gnu/packages/build-tools.scm | 2 +-
gnu/packages/logging.scm | 25 ++++++++++++++++---------
gnu/packages/wm.scm | 6 +++---
3 files changed, 20 insertions(+), 13 deletions(-)

--
2.38.0
G
G
Greg Hogan wrote on 7 Nov 2022 20:47
[PATCH 1/4] gnu: Add spdlog-1.10.
(address . 59110@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
49a71f175547aa07d2257d503dc96ba1caea4e7d.1667849907.git.code@greghogan.com
* gnu/packages/logging.scm (spdlog-1.10): New variable.
---
gnu/packages/logging.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 2781ac5194..7cce8e1624 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -245,6 +245,20 @@ (define-public spdlog
;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
(license (list license:expat license:bsd-2))))
+(define-public spdlog-1.10
+ (package
+ (inherit spdlog)
+ (version "1.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gabime/spdlog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "spdlog" version))
+ (sha256
+ (base32 "02xz017ba9fssm1rp1fcfld7h79awbr6fqai9dxaqp02akp3davk"))))))
+
(define-public rsyslog
(package
(name "rsyslog")
--
2.38.0
G
G
Greg Hogan wrote on 7 Nov 2022 20:47
[PATCH 2/4] gnu: bear: Replace spdlog with spdlog-1.10.
(address . 59110@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
f92ec323ee89dc7a6e62c42611b1399ed32f3b1e.1667849907.git.code@greghogan.com
* gnu/packages/build-tools.scm (bear)[inputs]: Replace spdlog with
spdlog-1.10.
---
gnu/packages/build-tools.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 9cd11f08ea..8627f699a1 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -141,7 +141,7 @@ (define-public bear
("protobuf" ,protobuf)
("python" ,python-wrapper)
("re2" ,re2)
- ("spdlog" ,spdlog)))
+ ("spdlog" ,spdlog-1.10)))
(native-inputs
`(("abseil-cpp" ,abseil-cpp)
("googletest" ,googletest)
--
2.38.0
G
G
Greg Hogan wrote on 7 Nov 2022 20:47
[PATCH 3/4] gnu: spdlog: Update to 1.11.0.
(address . 59110@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
e7765c011eac52bab972c917a430fe5b82c4c301.1667849907.git.code@greghogan.com
* gnu/packages/logging.scm (spdlog): Update to 1.11.0.
[source]<origin>: Remove obselete snippet.
---
gnu/packages/logging.scm | 11 ++---------
1 file changed, 2 insertions(+), 9 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 7cce8e1624..58af70c7c5 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -212,7 +212,7 @@ (define-public multitail
(define-public spdlog
(package
(name "spdlog")
- (version "1.10.0")
+ (version "1.11.0")
(source
(origin
(method git-fetch)
@@ -221,14 +221,7 @@ (define-public spdlog
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "02xz017ba9fssm1rp1fcfld7h79awbr6fqai9dxaqp02akp3davk"))
- (modules '((guix build utils)))
- (snippet
- ;; Prevent race on busy hardware. Remove snippet for versions
- ;; > 1.10.0; see <https://github.com/gabime/spdlog/issues/2363>.
- '(substitute* "tests/test_misc.cpp"
- (("spdlog::details::os::sleep_for_millis\\(10\\)")
- "spdlog::details::os::sleep_for_millis(100)")))))
+ (base32 "0i3a1cqrg1sz0w50g7zz9x73rf838igqri12q8ijh4rzpq0qq3ch"))))
(build-system cmake-build-system)
;; TODO run benchmark. Currently not possible, as adding
;; (gnu packages benchmark) forms a dependency cycle
--
2.38.0
G
G
Greg Hogan wrote on 7 Nov 2022 20:47
[PATCH 4/4] gnu: waybar: Update to 0.9.15.
(address . 59110@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
36317f1e3036e90a5f1a07916de63ff671141aa0.1667849907.git.code@greghogan.com
* gnu/packages/wm.scm (waybar): Update to 0.9.15.
[inputs]: Replace fmt-8 with fmt.
---
gnu/packages/wm.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 54e1c9c016..78aa79a05d 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1722,7 +1722,7 @@ (define-public swaybg
(define-public waybar
(package
(name "waybar")
- (version "0.9.13")
+ (version "0.9.15")
(source
(origin
(method git-fetch)
@@ -1731,10 +1731,10 @@ (define-public waybar
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "15fy21cipih80amv78g7g4k2gylf107phbv0fjacn3w3n0i3cf2k"))))
+ (base32 "0mvwsd3krrlniga0fq13b0qvsf1fj22mk9nzsfgz49r55lqw8sdv"))))
(build-system meson-build-system)
(inputs (list date
- fmt-8
+ fmt
gtk-layer-shell
gtkmm-3
jsoncpp
--
2.38.0
L
L
Ludovic Courtès wrote on 11 Nov 2022 23:17
Re: bug#59110: [PATCH 0/4] Update spdlog.
(name . Greg Hogan)(address . code@greghogan.com)(address . 59110-done@debbugs.gnu.org)
871qq9dtlc.fsf@gnu.org
Hi,

Greg Hogan <code@greghogan.com> skribis:

Toggle quote (5 lines)
> gnu: Add spdlog-1.10.
> gnu: bear: Replace spdlog with spdlog-1.10.
> gnu: spdlog: Update to 1.11.0.
> gnu: waybar: Update to 0.9.15.

Applied, thanks!

Ludo’.
Closed
?